Skip navigation

I can't download updates

282 Views 3 Replies Latest reply: Sep 4, 2012 3:45 PM by Andrageb RSS
DaQueen713 Calculating status...
Currently Being Moderated
Jun 20, 2012 4:29 PM

Why can't I update my apps?

  • stevejobsfan0123 Level 7 Level 7 (30,500 points)
    Currently Being Moderated
    Jun 20, 2012 4:31 PM (in response to DaQueen713)

    DaQueen713 wrote:

     

    Why can't I update my apps?

    I don't know - you tell us. Do you get an error message? Have you tried any troubleshooting steps yet?

  • Demo Level 9 Level 9 (73,845 points)
    Currently Being Moderated
    Jun 20, 2012 4:37 PM (in response to DaQueen713)

    I do agree with sjf0123 - more information would certainly be helpful. But here are my standard - "try these and see what happens" suggestions.

     

    Make sure that you do not have a stalled download in iTunes - a song or podcast .... if you have a download in there that did not finish, complete that one first. Only one thing can download at a time on the iPad so that could be what is causing the problem.

     

    If that doesn't work - sign out of your account, restart the iPad and then sign in again.

     

    Settings>Store>Apple ID. Tap your ID and sign out. Restart the iPad by holding down on the sleep button until the red slider appears and then slide to shut off. To power up hold the sleep button until the Apple logo appears and let go of the button.

     

    Go back to Settings>Store>Sign in and then try to update again. Tap one waiting icon only if necessary to start the download stream.

     

    You can also try deleting the waiting icons - tap and hold down on an icon until it wiggles - the tap the X on the icon to delete it. Then try to download again.

     

    You can try resetting all settings. Settings>General>Reset>Reset All Settings. You will have to enter all of your app preferences and device settings again.

  • Andrageb Calculating status...
    Currently Being Moderated
    Sep 4, 2012 3:45 PM (in response to Demo)

    Just try setting date to sometime in future. And retry connecting to Store. Weird but works.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.