Skip navigation
This discussion is archived

apple software update in windows help!!!!

18820 Views 43 Replies Latest reply: Oct 8, 2012 9:09 PM by SombraGuerrero RSS
1 2 3 Previous Next
ClearNexus Level 1 Level 1 (55 points)
Currently Being Moderated
Jun 19, 2012 6:07 AM

apple software update in windows, loads and opens, has a good internet connection, but when it trys to check for an update the looking for update bar appears doesent check. Then it closes the update bar,and shows no updates like to install safari i know this because since i started using apple software update over 2 years ago it has shown this.

 

my issue is similar to that of lkadlec he wrote the question below the only difference my software doesnt say new updates are available and my issue started 4 days from 6/9/12

##

Software Update not showing available updates (but says new software is available)

apple software update in windows
  • b noir Level 9 Level 9 (71,990 points)
    Currently Being Moderated
    Jun 19, 2012 8:50 PM (in response to ClearNexus)

    Yeah, there's been a sudden burst of reports of this. It's not clear what might be causing it yet (to me, at least).

     

    Folks with it can update to newer versions of their software using installers downloaded from the Apple Website:

     

    http://www.apple.com/itunes/download/

    http://www.apple.com/quicktime/download/

    http://www.apple.com/safari/download/

     

    If you're interested in doing some basic principles troubleshooting, would you mind checking something for me? (No guarantees that we'd get anywhere, I'm afraid.)

     

    If you're game, could you download and AutoRuns and check to see if there's any LSPs (other than the Bonjour ones) appearing in the Winsock providers tab in Autoruns? Instructions in the following Apple KnowledgeBase document:

     

    Apple software on Windows: May see performance issues and blank iTunes Store

     

    (LSP-trouble symptoms are pretty multifarious, and not all of them are officially documented, hence the interest in checking to see if there might be a LSP issue afoot here.)

  • Micah Hunter Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 20, 2012 11:50 AM (in response to ClearNexus)

    I am also seeing this issue across varius machines running windows, apple hardare or not. It is kind of frustrating because I am trying to get some machines up to date. I am now left to downloading each update and then installing them one by one.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 20, 2012 3:18 PM (in response to b noir)

    I , as well as many, many , many others are having this exact same issue. you can check here:

     

    https://discussions.apple.com/thread/4038569?start=0&tstart=0

     

    and there are a few hundred other threads discussing the same issue in one way or another. As of yet, Apple has made no official comment of why this is occurring or when it wil be resolved; but I think it's safe to say that it IS a problem from their end - lets face it, all of us didn't just mysteriously happen to have our Apple Software Update utility go dead at the exact same time. I'm sure it must have something to do with the new rollout of itunes 10.6.3(which is the 1st itunes to allow iOS 6 to be downloaded through it). itunes 10.6.3 is also a fairly hefty update that adds a 2 new programs(Apple Application Support & Apple Mobile Device Support) that I've never seen in my list of Programs & Features before. I'm sure they'll smooth it out in time. I just wish they wouldn't be so tight lipped about the whole affair.

     

    P.S. I also did AutoRuns and the only other LSP running under WinSock is my ESET antivirus/antispyware and that has been there for 2 years with no problems(I'm sure it's not the issue). I've tried every conceivable suggestion that I've seen mentioned on the forums and elsewhere.  I also have seen the EXACT same problem now on THREE seperate machines(one running Win 7 64bit; one running Win Vista 32 bit and one running Win 7 32 bit) at 2 seperate locations. At this point, I think it's completely safe to say that it is an issue that has it's origin at Apple's end.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 20, 2012 10:14 PM (in response to ClearNexus)

    I FIXED IT!! I can't believe it . I actually figured out how to make it work(well sort of). My Apple Software Updater now works (almost) perfectly and I just successfully downloaded and installed itunes 10.6.3.25 through it!!!

     

    Ok , the way I see it, either the latest itunes update or the recent Windows Patch Tuesday on June 12th, 2012 must have inadvertently removed the Administrative Rights from the Apple Software Update Tool .lnk file.

     

    So you must go to where the file resides on your hard drive - for me that was C:\Program Data\Microsoft\Windows\Start Menu\Programs - Right click on the Apple software Tool icon and choose properties. Click on the compatibility tab. At the bottom of this tab click on "change settings for all users" and hit Yes at the UAC pop-up. Now make sure you place a check in the "Run this program as Administrator" under the Privilege level section at the bottom. Hit Apply and then OK. The hit Ok again to get off the properties pop-up.

     

    When I went back and clicked on the Apple Software Update shortcut, I got a UAC pop-up asking me if I wanted to proceed(something I had always, in the past, gotten but haven't since this problem started). The Apple Software Update tool came up and to my suprise the progress bar STAYED and started to slowly fill up partially with the green progress bar. Viola, the itunes 10.6.3 update showed up on the top part of the screen as a new update needing to be installed - the bottom screen, as usual, had the changelog info for the 10.6.3 update. I clicked on install and , again, Viola. the update downloaded and installed flawlessly. I had to reboot my computer and when it restarted, itunes was working perfectly and it was correctly showing as itunes v10.6.3.25.

     

    I say it is almost or sort of fixed because when you click on the Apple Software Update shortcut after the 10.6.3 install it goes back to doing the same thing it did before(i.e. processing for a second and then saying there are new updates but showing a blank field). Maybe this is the way the software now looks if there are no updates available to install - maybe Apple is working on this to eventually get it back to normal. All I know is the process I outlined above worked for me(at least to get the ASU to recognize and properly download and install itunes 10.6.3). It's certainly not perfect, but it worked. Please try this method and let me know what results you have with it. Good luck.

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 21, 2012 11:39 AM (in response to ClearNexus)

    Yeah, I agree. It's definitely still broken from Apple's end. But at least most of the feedback I've seen from the method I posted last night is positive in the sense that people are at least able to get the newest iTunes update. Hopefully Apple will completely fix the issue within a few days and get this ASU issue straight. I've posted the instructions on every thread I can think of relating to this topic. Most people say they can get and install the iTunes update but the ASU goes right back to the "dead" state it was in prior.

  • b noir Level 9 Level 9 (71,990 points)
    Currently Being Moderated
    Jun 21, 2012 7:34 PM (in response to markarich159)

    Many thanks for the report, markarich!

     

    Trialling a slight variation on your instructions over in the following post:

     

    Re: iTunes says there is an update 10.6.3 but when I click to update nothing happens?

     

    (Effectively I'm doing a "one-time" Run as Administrator, whereas your technique runs ASU as an administrator at every launch.)

  • markarich159 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 21, 2012 8:01 PM (in response to b noir)

    Hi b Noir;

      I've seen your many helpful posts on this issue in several other threads and must give you a huge collective thanks for your selflessness in attempting to address & assist the plethora of users having this ASU problem.  The reason I chose to raise the ASU.lnk file to administrative privilege rather than the SoftwareUpdate.exe file was that(at least on my system) the "Run as Administrator" tick box was alrady checked under the properties/compatibility tab for the SoftwareUpdate.exe file. Right clicking on the software update.exe file and choosing run as administrator was not successful.  This is what gave me the initial idea to look at the shortcut (ASU.lnk) file and raise that to administrative privilege. You would think that since the SU.exe file has administrative privilege already, and the ASU.lnk shotrtcut simply points to the SU.exe file; none of this would be necessary anyway. This whole situation has me completely baffled and, again, at this point I can only surmise the issue lies at Apple's end. Thanks again for your help and your willingness to provide assistance throughout this forum.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.