Skip navigation

logic exs inst not found?

592 Views 4 Replies Latest reply: Aug 12, 2012 5:27 AM by Prince Moe RSS
Prince Moe Calculating status...
Currently Being Moderated
Jun 21, 2012 12:31 PM

Hey I have Logic 9.1.7 and it seems some exs inst. do not load because they are missing some files. The question is how do I find which instruments are affected, plus how do I fix this? Do I have to re-install?

 

It seems to only be the issue with the EXS.

 

Here's a screen shot.

 

Thanx.

 

MOEScreen Shot 2012-05-31 at 9.41.17 PM.jpg

  • GUSTO.K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 8:36 PM (in response to Prince Moe)

    Hi Moe,

     

         This issue has me baffled!.... No one seems to know the answer!...

     

    I get the same thing and some of my EXS Intrument Samples in my Logic Library:

     

    Screen shot 2012-08-04 at 1.10.30 PM.png

     

    Then, I look for the file in Finder and the sample exists:

     

    Screen shot 2012-08-04 at 1.09.19 PM.png

     

    Im no computer expert and I don't know how to link the 2 together :-(

     

    If often thought I may have something to do with the 9.1.7 update or:

     

    I've tried "MacKeeper" in the past to clean up my drive and my Logic Studio App's freaked out. I remember i had to re-install the updates for both Mainstage and Logic after a system clean. I read somewhere that the EXS sampler relies on 'file paths' to find it's samples, i've often wondered whether Mackeeper wiped them out and I somehow have to re-connect the samples with the sampler if you know what I mean.

     

    Anyways, I could be way off the mark but it's a common problem and your not alone. I havn't tried a re-install yet, Im still hoping there's a simple solution.

     

    Good Luck.

  • GUSTO.K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 4:59 AM (in response to GUSTO.K)

    Hi again,

     

         I thought it may be of some intrest to also mention that I tried to open my EXS sample straight from Finder. The sample is 'checked' to open in Mainstage and this is what popped up:

     

    Screen shot 2012-08-04 at 9.11.34 PM.png

     

    I found it interesting that Mainstage says the sample is corrupted. So, I went into the EXS sampler itself from Logic and found you can access all the instrument '.exs' files via the 'edit' button to the right of the preset pane. You open the sample via the 'instrument' button at the top of the edit window.

     

    Screen shot 2012-08-04 at 9.05.12 PM.png

     

    What's happening is, EXS is identifying the sample and wants to play it, but in my case, the '.aif not found' file, although very small, is missing and corrupting the sample. I guess it's like trying to start your car with a faulty spark plug, it's very small, but it's crucial and the car wont start without it. I continued to proceed in the EXS editor and got this:

     

    Screen shot 2012-08-04 at 9.06.06 PM.png

     

    In the 'Audio File' column, are all the '.aif' files that seem to represtent the 'pitch' of the MIDI events that occur in a recorded MIDI region. So, my '.aif not found' file one could argue, is actually a missing 'note' within my 'Dobro Slide' sample. If you notice the grey, rectangular shapes above the piano keys at the bottom of the pic. There is a square chunk missing on the left side, I have a feeling that's the missing piece of my sample, deeming it 'corrupted'.

     

    I have noticed your's is a '.wav' file that is missing, but, at a guess, I think we have the same issue. I think a re-install of all samples are the only option.

     

    All the best.

  • GUSTO.K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 10:31 PM (in response to GUSTO.K)

    Hey,

     

    I found this thread:

     

    http://www.logicprohelp.com/forum/viewtopic.php?t=55440

     

    It solved the problem, the App 'PACIFIST' highlighted to me that my issue was with the original install from the discs at the begining. I think the 'Jampack Content 2' disk has a bug. It seems to install the intstument files but forgets to install some of their coresponding sample folders that harbour the .aiff/.wav files needed for them to play in EXS.

     

    Sorry about my last 2 posts, like i said, im no expert but it led me to a solution. Although I had a few instruments missing, the intrument i used in my screenshots was my 'Dobro', here's a pic showing that all the relative files are now on my HardDrive (along with the others).

     

    Screen shot 2012-08-12 at 3.28.36 PM.png

     

    Thankyou PACIFIER, great App, highly recommended.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.