Skip navigation

iPhoto won't work

535 Views 12 Replies Latest reply: Jun 26, 2012 3:16 PM by Terence Devlin RSS
matkins65 Calculating status...
Currently Being Moderated
Jun 20, 2012 7:41 PM

A couple of days ago I attempted to install the latest updates after opening iPhoto and getting the "updates available" message. Well, the update froze midstream and I had to force quit. I attempted a few more times only to encounter the same problem. I tried to delete recently added files in hopes of correcting the problem, but then the app wouldn't open at all. I took my MacBook Pro to the nearest Apple store where the tech first attempted a rebuild. That didn't work so he deleted the "receipts" and attempted to reinstall iLife. No luck. He tried again and still no positive results. When I click on the icon a message pops up that the latest updates need to be installed. As always, all of my updates are up-to-date. The tech said my next step would be to wipe my hard drive and reinstall EVERYTHING from scratch. I'd rather NOT do that if I can avoid it.

 

Anyone have any other suggestions or bright ideas?

MacBook Pro (17-inch 2.4 GHz), Mac OS X (10.7.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.