Skip navigation

Purchased iPad 2 Apps Not Appearing On App Store "Purchased" Tab

64449 Views 156 Replies Latest reply: Apr 5, 2014 12:39 AM by aldearle RSS
1 2 3 ... 11 Previous Next
TiffWagg Calculating status...
Currently Being Moderated
Jun 22, 2012 8:19 AM

This is quite a major issue in the sense that ALL my previously purchased apps no longer show in the "purchased" tab on the App Store. This problem also applies to my phone. Someone else asked this question and got a really inane answer from someone who said "they will come back".... when? They should never have disappeared in the first place. I've had friends open their app store and it shows their previously purchased but no longer installed apps no problem. What am I missing here? Is it down to a setting as to why they are no longer showing? Something to do with iTunes or iCloud?


This issue is really starting to irk me because some apps I had deleted from my iPad I wanted to re download again. These apps were PAID for. I searched for these apps in the app store and it didn't say "Install" anymore like they usually do when i had paid for it before, it was asking me to pay.... AGAIN.


Since when has it been a case of when you pay, and delete you the pay again?


My purchased tab is empty. It doesn't show a single app. It says "All of your available apps have been downloaded to this device" same goes for my iPhone. This ins't the case AT ALL. I've got only a quarter of apps I paid for actaully installed on my devices.


Can anyone suggest what the issue may be? A resolution? Suggestion?

iPad 2, iOS 5.0.1
  • Demo Level 9 Level 9 (73,680 points)

    Are you sure that they are not hidden? If they are hidden, they will not show up as purchased.


    Unhide Purchases on iPad


    Depending on the content type, open the App Store, iBooks, or iTunes Store on your device.

    Scroll to the bottom of the main page.

    If you're not already signed in, tap Sign In.

    Tap your Apple ID name, then tap View Account.

    Scroll down on the Account pane, and tap Hidden Purchases.

    Locate the item you would like to unhide then tap the Unhide button.

  • Demo Level 9 Level 9 (73,680 points)

    Frankly, I am mystified as to why this is happening. If you had used a different ID to purchase the apps that would explain it, but if you had used another ID - you wouldn't be able to access the Purchased Tab of that ID.


    Have you quit the app store completely and rebooted the iPad? Another thought regarding downloading again, you could choose one inexpensive app, try to download it again - and see if the Buy button doesn't turn into the Install button. You still have to enter your password before you buy the app.

  • Alix Leigh Level 1 Level 1 (135 points)

    Demo's idea sounds like a good way to make sure your iPad is definitely linked properly to iTunes store.


    Nonetheless: If you just recently switched to iCloud you should re-check your iTunes store Account info

    sign out then (REENTER both your iTunes Store Apple ID and password).


    Lastly: here's a link to a thread that might solve your problem, involving parental controls:


    Good luck. If all else fails contacting apple, is likely the quickest. and certainly surest way to resolve this.

  • Demo Level 9 Level 9 (73,680 points)

    You are probably at the point where you should seek assistance rom iTunes support. It certainly can't hurt.

  • pearlcific Calculating status...

    I just discovered I have the same problem. I'm using a 3rd generation iPad and previously had no problems accessing all my purchased apps on the iPad app store. However today I realised that apps I'd previously downloaded no longer said "install", and when I checked, the "purchased" tab was completely empty!


    This isn't the case with my iPhone 4S though. That seems to work fine. Any ideas how to fix it? Did you write to Apple? What did they say?

  • bedardjr8 Level 1 Level 1 (95 points)

    I had this problem previously and the only thing I could figure out was that there was potentially an update going on with Apple since all my apps suddenly came back in a day or two. 


    This is only speculation, but there's been rumors going around on changes in iTunes, so there may be a connection.  Again, that's only speculation.  So, I'd either contact support as Demo mentioned or try again later in the day.  On a side note I never signed out and back into my account when this happened to me.  It just cleared up on its own. 

  • pearlcific Level 1 Level 1 (0 points)

    Thanks for the reply. For some reason I just checked it again and everything is back to normal. I didn't have to sign out and in again at all. My downtime wasn't as long as yours though, and only lasted a couple hours or so. Probably some temporary system downtime or something. Glad it's working now anyway. Cheers everyone!

  • Tommy Kim Calculating status...

    This happened me too, and i didn't do anything like updating my ios or changing my apple id or anything.

  • AlbionEikon Calculating status...

    I am experiencing this problem right now on my iPad2. I have a purchased App that I want to reset (uninstall and reinstall) but I don't want to pay for it twice. I have tried following the steps to "Unhide" any Apps which were hidden (I have not hidden *ANY* of them, but they are not displaying).


    When I navigate to my Apple ID, there is no "View Account" link, button, or anything like that. Therefore, I cannot get to the point of Unhiding Apps.


    P.s. I have logged out of my account and back in again. No change.


    Real. Pain. /grumble

  • Peaceful_Hope Calculating status...

    I have the same problem too.  Yesterday all my purchases were showing correctly in the "purchased" list on my iPad (a new iPad only 3 weeks old).  This evening I went to check something on the list and found that the list just wasn't there.  I tried a few things including rebooting the iPad, but nothing made a difference.  Then, by accident I found that if I clicked on where they should be I could open up the page for each app which I could not see!  So the link to the app is there, but the icons have vanished . 


    What is going on?

1 2 3 ... 11 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (10)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.