Skip navigation

Retina MacBook Pro Trackpad in Windows 8

56391 Views 30 Replies Latest reply: Dec 15, 2013 12:16 PM by mauonline RSS
1 2 3 Previous Next
designerdougm Calculating status...
Currently Being Moderated
Jun 22, 2012 2:48 AM

Hello, and apologies if this has been answered anywhere, I've been digging for hours and to no avail.

 

I just recently picked up the new Retina MacBook Pro, and I'm having issues with the trackpad in boot camped Windows 8. For reference, the trackpad worked fine in Windows 7, and I used the same Windows Support drivers that Boot Camp downloaded for both Windows 7 and Windows 8.

 

The issue manifests itself as such:

  • Windows receives no input from Trackpad at all
  • 2 "Touchpads" appear in Device Manager in Windows 8
  • Both touchpads have yellow yield sign indicating on further inspection "driver installed improperly"

 

So far I've tried the following:

  • Uninstall and re-scan for devices
  • Reinstall by running repair with boot camp utility
  • Older versions of the driver in boot camp
  • Running the individual boot camp driver directly (results in "you need to run 64 bit version of DPInst.exe"
  • Extracting boot camp driver archive, replacing DPInst.exe with a 64 bit version, running DPInst.exe as well as re-archiving and running the driver
  • Checking online for additional drivers, including Microsoft's auto-check functionality

 

Each of these methods have resulted in the same thing, 2 touchpads appearing with "incorrectly installed drivers." I'm at a total loss, if anyone has had any success conquering this issue, or if you've simply been able to use your Trackpad on your RMBP, please share your steps!

 

Cheers.

MacBook Pro with Retina display, Other OS, Trackpad Driver with Windows 8
  • Csound1 Level 7 Level 7 (32,390 points)
    Currently Being Moderated
    Jun 22, 2012 1:36 PM (in response to designerdougm)

    designerdougm wrote:

     

    As a small update, I have also tried manually removing and re-installing, as well as replacing the drivers in System32 folder, still no dice on the trackpad working. A bit frustrating as the Windows side of my machine is basically a brick when I'm not hauling a mouse around.

    When Windows 8 is released, and assuming that Apple support it there will be drivers, at this stage, with an unreleased OS and a laptop only days after release I suspect that you will be working on this with little to go on.

  • Csound1 Level 7 Level 7 (32,390 points)
    Currently Being Moderated
    Jun 22, 2012 3:01 PM (in response to designerdougm)

    designerdougm wrote:

     

    Of course, however, I have seen numerous videos and product reviews showing off Windows 8 on the RMBP, so obviously there are at least a handful of people who have had success, just hoping to bump into one!

    I hope that happens before MS release 8,

  • gol10dr Calculating status...
    Currently Being Moderated
    Aug 18, 2012 10:40 AM (in response to designerdougm)

    I installed Windows 8 RTM and everything works great except the trackpad.  I tried most of the list as you did.  What did give me some functionality is to update the driver in the device manager, pick my own and select the USB Input device.  I did this with both trackpad unknown devices and I now can use it.  I dont have options in the Bootcamp assistant driver so two finger scroll and tap to click doesn't work but I it is usable.  I hope they update the drivers soon.

  • The hatter Level 9 Level 9 (58,595 points)
    Currently Being Moderated
    Aug 18, 2012 11:27 AM (in response to gol10dr)

    To make the trackpad work. You need to install trackpad++

    (http://www.techspot.com/downloads/4967-trackpad-control-module.html), it will enable the trackpad driver on boot camp. After you install the trackpad++, trackpad++ will complain something. ingnore it.  You should be able to enable trackpad. And you can now even uninstall the  trackpad++, the trackpad will sill work.

     

    brightness, what graphics card are you using? It might be due to the auto adjusting brightness running there. You can go to your power options, edit the one you are using  (Change plan settings >> Change advanced power settings) and look for Batteries >> Enable adaptive brightness and disable the one you are using. After that, the scrollbar for adjusting brightness in power options should work again.

     

    bluetooth connection is incredibly unreliable/intermittent when in Windows (I run Windows 7 64-bit and Boot Camp 4.0, and got both devices connected without any trouble via Bluetooth).

    https://discussions.apple.com/thread/4079148

    After much testing, I have found the cause of lagging/jumpiness on the Bluetooth Magic Mouse and Magic TrackPad in Boot Camp. Hopefully this will help others:

    The drivers for the Broadcom 802.11n Wireless Adapter have a setting called "Bluetooth Collaboration" that is Disabled by default. Enabling this option removes the problem instantly. My Magic Trackpad now works flawlessly, even if I stand 6 metres from the machine. It now works just as well as under Mac OS. The setting can be found under:


    Control Panel > Device Manager > Network Adapters > Broadcom 802.11n Network Adapter (right click and choose "Properties".

    Under the "Advanced" tab, highlight the setting named "Bluetooth Collaboration", then change it to Enable. Then click OK.


    I narrowed the problem down to the wireless card by disabling ALL startup services and processes for Windows, then re-enabling one by one.

    As soon as I enabled the Windows Wireless Service, the problem came back.


    Similarly, disabling the Wireless Card inside the Network and Sharing Center (or Device Manager) removes the problem.


    This led me to believe it must be a driver issue with the wireless card, since the problem didn't occur with the Magic TrackPad under Mac OS, or on my mother's Windows 7 64-bit computer.


    So when I went into the Driver Properties to check for an update, I found this setting about Bluetooth Collaboration.

    All Apple notebooks use the Broadcom card (and have done for years), so this driver is installed for almost anybody using Boot Camp on an Apple notebook. I'd assume this problem would affect anybody using Boot Camp + wifi + a Bluetooth device.


    Wireless Connection problem using windows in a Mac.

     

    Mac Pro, Windows 8 Preview x64 3.2GHz
  • gol10dr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2012 12:16 PM (in response to The hatter)

    I looked at that but it says it is not supported on 8 yet. Do you need power plan too? Have you installed it yet on a mid 2012 mbp too?

  • gol10dr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2012 1:07 PM (in response to The hatter)

    I just tested Trackpad++ and it pops up a message that it is not supported.  Like I said, if you simply pick the generic USB input device, the track pad is works and so does click but there are no multi-touch gestures, two finger scroll or tap to click.

     

    So I uninstalled, wheent back to the device manager, clicked on my generic USB input and picked the Apple Multitouch, which used to fail and now it works.  All is good.  I do still have to use the notepad trick to laucn the bootcamp assistant tho.  AWESOME!

     

    http://apple.stackexchange.com/questions/59048/macbook-pro-retina-and-windows-8

  • irishnz Calculating status...
    Currently Being Moderated
    Aug 19, 2012 7:27 PM (in response to designerdougm)

    Hi All,

    First time poster :-)

    I tried all of the above without success, and after a bit off trial and error, this worked for me.

    I removed trackpad from device manager, Apple software update and bootcamp from add remove programs, restarted in safemode and removed all registry entries (after reg backup) for trackpad, multitouch, multitouchmouse and trackpad++, when I restarted trackpad was working, then I reinstalled bootcamp.

     

    This was from a windows 7 upgrade to windows 8

     

    :-)

  • V-l-a-d-i-m-i-r Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 20, 2012 12:40 AM (in response to The hatter)

    IMPORTANT: THE CURRENT VERSION OF THE TRACKPAD++ DRIVER IS FOR WINDOWS 7 64-BIT/32-BIT ONLY. DO NOT INSTALL IT IN WINDOWS 8 UNTIL IT IS OFFICIALLY SUPPORTED.

  • somerandomguy21 Calculating status...
    Currently Being Moderated
    Aug 20, 2012 2:35 PM (in response to designerdougm)

    Here's what I was able to do to fix this problem on my MBP (not a retina, but same symptoms). I went into Device Manager and on the two "Touchpad" entries with the bang on them, went to "Update Driver" -> "Browse My Computer" -> "Let me pick from a list..." and changed them both to USB Input Device. Reboot.

     

    Go back to Device Manager, do an "Update Driver" again, let it search automatically, and one comes back as Apple Multitouch and the other as Apple Multitouch Mouse. Rebooted again, trackpad working and shows up in Boot Camp control panel.

  • michaelrau Calculating status...
    Currently Being Moderated
    Aug 22, 2012 2:12 PM (in response to somerandomguy21)

    You rock somerandomguy21, this fixed my new AIR.

  • The hatter Level 9 Level 9 (58,595 points)
    Currently Being Moderated
    Aug 22, 2012 2:25 PM (in response to V-l-a-d-i-m-i-r)

    Your caps to yell a suggestion when others have working ideas and solutions...

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.