Skip navigation

No sound coming from my iPhone 4s.

579585 Views 219 Replies Latest reply: Apr 2, 2014 4:36 PM by koreabella80 RSS Branched to a new discussion.
  • AzzyJ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2012 9:26 PM (in response to szayat)

    hi

     

    the problem seems to be with the dock connector.

     

    have a look here: http://www.ifixit.com/Answers/View/68836/Volume+bar+has+disappeared+-+No+sound+i n+apps

     

    seems cleaning it worked for a lot of people. unfortunately it hasnt worked for me, I am beginning to think that my dock connector is damaged.

     

    hope that helps.

  • herrjoel Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 11, 2012 10:52 AM (in response to szayat)

    Update:

    I had exactly the same issue and my iphone 4S was just updated to 5.1.1 and it still doesn't work so it

    s obviously a hardware issue.

    the guys at the local apple store said they never heard of the problem, so I'm thinking they have a sound issue themselves:0

    I tried all the fixes mentioned here and none of them worked so I'm having mine replaced.

  • BGowdey Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2012 1:52 PM (in response to szayat)

    My problem was a bit different.  When I plugged my iPhone into the power socket in my car or my pc at work the phone would only vibrate. The + - volume buttons, when pressed, only showed a speaker icon, no line of blocks noting sound level. When I went into sounds and tried to play a sound the phone only vibrated.  When I unplugged it from the charging cord it worked fine.  The cord was the common hardware.  No problems when I tested it with a Kensington cable.

     

    Found out it was the cheap Macally charging pack that my company had purchased.  Purchased a nice kensington cable and the phone hasn't had a problem since.

  • MsRoyalHotness Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 28, 2012 11:57 PM (in response to ScopiJohnson)

    This worked for me!!! Thank you! I've tried the hard reset, The itunes restore none worked! Yeah I think it has something to do with the connector.

  • EoinSully2012 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2012 1:07 PM (in response to szayat)

    I have had this problem also. Sounds would not play on youtube etc. I checked the sound settings and also made sure that the device wasn't on mute. I also made sure there were no obstructions to the docking port or earphone jack. Eventually I traced the problem to a recently installed app in which the sound had been muted, effectively muting all sounds on the iPhone. Unmuting this solved the problem.

  • PCsSuck Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 6, 2012 4:06 PM (in response to szayat)

    I was/am also having this issue. Somewhere in here, someone suggested blowing air into the dock connector. I did this, and my volume slider and sound came back. This phone replaced a phone that had been damaged by water. I checked for the liquid indicator once I started having the issues with the internal speakers (same issue as most... no volume slider, phone seemed to think it was always connected to a dock, no sound from speakers) To locate the indicator, look here iPhone and iPod: Liquid damage is not covered by warranty

    My indicator was not tripped. That was two weeks ago. I have been having OK luck with the air, but was sick of not having sound when I wanted it. Now, I will explain why I brought up the indicator.

    I took it to the genius bar today to have it replaced. They checked the device, and the indicator was tripped (probably from the condensation from the canned air) Well, this immediately voids the warranty. No ifs, ands or buts. I was ******. They took it in the back and could not find a single sign of damage or moisture, but still told me I would have to pay $199 for a replacement because the liquid indicator was tripped. I spoke to a senior manager, and he was just as useless as the tech.

    Called Apple Care (without paying because I checked the box for an exception) 30 minutes with a support guy and 35 minutes with the lead supervisor. Again, nothing they can or will do with the indicator tripped.

    So, to make a long story a little longer, check your indicator. If it is activated, you're screwed. If not, take it immediately to a Genius Bar and have them replace your phone. DO NOT BLOW AIR IN IT or, as one person suggested, USE ALCOHOL ON THE DOCK CONNECTOR (this will definitely trip the indicator.) Hope this helps some of you, and you are able to get new phones.

    I believe it is a dock connector/hardware issue and not an iOS issue (even though I am hoping for the latter)

    Good Luck.

  • smoltzfan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 22, 2012 12:14 PM (in response to szayat)

    I am new to Apple products and have only owned my iPhone less than two weeks. I too downloaded the update 5.0.1 and have had no sounds since.  I scoured all the responses on here and found one I actually understood and thought I could do...which was check the toggle switch above the volume buttons...if you see orange then everything is muted.  Mine was orange.  I toggled it back and all my sounds are back.  Not sure how mine got switched since I have an Otter Box case on it and the toggle switch is completely covered.  I hope this will help some of you.  I am certainly relieved it fixed my problem.  Was beginning to doubt my very expensive purchase.

  • Qsalman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 22, 2012 6:08 PM (in response to smoltzfan)

    I had the same problem and came here to try to look for a solution. As I looked on I saw nothing to help. Everyone said get it replaced. So I had a crazy idea. It obviously wouldn't work so I went what the heck, I'll do it. Apparently random button pushing helps, luckily I remembered my randomness. Worked for me so lets hope it works for you. So heres what to do:

    1.) Go to the lock screen(don't type your password in if you have one).

    2.) Press both sound buttons(the plus and minus).

    3.) Try to press the main circle button thing.(Do it)

    4.) Simply slide to unlock.

    At least I think that's what I did. After all it was random. Just try it. I do remember though. Lock screen, don't go on the password screen. Use the screen that says "Slide to Unlock".

  • kateym71 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 3:56 PM (in response to amemusjj)

    Thanks very much!  This is what was wrong for me.  I think this should be on the list of things to consider before contacting Apple or whatever.  Other people  should not disregard this tip!!!

  • kateym71 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 3:58 PM (in response to russellfromlongmont)

    amemusjj's post worked for me. There are people who read these posts who may not be aware of the mute button.

  • malhar87 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 8, 2012 9:42 PM (in response to szayat)

    I have iPhone 4 with 5.1.1 OS. Suddenly I'm facing strange issue with my speaker. If I let the phone in stand by for 3-4 hours and then use it, speaker works fine for sometime, but if I use it for some time(5-10 mins) talk on speaker phone or it rings because some one is calling on my number, speaker suddenly stops and no output. Headphone works fine. I can't seem to identify issue.

  • LFortune Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 16, 2012 1:54 PM (in response to Kmedina10)

    Hey i was wondering if you had to have an active warranty in order to have your iphone replaced because of this problem?

  • Moneyzoom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2012 7:37 PM (in response to szayat)

    DIRECTIONS FOR THIS FIX:

     

    1) Jailbreak the iPhone (use Redsn0w for iPhone 3G, 3GS & 4 and iPad 1; use Absinthe for the iPhone 4S and iPad 2). For iOS 5.1 a tethered jailbreak is currently only available but that's good enough to perform this fix.

     

    2) Download and install 'iExplorer' (link below). It's available for both Mac and PC

     

    http://www.macroplant.com/iexplorer/

     

    3) Connect iPhone to your PC/Mac and run iExplorer

     

    4) Within iExplorer, on the left column navigate to System / Library / LaunchDaemons

     

    5) Within the right column find 'com.apple.iapd.plist', right click then select delete

     

    6) Close iExplorer and reboot the iPhone

     

    7) Enjoy sounds again on your iPhone!

  • PCsSuck Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2012 7:56 PM (in response to szayat)

    I put in detail what you need to do, but I used blacklisted words. Bottom line: It's iOS issue and you need to "fix" your phone before you can actually fix your phone. Apple isn't owning up to this issue.

     

     

    Get into your root directory (only possible if you have a "fixed" phone) find 'com.apple.iapd.plist', and delete it.

    Complete walkthrough here:

    http://www.youtube.com/watch?v=WEkNyosPkZI&feature=youtube_gdata_player

  • lupe911 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2012 6:36 PM (in response to szayat)

    I had the same problem on my iPhone. Speakers were not working, when they did it was during calls on loud speaker. If you wanted to hear some sort of sound you had to use headphones. This frustrated me so much as with out sound on the iPhone it makes the experience depressing. So i made a simple blog that has all the answers, solutions, fixs and so on on that i could find to resolve this issue. Hope it helps

     

    http://iphonenosound.com/

1 2 3 4 5 6 ... 15 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.