Skip navigation

Logic 9 crashes in piano roll whilst editing - HELP !

1436 Views 13 Replies Latest reply: Mar 28, 2013 10:48 AM by riknvic RSS
riknvic Calculating status...
Currently Being Moderated
Jun 24, 2012 4:06 AM

After a few moves of adjusting various things in piano roll edit . .  the 'piano roll section '  may suddenly go light grey and the 'rolling ball of doom' appears . This is the sign that Logic has locked up and the only way out is to force quit . . usually losing hours of editing ! !  Any ideas ?

iMac, Mac OS X (10.7.4), never got this with Logic 8 !
  • Eriksimon Level 6 Level 6 (10,415 points)

    The beachball is not a sure sign that things have locked up for good. Sometimes Logic "snaps out of it" after a few minutes. How long have you given it?

    My piano roll section is light gray, so I am not sure what you're describing? Do the gridlines disappear?

    A basic idea to not lose hours of work: cmd-s, cmd-s and cmd-s. And save. And cmd-s.

    Crashes and freezes do happen, especially if you keep working for hours with unsaved RAM contents. So not only does saving prevent losing more than a few minutes of work, it actually may prevent some corruption of RAM contents and thus also prevent certain lockups and crashes.


    Further, I'ld like to know what version of Logic this happens with? And also what Software Instrument was on that track, and whether or not Logic was playing back. I'd also like to know if it only happens with one particular project, or with any project.

  • Eriksimon Level 6 Level 6 (10,415 points)

    OK, that's clear. One more thing: are you using Logic in 32 bit mode or in 64 bit mode? If 32, switch to 64. Logic can use all your available RAM in 64 bit mode, whereras it can only go up to ± 2.5 GB in 32 bit mode.


  • cbmtrx Level 1 Level 1 (10 points)

    I have the same problem on an almost identical system (21.5" 2011 iMac, 2.5GHz 20Gb RAM). I was snooping around Logic Pro 9.1.7 with a file saved from Logic 8 and encountered this same issue (which I don't recall ever seeing in Logic 8). I also tried saving the file from within 9 to see if there was some sort of version issue--no change,


    I also do a lot of work directly in the piano roll and this is where it will suddenly turn light gray and become unresponsive, out of the blue. No clue as to why. When I call up the Force Quit dialog, Logic is indeed in red with "unresponsive" beside it.


    riknvic I happen to have a few instances of the G-Player plugin (plays Gigastudio files), although I found that this problem happens even when there are no G-Player tracks. I also use an EMU MIDI 1x1 Tab (USB MIDI out to an external keyboard), but onot on the track I was working on at the time. Just wondering if you happen to have any of these, which might help to narrow down the issue (if it's not a Logic 9 software issue).


    The only other possibility might be that I have unvalidated plugins (currently all disabled) from when I set up all my old plugins from Logic 8; don't know if it could have anything to do with it but I figure it doesn't hurt to mention this.


    Very puzzling. I do save often, but even 5 minutes of work lost is a lot of work to redo.


    Any ideas? Any other possible software conflicts that could cause this sudden crashing? I'd hate to have to revert to Logic 8...

  • byzantine Level 1 Level 1 (0 points)

    If it's any comfort I'm having exactly this white screen crash running 9.1.7. on Lion.


    Seems to happen when I zoom in the piano roll regardless of what plugs are instantiated.


    I tried disabling display sleep and that may just have stopped it, too soon to say tho.

  • cbmtrx Level 1 Level 1 (10 points)

    I also just started using 64 bit mode...and so far I've had no crashes, but it's too early to tell.


    (And in case you're not aware of 32 vs 64 bit, Logic 9 can take full advantage of ALL of your RAM in 64 bit mode--I never even see the CPU meter register anymore--whereas it used to max out constantly.)


    Will see if the piano roll zooming in/out brings it on; puzzling.

  • cbmtrx Level 1 Level 1 (10 points)

    FYI I've had no crashes [YET] in 64-bit mode. This could be a total fluke and the next crash is right around the corner, but so far so good.


    The plugin bridge for 32bit plugins seems to work fine...just a tad less user-friendly because it switches between Logic and this app.

  • byzantine Level 1 Level 1 (0 points)

    Sorry to raise the ghost of this thread but I am still having these whiteflash-crashes always while in the Piano Roll and I'm wondering if anyone has noticed a resolution to this persistent bug by updating to Logic 9.1.8?


    I remain on 9.1.7 coz I don't really look forward to the Gatekeeper scenario (though I know you can turn it off...) but I would update to 9.1.8 if peeps here started saying the whiteflash bug is dead in this new revision.


    This is really getting me so any feedback appreciated to the max.




    PS I'm in 32 bit mode

  • byzantine Level 1 Level 1 (0 points)



    Why would moving to 64bit solve a problem related to using the piano roll?


    Is more ram needed while in there?


    I've now got a permanent nervous reflex going on which means I can't relax in the piano roll and have to hit CMD/S every few seconds...

  • cbmtrx Level 1 Level 1 (10 points)

    Haven't really had this behavior much lately--in fact I can't recall the last time it happened.


    A couple of things I recall that might have caused audio skipping etc when moving the mouse over the piano roll during playback:


    1. I use the G-Player (multi/solo) AU instrument for Gigastudio patches; this AU is a little buggy, and the audio weirdness only seems to happen in the piano roll for these tracks;
    2. I seem to recall that this happened, more often than not, when I had left Logic on all day in the background and, even after shutting down most other apps, it seemed to have a harder time with CPU load than it did first thing in the morning.

    But I STRONGLY recommend 64-bit mode. It's a whole new order of power, particularly for heavy-duty projects.

  • byzantine Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 9:49 AM (in response to cbmtrx)

    Know what you're saying there, cbmtrx, I never get this behaviour in the morning ;-) I mean I never get this early in a sesh so that might be a factor...


    Gald U are not getting it anyway.


    Haven't noticed any particular plug causing this here tho.


    Can I ask are you on 9.1.8? And if so d'ya think there'S any correlation between updating and not seeing this anymore?


    (I wanna move to 64 but too many plugs still get left behind here)

  • cbmtrx Level 1 Level 1 (10 points)



    You can still use most 32-bit plugins in 64-bit mode...most, but not all.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.