1 2 3 Previous Next 34 Replies Latest reply: Jun 15, 2014 6:24 PM by weeflea Branched to a new discussion.
creativefi Level 1 Level 1 (0 points)

No sound on my iMac.Start up sound but that is all.

  • 1. Re: No sound on my iMac
    dsimagry Level 4 Level 4 (1,275 points)

    Have you tried the usual..

     

    Mac OS X: Starting up in Safe Mode

     

    http://support.apple.com/kb/HT1455

     

     

    Resetting your Mac's PRAM and NVRAM

     

    http://support.apple.com/kb/HT1379

     

     

     

    Resetting the System Management Controller (SMC)

     

    http://support.apple.com/kb/HT3964

  • 2. Re: No sound on my iMac
    den.thed Level 7 Level 7 (23,965 points)

    If none of the above resets solves the problem, then try the following.

     

    If there is anything plugged into your Headphone audio out port, unplug it.

     

    If not, but you have recently unplugged something from the audio out port, then perhaps the micro switch inside of the out put port is stuck. In that case, try re-plugging and up-plugging the device a couple of times to see if you can unstick the micro switch.

     

    If not, then you will need to contact Apple, your Apple Store or AASP and have it checked out.

     

    see > Apple - Support - iMac - Service FAQ

  • 3. Re: No sound on my iMac
    RRFS Level 5 Level 5 (4,430 points)

    When you open the Sound panel in System Preferecnce what does it say for output devices?

  • 4. Re: No sound on my iMac
    creativefi Level 1 Level 1 (0 points)

    It fixed its self yesterday but not working again.It now says digital out -optical digital-out port it seems to change its self and I am not sure how to change back.I have unplugged every thing from the back of the computer.

    Thanks again

  • 5. Re: No sound on my iMac
    X423424X Level 6 Level 6 (14,190 points)

    Plug into the headphone jack and then pull the plug.  Is it still stuck in digital out only?

     

    Are there no other choices in Audio MIDI Setup?

     

    Do you have a hdmi connection to, say, a TV?  If so, disconnect it.

  • 6. Re: No sound on my iMac
    creativefi Level 1 Level 1 (0 points)

    When I plug into headphone jack the sound icon comes on when i pull out it goes off.No other choices in the audio midi setup now I only have headphone port.

    I have my itunes set up to my stereo through airport that is working fine.

    Do i need to disconnect the airport extreme?

  • 7. Re: No sound on my iMac
    X423424X Level 6 Level 6 (14,190 points)

    Is itunes running during all through these tests?  If so quit it.  You should have to disable airport.

  • 8. Re: No sound on my iMac
    creativefi Level 1 Level 1 (0 points)

    Thanks for your help.At the moment the sound is back on it seems to have a mind of its own.

    If it goes off again will run all the tests with airport and itunes shut down.

  • 9. Re: No sound on my iMac
    MrKuss Level 1 Level 1 (0 points)

    I'm having the same problem. I just asked the same question about 10 min. ago and now the sound came back on without me doing anything. Like you said it seems to have a mind of it's own. Let me know if you ever find out how to fix it.

  • 10. Re: No sound on my iMac
    seniordalite Level 1 Level 1 (10 points)

    You guys are not the only ones. I had the same problem and there was no sound. But it came back after I shut down and re-started (someone says this was a smc reset.) I got a 900+ page Manual on the "Mac OSX Lion, the missing manual" and none of this was covered. Disappointing.

  • 11. Re: No sound on my iMac
    edxburdick Level 1 Level 1 (0 points)

    I have the same problem right now. It has yet to resolve itself like you guys are all saying it did for you. I restarted, shut down and started up again, put to sleep and started again, started up in safe mode, reset the PRAM/NVRAM, plugged and unplugged headphones from the headphone jack, checked preferences etc, made sure everything but this troubleshooting window was completely closed, and nothing has worked yet. I'm going to check system updates to see if my software is up to date. this is really irritating. Sound does not work through headphones either. Let me know if there is a clear solution found at some point because I am very frustrated. thanks.

     

    EDIT: system updated and I shut down and started up my computer again. seemed to do the trick. easy fix.

  • 12. Re: No sound on my iMac
    seniordalite Level 1 Level 1 (10 points)

    After 3 trips to the Apple store to consult with an Apple Genius (??) I came home with the same problem: no YouTube and no audio. Of course in the store, it worked because they unplugged the cable and did something similar to a SMC RESET.

     

    Finally, I tried, just for the **** of  it, to shut down and then click the Re-start button. It worked (it no longer boots up in Safe Mode): YouTube and audio all work. I now hit re-start everytime to get out of Safe Mode.

  • 13. Re: No sound on my iMac
    Paola Rizzato Level 1 Level 1 (15 points)

    Such a simple solution - but one that fixed it for me. I was having the same problem, but after reading den.thed's reply I poked the headphone socket with the headphone jack a couple of times and it now works. Clearly something had got jammed. Thanks!!!

  • 14. Re: No sound on my iMac
    seniordalite Level 1 Level 1 (10 points)

    While I fixed the Safe Boot problem by clicking on the Re-Start button, I discovered another and simpler fix: just turn on your computer by pressing the button on the back of your iMac, not the power button on your keyboard.

    One operation less, and it works!

1 2 3 Previous Next