Skip navigation

Aperture Library not working after update

3928 Views 25 Replies Latest reply: Jul 25, 2013 11:51 AM by Brian Choong RSS
  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Jun 30, 2012 9:29 AM (in response to marwandese)

    That is what I was hoping for.

     

    If you do not press the "upgrade" button you now should have again an Aperture 3.2 library that you can open with Aperture 3.2.x.  If you press the upgrade botton, hopefully this time - with the new 3.3.1 version, the upgrade will be successful.

     

    It is up to you what you try now.

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Jun 30, 2012 10:23 AM (in response to marwandese)

    So i have to install aperture 3.2.4?

    no, only if you want to stay with Aperture 3.2.4.

    The screenshot you showed was Aperture 3.3 asking you for permission to upgrade the library to Aperture 3.3 format.

     

    If you double-click your Library again, Aperture 3.3.1 (you upgraded to 3.3.1, didn't you?) will now upgrade the library and hopefully better than the last time, since they fixed a bug and your library is now repaired.

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Jun 30, 2012 12:30 PM (in response to marwandese)

    Are there any diagnostic messages in the Console Window?

  • Erik Veland Calculating status...
    Currently Being Moderated
    Jun 30, 2012 6:55 PM (in response to marwandese)

    Yikes. At least my photos are there, but I have 10K photos to sort out. Any chance of saving my projects?

  • hoodcj1 Calculating status...
    Currently Being Moderated
    Aug 17, 2012 2:42 AM (in response to Erik Veland)

    I have had the same experience, but what it took to restore functionality to Aperture, was change permissions to the disk that had the Aperture Library.  I pressed CMD I and checked sharing & permissions.  Although I had Read & Write permissions, I still couldn't open the library without the same error message you are receiving.  I then changed the sharing & permissions for "everyone" to read & write.  I then clicked the gearwheel to apply changes to enclosed items (or a similar message).  After I did this Aperture opened as normal

    I am not sure what caused this, but I had recently backed up to an external HD.

  • Tescum Calculating status...
    Currently Being Moderated
    Oct 12, 2012 8:19 PM (in response to marwandese)

    Well I had the same problem. And after try a lot of things... I quit.

     

    After a month I tried in another computer with the original library. I updated it and then, the same....

     

    But this time I tried looking in "trash".

    And... All the time was in there.

     

    I hope that everybody in here have the same luck.

  • Brian Choong Calculating status...
    Currently Being Moderated
    Jul 25, 2013 11:51 AM (in response to marwandese)

    I got this problem too, but I able to find the solution my self

    This issue happen because of the Aperture trying to upgrade/open a corrupted library file

    e.g. You got a Library call Library A

    And then when you try to open it with Aperture, aperture detect this library is from older version and then ask you to upgrade it

    Then you say yes, this is the most interesting part, if the upgrade fail, then you will get this message, and no way to open the Aperture again

    Aperture will always prompt that error message

    Why? Because everytime when you trying to start Aperture, Aperture will try open the Library A

    And the worst part is, Library A is set as default library for Aperture

    But, library A is corrupted and cannot be open

    This is a dead lock

     

    To solve the dead lock, we need to change the default library for the Aperture, so that it able to load smoothly

     

    Well, we know the new Aperture able to open iphoto library,

    Also, there is a shortcut for iphoto to launch Aperture at it menu

     

    To solve the problem

    1. Launch the iphoto

    2. Create a photo album, let say Album A, import some photo to it

    3. At iphoto, highlight the Album A, and then go to File/Open Library in Aperture

    4. Yes, now Aperture will be launch and opening the iphoto library, which is Album A now

    5. Once Aperture able to open Album A, it mean it will lock the default library as Album A, problem solve!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.