Skip navigation

iphoto imports upright photos as black

52183 Views 107 Replies Latest reply: Oct 16, 2013 9:38 AM by Old Toad RSS
  • Beum Calculating status...
    Currently Being Moderated
    Jun 19, 2012 11:37 AM (in response to david_mbp)

    I found the reason for this issue: it's iPhoto itself! Or at least an iPhoto update.

    It has nothing to do with a corrupted image or library.

    The issue starts the moment you update iPhoto form 9.1.3 to 9.2

    The only solution that currently works is to delete iPhoto, reinstall (preferably from the iLife install DVD) and update up to 9.1.3.

    You probably would have to create a new library, because the previous one can not be opened and requires a newer version of iPhoto.

     

    I had the same issue when importing pictures from a Nikon D800 in my iPhoto library. Luckily I had a few other Mac around me so I could test this thoroughly.

  • vivianfromca Calculating status...
    Currently Being Moderated
    Jun 20, 2012 9:59 AM (in response to david_mbp)

    As a layman following this stream with great interest but some confusion,  I have two questions.

     

    1.  It would be great if we can all report this to Apple because it seems to be a pretty widespread problem.  Can someone tell me how I report this problem to Apple, since they don't follow the community postings? 

     

    2.  If someone could summarize technically what we are actually reporting, maybe we can all send the same report in.  And/or maybe there's a way to just link to this discussion to provide the historical context.  It seems that there have been a lot of technical workarounds analyzed and tried in this stream including rebuilding libraries, but as a layman, they aren't easy to follow.  The only easy buty klugey fix within iPhoto seems to be Edit and Rotate each individual photo, and the last few solutions involve bypassing iPhoto somehow by either storing photos outside the iPhoto library or not upgrading to the latest version.  None of these are really acceptable from a consumer standpoint although they're helpful for now.

     

    Thanks.

  • jasonfromnew Calculating status...
    Currently Being Moderated
    Jun 20, 2012 3:39 PM (in response to vivianfromca)

    Hey Vivian, just open iPhoto, then click on iPhoto in the menu bar and select "Provide iPhoto feedback". If everyone that posts here send Apple a notification, it'll speed up a fix.

    Interestingly, this problem only started happening to me this week. Not sure when I last imported imaged, but it may well have been since the latest iPhoto update.

  • TaraInAustin Calculating status...
    Currently Being Moderated
    Jun 21, 2012 10:06 AM (in response to david_mbp)

    Hi all,

     

    Same problem here.  I'm using iPhoto 9.3, have done all updates, and my camera is a Nikon D3100.  This is a relatively new problem -- I'd say within the last two weeks (it's June 21, 2012 as I type this).

     

    I read through and am trying to work around it with small editing fixes so the photos appear (thanks, everyone who suggested that) but it is still a major pain.  I reported it to Apple through the iPhoto feedback and hopefully it will be resolved.  I did not use technical language (EXIF, what-have-you) because heck if I know what that means.

     

    T

     

    Message was edited by: TaraInAustin because I used a no-no word.  Now it says "heck."

  • yozhbk Calculating status...
    Currently Being Moderated
    Jun 24, 2012 9:43 AM (in response to TaraInAustin)

    Does anyone know a real solution to this issue ? I have 1k+ pictures from Europe trip and ofcourse lots of portrate pictures all show up black, not only in iPhoto but in Photo Stream, which is very very annoying, I tried to edit and revert back the picture which works, but going thru 1k+ pictrures is a very long task.....

     

    Any better solutions ? I`m rebuilding iPhotos Thumbanails now

  • William Tucker Calculating status...
    Currently Being Moderated
    Jun 24, 2012 5:39 PM (in response to yozhbk)

    I, too, have this problem, and am desperately trying to edit photos for a project due tomorrow.  Rebuilding iPhoto databases does not seem to have worked.  I tried editing and reverting, but this doesn't seem to do anything either.  Perhaps transferring the photos to my old tried-and-true G5 on Leopard, rather than this MacBook Pro on Lion will work.  Apple, please fix this problem!

  • birgitlh Calculating status...
    Currently Being Moderated
    Jul 1, 2012 1:49 PM (in response to david_mbp)

    I spent 30 minutes on the phone with Apple support and, after a lot of troubleshooting, found this solution:

     

    There was a problem with the user preferences.  I went into the library (in Finder toolbar, click "Go" and hold down "Option" key to show library), then chose the Preferences folder, found the PList file for iPhoto, and deleted it.  Upon reopening iPhoto, it worked fine.

     

    This was after I had established that I had the same problem in another user's account on the same computer, and with another SD card.

     

    Hope this helps!

  • leo8877 Calculating status...
    Currently Being Moderated
    Jul 1, 2012 6:46 PM (in response to birgitlh)

    I deleted the com.apple.iPhoto.plist and restarted iPhoto and the images were still black.  Was this the file you deleted as well?

  • birgitlh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2012 6:53 PM (in response to leo8877)

    Yup, that was it for me.  If it didn't work for you, I have no further ideas, sorry.  Here are the other things I tried before that didn't work - maybe it's one of them:

    - Try plugging in your camera instead of putting the SD card in the slot directly - maybe the interaction between slot/card isn't good (I find this unlikely but the guy suggested it).

    - Try a different SD card - the guy suggested this, but since it wasn't all of my photos (just the vertical ones), I thought that it was unlikely I had an SD card problem.

    - Sign in as a different user on your computer (I created an account just to test) - see if importing the photos there works.

    - Create a different library in your iPhoto, see if the photos import correctly there.

    Unfortunately, I don't know how to fix those last two problems, if you find that it's one of them - at least you'll have more to work with, though.

    Good luck!

  • birgitlh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2012 7:09 PM (in response to birgitlh)

    Never mind, the problem is back for me now.

  • Buadhai Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2012 7:16 PM (in response to birgitlh)

    Here's how to fix a whole lot of them at once:

     

    http://www.philmug.ph/forum/f19/fix-iphoto-black-portrait-images-84679/

     

    Note that the guy agrees with me: It's a problem with the EXIF data....

  • TaraInAustin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 5, 2012 5:52 AM (in response to david_mbp)

    Hey all, I deleted the PList file for iPhoto per birgitlh's suggestion.  It didn't change the old photos I'd already put on my computer (from my Nikon D3100)  BUT when I added photos yesterday (about 100 -- it was the fourth of July) they all showed up -- portraits, landscape, all of them!  So I am sending big, smoochy kisses to you, birgitlh.

     

    And Buadhai, I will have you over to my house someday to explain what in the world EXIF data is.

  • Thad Spreg Calculating status...
    Currently Being Moderated
    Jul 5, 2012 5:31 PM (in response to david_mbp)

    I tried throwing away my plist files and nothing changed. My photos are still black when I enlarge them but the thumbnails are fine. Oddly, my photos flash on the screen for a split second when zooming between thumbnails and full size. :-(

  • kingping Calculating status...
    Currently Being Moderated
    Jul 15, 2012 10:02 AM (in response to Buadhai)

    +1 to Buadhai post.

     

    I noticed that I need to rotate the photos twice before the Revert to Original option appears. 

     

    Thanks!!

  • Henry5 Calculating status...
    Currently Being Moderated
    Jul 17, 2012 6:55 PM (in response to luggate)

    Yes! They Show in "Edit" Mode (I just started in my MacBook with same Black Problem!)

     

    And if You do any kind of Editing, they Start Showing!!!!!

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.