5 Replies Latest reply: Jul 2, 2012 11:43 AM by Frank Caggiano
freer Level 1 Level 1 (0 points)

I am trying to purchase Aperture but it tells me that it can't because it needs OSX10.7.4 but I and running Lion, which I thought was 10.7.4


iMac (21.5-inch Mid 2011), Mac OS X (10.7.4)