Skip navigation

Computer fails to sleep

874 Views 8 Replies Latest reply: Jul 15, 2012 2:06 AM by Gochugogi RSS
Bruce Plummer Level 1 Level 1 (45 points)
Currently Being Moderated
Jul 4, 2012 8:48 AM

When I put computer to sleep, after approximately a 2 second pause, it wakes up again.

  • dominic23 Level 6 Level 6 (18,535 points)
    Currently Being Moderated
    Jul 4, 2012 9:52 AM (in response to Bruce Plummer)

    Why Mac may not sleep?

     

                       http://support.apple.com/kb/HT1776

     

    Rest SMC.   http://support.apple.com/kb/HT3964

  • LexSchellings Level 5 Level 5 (5,505 points)
    Currently Being Moderated
    Jul 4, 2012 12:24 PM (in response to Bruce Plummer)

    First got SystemPreferences/EnergySaver uncheck "Wake for Network Access".

    Then goto SystemPreferences/Print&Fax and display the print queue, delete everything in the printqueue.

  • Gochugogi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2012 6:00 PM (in response to Bruce Plummer)

    Same exact problem: my 2009 Mac Pro can only sleep for about 2 seconds and then wakes up. Sleep was fine with prior OS all the way back to Snown Lep. Tried all sorts of stuff: reset PRAM/SEM, disconnected all external drives and devices, repaired preferences, diabled Bluetooth, disabled network wake, etc., just about every suggestion I could find, including a bunch of terminal "fixes" to no avail. However, if I restart into Snow Lep on another drive it sleeps just fine with all the same apps, hardware and settings. I even installed the "Please Sleep" app and it did nothing even with the force sleep option checked. I can only assume 10.7.4 has a bug since the prior versions slept fine. Wish I could go back to 10.7.3...

  • LexSchellings Level 5 Level 5 (5,505 points)
    Currently Being Moderated
    Jul 13, 2012 11:51 PM (in response to Bruce Plummer)

    Bruce,

    This article you should read:

    http://osxdaily.com/2012/07/11/mac-wont-sleep-heres-how-to-find-out-why-and-fix- it/

    Then you can set your system to do what you want it to do.

    Keep us informed,

    Lex

  • Gochugogi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2012 1:21 AM (in response to Gochugogi)

    I did the "pmset -g assertions" and didn't get "1" after any of the sleep related items. However, after trying a 100 different things, I found one that seemed to fix it: disable guest user in Users and Groups in the System Preferences. I've never enabled or used it but apparently it became a default after the last OS upgrade. All day my Mac Pro slept like a baby with the Engery Saver timer or user invoked sleep.

  • LexSchellings Level 5 Level 5 (5,505 points)
    Currently Being Moderated
    Jul 14, 2012 2:22 AM (in response to Gochugogi)

    Very good!

    It should not influence the behaviour, but happy it worked !

    I would have never thought about that, always learning....

    Lex

  • Gochugogi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 15, 2012 2:06 AM (in response to Bruce Plummer)

    Still sleeping on day two: both auto sleep and user invoked. I'm afraid to touch Mountain Lion now that almost everything is finally working right. Well, every few days an image in Aperture suddenly turns black when using a paint in effect tool but Aperture has always been buggy.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.