Skip navigation

Macbook Retina Display isight camera not working - graphics freeze

18960 Views 67 Replies Latest reply: Jan 14, 2014 2:31 AM by Nosheen Zaza RSS
1 2 3 ... 5 Previous Next
Paipuky Calculating status...
Currently Being Moderated
Jul 4, 2012 9:02 PM

I recently bought a base MBP-RD and can say that I am overall impressed with it, though I have found a couple issues already. One of them is related to the iSight camera which for some reason doesn't work. The camera appears in system profiler, but it shows as "camera not detected" when trying to launch application like iChat, Skype, FaceTime, etc. I already tried re-installing OSX Lion, and still not working.

I have also found some weird issue with graphics where it freezes a series of frames when going to Mission Control or App Expose.

I am returning this computer as there are other things I didn't like, but overall pretty impressive (no LED battery indicator, no Lock slot, no sleep light indicator...)

Please reply if you have same issue.

  • DisneyWorld Level 1 Level 1 (55 points)

    Try making an appointment with a genius at an apple store (it is free) to see what they can do.

    Don't return it just because of the camera and the other features it doesn't have.

  • clintonfrombirmingham Level 7 Level 7 (26,655 points)

    I have to agree with DisneyWorld - there are going to be some problems with bleeding-edge technology and that's what you bought and, as you say, except for the problems you're having, you like the notebook.

     

    As to those things that are 'missing' - I understand. I use my Kensignton lock with a cable lock frequently. I would miss it. However there is an alternative that will be available within 4-6 weeks - see here.

     

    However... if you're still within 14 days of your purchase, you can always exchange it for a non-Retina model, which has all the things you're 'missing.'

     

    I'd just take it into your Apple Store and see if they have a fix for what's wrong with you're computer. Have it repaired and enjoy it!

     

    Clinton

  • clintonfrombirmingham Level 7 Level 7 (26,655 points)

    The 802.11ac spec has been 'coming' for about three years. Is it possible in the new MBP-R but needing a firmware update as 802.11n did on some Mac's? Maybe so - maybe not. Cisco just announced a 802.11ac router a couple of days ago - how many machines are ready for it? Not many. But, as I said, it could be in the new MBP's - just not implemented. We'll just have to do a wait-and-see on that one.

     

    Regards,

     

    Clinton

  • Kavin3 Calculating status...

    I have the same problem with the built-in camera on my retina macbook pro. However, it would reconnect after i restart it. It always happens after when i don't shut down my retina macbook pro for a while. I just let it sleeps mostly.

  • AlyMourad Calculating status...

    Same problem on my Retina as well. But mine sometimes reconnects & sometimes not.. sometimes appear in System Information & sometimes not as well.

     

    The strange part which makes me kinda think its software/firmware fixable issue and not a hardware/connector problem is that I noticed when I open an app (Photobooth & Facetime in my case) and the camera connects after a restart. the camera keeps working as long as I don't close the app. I was able to keep it working for 12+ hours till I had to close it to sleep.

     

    What are you going to do to fix it? send it back to apple or wait till it might be fixed via software/firmware updates? I'm wondering cause in my case living in Egypt. It's going to be hard sending it to the reseller cause they will ship it to apple to be fixed or try fixing it themselves & I'm worried that this will probably result in a lot of damages to the device.

  • ziadsa Calculating status...

    i think Macbook Pro is a good computer but plenty of issues, since day one.

     

    i received my computer with space bar cracked. i figured this out @ night when the keyboard backlight was.

     

     

     

    then my USB port ***** on it, it does not read all.

     

    even after the update no go the USB port does not  work all the time with the apple usb to ethernet adapter.

     

    while if i install vmware it does work on the windows in VMware environement.

     

    my Camera also is not being detected    how can i fix the camera.

     

    please do not tell me go to genius bar, they are all but not genius, if you have issue they ask you to format they do not know how to troubleshoot.

     

     

    Conclusion problem with macbok retina version:

     

    isight Camera wont detect

    USB port Does not work with all devices.

    Space Bar key broken from manufacture.

  • mjhawk Calculating status...

    This is exactly the same as mine.  It always works after a restart but within a few hours the camera stops working again.  I'm taking it in to the Apple Store today so I'll let you know what they do about it.

  • miniman75 Calculating status...

    Same problem here, did taking it to an Apple store shed any light on the problem?

  • zmatt1130 Calculating status...

    I've been having the same problem with mine. I brought it to the apple store a few days ago and of course the camera decided to work, so the guy couldn't see anything wrong with it. He offered to ship it out for them to do a full test of the computer/camera, but I didn't want to waste the time with that. Has anyone found a fix yet??

  • Tim Jonathan Calculating status...

    I have the same problem here. iSight Camera wont detect at all.. allthough it was working 2 weeks ago. Another problem is the left usb port throwing out my usb3.0 harddisk after a few seconds every time.

  • zmatt1130 Level 1 Level 1 (0 points)

    ok, the isight problem seems to be an issue with flash player. My friend told me he was having the same issue, but when he updated flash player it went away. I just updated flash, and the problem went a way for a bit longer, but came back. While it said "no camera connected" I unistalled flash completely, and then restarted photobooth. the camera worked! but then I wasn't able to do anything that required flash. It seems like it also works with the much older version of flash (10.3), but this won't let you watch youtube videos among other things. it seems like we will have to wait for the next version of flash player to come out and hopefully eliminate this issue.

  • LeeTheKing Calculating status...

    Same Problem!!!!!!!

  • Tim Jonathan Level 1 Level 1 (0 points)

    I uninstalled flash player completely.. after a restart photobooth still tells me "There is no connected camera"

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.