Skip navigation

SMTP not working for Mail. Works on iphone and smartermail.

62535 Views 71 Replies Latest reply: Jul 2, 2013 1:44 PM by James Donnelly1 RSS
  • Katie \'OConnell Level 1 Level 1 (15 points)

    @Glenn - I opened a GMail account and starting sending my outgoing emails via that SMTP server and -VOILA! - no hangups or error messages. I thought this was THE answer until I realized that - regardless of the email account I was sending 'from' (myself@mydomain.com) the message showed up with myself@gmail.com in the "From" field.

     

    This totally negates all the plusses of using the GMail SMTP server since I cannot have that 'from' address when sending official messages from my business.

     

    Why does it do that anyway? More importantly, is there a workaround? Like hiding the 'from' line (if that's even possible) and just specifying the 'reply to' address?

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    Katie

     

    I haven't done this, but I believe you can configure GMail to send as a different address or you can specify a reply to address.

     

    Log into GMail and click the options menu at the right top corner of the window. Go to Account Settings, Accounts & Import tab. On the "Send Mail As", click to learn more. That should help you.

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    Katie

     

    Here's more on the process. Log into GMail. Open Mail Settings from the menu. Open the Accounts & Import tab.

     

    Click on the Send Mail From Another Address.

    Put the name of the email account address in that field.

    Follow the setup steps. You will have to verify the account.

    Once verfied, go back and choose "Reply from the same address the message was sent to" on the GMail screen.

     

    Open Mail preferences and choose your account. Add the GMail server to the server list and choose to use that server with that account. Check the box to use only that server.

     

    That should correct the from address when using the GMail server to the account your sending from.

  • Katie \'OConnell Level 1 Level 1 (15 points)

    @Glenn: You are the BEST! This works like a charm. Thanks so much.

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    Glad that works out for you.

     

    Your Welcome

  • donnaf.fromca Calculating status...

    One & a quarter years later the problem continues.  I have tried for 3 days to send emails from both my hotmail & sbcglobal accts. (2 have gone thru on 2 separate days).  "Mail Connection Doctor" indicates hotmail, sbcglobal.net & smtp.live.com "connection & login to server succeeded". BUT smtp.att.yahoo.com is NOT connecting to server ("connecting to server ..." with gear icon spinning for days).  Detail from diagnostics is not helpful:  "OK mailbox unchanged, POP3 server signing off" or "0x116f6af80 - thread:0x116f726c0   Quit". 

     

    Have you learned how to resolve this issue or where the problem resides?  My husband uses att/yahoo mail on a non-Apple computer with Windows, and he too has had this problem in the past BUT NOT now.  We are both hardwired. Of course I called AT&T and got the same response as everyone else - not their problem.  No Apple Support.

     

    Very, very frustrated.

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    The server setting you are using is way outdated. Don't even know if it still works.

     

    See this discussion:

    https://discussions.apple.com/message/17137126#17137126

     

    Note the end of the discussion also: Open KeyChain and clear all the passwords for that account. Let it create new ones for it. Also do Keychain First Aid to make sure it has no problems.

  • donnaf.fromca Level 1 Level 1 (0 points)

    Glenn, you are an excellent resource, & I appreciate your technical expertise.  I on the otherhand am not technical at all. 

     

    As for "keychains", sometime ago I dealt w/ "keychains" from a pop-up where I had to confirm my passworrd. Now I do not know how to access  "keychains". Could you please tell me how for future reference?

     

    As for my server settings, they seem to be current.  Just now I was able to send 2 email (w/out attachments or links) and did not make changes to anything before I sent them.  From all the postings on this topic, it seems server problems are recurring & frustrating mysteries and none of the responsible parties will take ownership of them.  I am seriously considering going to gmail.  I hope the set-up is not too technical given my limited capabilities.  I will now tempt fate by trying to send another email with a link. 

     

    Thank you for your help.  You will most likely hear from me again.

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    KeyChain is located in the Application/Utilities folder.

     

    There are failures to connect to ATT for me also on occasion. If it happens constantly, then that another issue.

    The server smtp.att.yahoo.com is old. Maybe it still works.

    Try changing it to the new one provided in the like above.

     

     

    You can also try this one:

    • Yahoo Outgoing Mail Server (SMTP) - smtp.mail.yahoo.com (SSL enabled, port 995)

     

    This is the one I use.

     

    I also suggest you create a new discussion if this doesn't work for you. State your problem and someone else may be able to post some advise.

    Never Mind. I see you have already created a new discussion.

  • donnaf.fromca Level 1 Level 1 (0 points)

    Glenn,

     

    Thank you so much for all your help.  You are an exceptional resource for the Apple Support Communities.  I have updated my server info.

     

    Donna

  • Glenn Leblanc Level 5 Level 5 (5,895 points)

    Donna

    Let me give an update just for general info.

    As of yesterday, I started having problems with one of my accounts. Seems ATT has been creating havoic on one of my accounts to the point to I could only get webmail for it. Appears that they locked me out of the account after password failures yesterday. Working half way this morning, with many failures.

     

    It appears to be a server issue. Tried Mail and Outlook on one computer with same results. The iPad is working a bit better today. New user account has the same issue.

    My other 2 ATT accounts have no problems.

     

    Seems ATT for this account has issues. Can't even change the password at the ATT site.

     

    I just wanted to update you and say that they are having problems again. Just see if you can get them to admit it though.

    This is probably not your issue if it is just a sending problem, but you may have more success by updating to the latest server info as you said you have.

  • mkaplanphoto Calculating status...

    I have begun having outbound mail problems on mac Mail and att.yahoo. It started with no apparent reason two weeks ago, after years of having no problems. I've tried updating my Mail settings as noted above for the smtp.att.yahoo.com account to no avail. No outgoing mail gets sent. Just a spinning cursor, a request for my password, more spinning cursor then an error "cannot send message using server..."

     

    Mail connection doctor reports "Could not connect to the SMTP server. Check your network connections......." Ot

     

    I'm using  Mail Version 4.6 (1085) and  OSX 10.6.8

     

    Any one with new ideas on this problem? This is so frustrating. Thanks so much!

     

    Matt in Chicago

  • tkopley Calculating status...

    Matt,

    I've been having the same ATT/Yahoo mail problems starting the same time as you.  Same Mail and OSX versions too.  Today I've finally had a few hours to dig into this problem.  An email to Yahoo support went unanswered for several days, so I tried calling AT&T.  They said the same thing as others noted here: it's a Mail problem.  I appreciate all the previous postings in this tread, which have at least given me a few things to try.

     

    Unforunately, smtp.att.yahoo.com didn't work, nor did the new official server outbound.att.net.  In the end I created a Gmail account and now use smtp.gmail.com for my outbound mail, as described by others.  I aliased my yahoo email address as described by Glenn above on Apr 17 -- thanks Glenn! -- and it seems to be working, although connecting to the server is still very slow.  If you go that route, note that the Gmail Settings menu pick is now initiated from the gear icon in the upper right of Gmail.  Took me a google search to figure that out!

     

    This has been a frustrating 3 weeks, and the work around kind of a kludge, but at least I can send mail again.  I am not looking forward to having my outbound email data-mined by Google, but that's the price of convenience I guess.

     

    Good luck,

    Tom

  • mkaplanphoto Level 1 Level 1 (0 points)

    Thanks Tom. After a lot of hair pulling I finally did the same thing last week, using a gmail account I already had. Now I can send outbound email again from Mail, but I also worry about Google sifting through my messages.

     

    Still wonder what changed in Mail or ATT/Yahoo after everything worked fine all these years.

     

    All the best,

     

    Matt in Chicago

  • Katie \'OConnell Level 1 Level 1 (15 points)

    This problem has come and gone a few times for me. But I did find an ATT technician who was knowledgeable enough to truly help.

     

    First, make sure that your outbound server name is smtp.att.yahoo.com and check the "use custom port" option rather than the default. The port number should be 465. Check "secure sockets layer"

     

    Next - and maybe most importantly - you need to make sure your email address is VERIFIED and this is where it gets a bit trickier because ATT/Yahoo seems to have changed how that process happens. I believe that this is the way it's now done:

     

    Go to https://edit.yahoo.com/commchannel/manage?.done and enter your primary email account address and pw. You will then be at "Manage your email addresses." and should see a list of any and all email addresses associated with your primary account. The assumption is that, if the email address is on the list, it is verified. HOWEVER, if you're having problems with SENDING out email from your POP account, try deleting the email address (NOT your primary one, however!) then re-adding it by selecting the "Add Another." Whenever you add a new email address, you'll see a message saying that an email has been sent to that address for verification. You need do nothing once you get the email (this is the weird part). But at that point, you SHOULD be able to send out emails using the address from your Mail program.

     

    Good luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.