Skip navigation

Can't Install Final Cut Pro5

866 Views 8 Replies Latest reply: Nov 14, 2012 2:02 PM by Jim Cookman RSS
iamsam1994 Calculating status...
Currently Being Moderated
Jul 9, 2012 11:21 AM

So I looked eveywhere and couldn't find anything about this, I also called customer support and nothing has helped yet. I recently bought final cut pro 5 from someone and they gave me the sticker with the final cut studio serial number on it. I downloaded it on my macbook pro that could run this program and installed it and that went fine. When I tried running it, the licensing dialogue box came up asking for basic information (Name, organization, ad serial). I put all of that in and nothing happened. There are two buttons at the bottom of the dialogue box, the quit button and an ok button. The ok button is grayed out so I can't press it. I don't know what to do! Does this mean the serial number isn't working? Does anybody know about this?

Mac OS X (10.5.6)
  • Nick Holmes Level 7 Level 7 (29,805 points)
    Currently Being Moderated
    Jul 9, 2012 11:57 AM (in response to iamsam1994)

    You can't run Final Cut Pro 5.0 reliably on a Mac Book Pro. It will crash, refuse to start and generally do inexplicable things. FCP 5.0 was written for the older Power PC based Macs. Your MBP is Intel based. The earliest version you can use with Mac OS X 10.5.x is Final Cut Pro 5.1 with all updates to 5.1.4 installed.

  • Gary Scotland Level 5 Level 5 (7,590 points)
    Currently Being Moderated
    Jul 9, 2012 1:09 PM (in response to iamsam1994)

    Nick is the one you should listen to


    Check the exact version numbers, stating version '5' is not accurate enough and refer to Nicks advice

  • Nick Holmes Level 7 Level 7 (29,805 points)
    Currently Being Moderated
    Jul 9, 2012 2:26 PM (in response to iamsam1994)

    I don't care who you talked to. My advice above is absolutely accurate.

    "Customer Service" will talk to you all day about iPhones or making ringtones in GarageBand. They are not professional editors who have been using FCP day in, day out for the last 12 years.


    As for "looking everywhere", you could have just searched here and paid attention to hands on experts.

  • David Mclaine Level 4 Level 4 (1,855 points)
    Currently Being Moderated
    Jul 9, 2012 3:16 PM (in response to iamsam1994)

    Apart from the fact that Nicks advice is good, with regard to your serial number, make sure you are entering it correctly. It is easy to mistake a zero for a letter "O" or a number 1 for an "I".


  • Ultramud Calculating status...
    Currently Being Moderated
    Nov 13, 2012 4:58 PM (in response to iamsam1994)

    Hi iamsam1994...


    I'm having the same problem passing the License field on an older PowerPC (so it's not neccesarily because you're trying to install on a PwerMac).


    I'm wondering if you fugured this problem out?



  • Jim Cookman Level 7 Level 7 (23,435 points)
    Currently Being Moderated
    Nov 14, 2012 2:02 PM (in response to Ultramud)

    He stopped whining months ago, so he probably did figure it out.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.