Skip navigation

cannot install apps via apple configurator 1.1

10584 Views 14 Replies Latest reply: Jan 23, 2013 12:00 PM by Musix220 RSS
jasonfrombc Calculating status...
Currently Being Moderated
Jul 10, 2012 10:00 AM

error message that apple configurator "can't install app", tooltip that "an unknown error message "install prohibited" was received from the device".


Computer is authorized, app is free (iwritewords free version), ipad is supervised.  Have tried multiple apps, clearing and restoring supervision, clearing and restoring apps from configurator.  same error everytime.


Trying to determine if it is viable to deploy iPads as childrens games stations in public library branches.

iPad 2, iOS 5.1.1
  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    Jul 10, 2012 10:43 AM (in response to jasonfrombc)

    Are any restrictions at all  enabled on the iPad?  If so, remove them and try again.

  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    Jul 11, 2012 6:10 AM (in response to jasonfrombc)

    Try unsupervising , and installing app(s) just using prepare function.

  • intunsa01 Calculating status...
    Currently Being Moderated
    Jul 19, 2012 3:19 AM (in response to jasonfrombc)

    Hi I have just finished struggling with this issue. The problem was that I had a profile set up for our students which had the "allow app installs" unticked. You would think that this would just stop the user installing but obviously it blocked it on the ipads completely. I suspected this so I created an "Installation" profile which only had the web proxy configured everything else was left as default. This didn't work! It was only when I realised that I had to go in and tick the allow installs box that it sprang to life. Cheers Apple that's two days that i won't get back.

    Just in passing, whilst I was preparing the ipads I was getting an "ios file invalid" error message with no explanation. Turns out that Apple configurator needs a live internet link which, working in school, I didn't have until I logged on. I think that's there's still a long way to go before Apple gets it right for ordinary schools.

  • MrKGB Calculating status...
    Currently Being Moderated
    Jul 26, 2012 10:35 AM (in response to jasonfrombc)

    I'm just beginning to learn all of this, and was struggling with the same issue. I tried all of the things listed above, to no avail.


    Finally, I found something that worked for me:


    In Settings -> General, near the very bottom, there is a "Profile" that shouls be whatever you installed via Configurator. Delete that, and then re-prepare the iPad.


    That worked painlessly for me.

  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    Jul 26, 2012 10:49 AM (in response to MrKGB)

    You should be able to be able to accomplish the same by selecting "erase before installing" in Configurator and you can add new apps to the profile you are using or remove, whatever the case may be.

  • Tsuma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2012 4:56 PM (in response to intunsa01)

    Thanks for the tip. This helped me.

  • wrant Calculating status...
    Currently Being Moderated
    Oct 9, 2012 5:19 AM (in response to jasonfrombc)

    The problem with unsupervising and re-supervising is that I have to start all over again with the "new iPad" start up.  I have to tell it what language, what id to pair it with and such.  This is no way to maintain ipads!!!

  • AndyMelanie Calculating status...
    Currently Being Moderated
    Oct 15, 2012 7:44 AM (in response to jasonfrombc)

    If you have "Allow App Installs" Checked so that Students cannot install apps, you need to Untick "Allow App installs", then click the Apply button BEFORE you choose the apps to install. For some reason, Configurator will fail installing apps, and then neglect to apply the new configuration. This should all be documented better by Apple, instead of us having to figure it out.

  • wrant Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2012 8:15 AM (in response to AndyMelanie)

    This is exactly what I've found out.  Thank you for stating it so succinctly.

  • Musix220 Calculating status...
    Currently Being Moderated
    Jan 10, 2013 5:35 PM (in response to jasonfrombc)

    I am getting the "Can't install apps" error. I have tried the following:


    • Unsupervise, resupervise
    • Delete profile
    • Erase all settings on the iPad and start from scratch


    I'm using Lion with 1st gen iPads and Apple Configurator version 1.2.


    Basically, my iPads with configurator right now are useless. I can't install any apps. Anyone have any ideas?

  • BetterAnnaMac Calculating status...
    Currently Being Moderated
    Jan 22, 2013 7:10 AM (in response to jasonfrombc)

    What a big huge hairy deal. I had the same problem and came here to find solutions. Based on what was said, this is what I tried and what worked for me...


    Even though I had the setting to remove profiles that AC didn't install, I checked the profiles and the student restrictions profile that prevents installing apps was still on there. So I guess even though I'd unchecked it, AC didn't remove it. I consider that a bug. But I digress...


    I manually removed every profile on the iPad directed excect the one that says it's supervised and then refreshed in AC. That worked. So I won't have to uncheck and recheck all apps (which I tried and didn't work for me) but I *WILL* have to manually remove that student restriction profile on every single device. Grrr!! I'm considering NOT putting that one back. The iTunes store is blocked in our district filter for students anyway. I can't imaging having to manually remove that profile on every device every time I want to add a new app or update. Insane.

  • Musix220 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 12:00 PM (in response to BetterAnnaMac)

    I tried that. It didn't work. I had to remove some things which I couldn't even find without using the terminal. However, now it's unsupervising my devices when I plug them in automatically and I have to prepare them all again. I'm ready EXTREMELY frustrated with Configurator. I feel like it's extremely buggy and rather shoddy. Not what I'd expect from Apple.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.