Skip navigation

Airplay icon missing from multiple devices; receiver missing from local network

26616 Views 39 Replies Latest reply: Nov 5, 2013 2:21 AM by IvanLaw RSS
1 2 3 Previous Next
HowlingF Calculating status...
Currently Being Moderated
Jul 7, 2012 12:50 PM

I am at a loss after Airplay suddenly stopped working (icon disappeared and iphone/PC no longer recognizing my hardwired Denon receiver as a network device) and has not come back after extensive troubleshooting.  If anyone is willing to plod through the following and hazard a guess at a viable solution or otherwise provide helpful advice, you would have my undying gratitude.

 

I had Verizon Fios installed about a month ago and they gave me an ActionTec router, model # MI424WR, which I'm told is their most current offering.  I have one device connected directly to the router via ethernet cable -- a Denon AVR 1913 receiver, and  several devices connected wirelessly, including the following: Windows PC (running Vista), two Samsung 7000 series smart TVs, two Cisco DVR set-top boxes (courtesy of Verizon), a wireless printer, and an iPhone.  For the first few weeks of this set up, everything was great. I was able to successfully stream music to the Denon (1) by accessing songs physically stored on my iphone, (2) using Spotify Premium from my iphone, (3) using Pandora from my iPhone, and (4) using iTunes from my PC.

 

One day the Airplay icon disappeared without warning (and seemingly not in response to anything) from both the iphone and PC, and I noticed that the Denon receiver was no longer showing up among network devices in my PC's "network and sharing center," whereas it once did.  (The iphone also did not show up in the network and sharing center, but I can't recall if it ever did.)  When I entered the router's ip address in my web browser and looked at the devices in my network, both the Denon receiver and the iphone are there.  Furthermore, I can access the Denon by entering its IP address in my browser and I can play internet radio using the Denon.  I also tried pinging it and all were packets were received, none lost.  Clearly the router is recognizing the Denon and it's connecting to something; just apparently not my local network, or at least not anymore anyway  (I cling to the belief that it will one day work again, because it once worked great!)

 

I found one temporary work-around that is not a solution, but may be relevant diagnostically: when I connect my PC directly to the router using an ethernet cable (so that both the Denon and the PC are connected via ethernet cable -- everything else remains wireless), the Denon suddenly appears in my PC's network and sharing center.  Furthermore, the Airplay icon re-appears, and it works just fine from itunes on my PC.  However, the icon does not re-appear and does not work from my iphone, nor does the iphone appear in my network and sharing center.  And as soon as I disconnect the ethernet coonnection to my PC, the icon disappears.

 

Two other observations, in case they are relevant.  One is that when I access my router by entering its IP address in my browser and look at the devices in my network, the Denon is identified by it's MAC address.  When it used to show up in my PC's network and sharing center, before this all started, it was identifed by it's "friendly" name, which is the following: [Denon:AVR-1913].  The other observation is that I have the Denon iphone app, and it has also stopped recognizing the receiver as an available device to connect to.  Before this all started, the app used to recognize the receiver, also by it's "friendly" name.  When I tried manually entering the IP address for the Denon receiver into the Denon iphone app (temporary IP address assigned by DHCP that is), I got an error message saying something to the effect that the device is not available and cannot connect.  However, if I enter the IP address for the Denon receiver in my iphone's Safari browser, it accesses the receiver.

 

After calling tech support for Apple, Verizon, Denon, and Actiontec, and combing these support communities for posts, the majority view seems to be that it must be a router issue; the minority view is that it could be a receiver (Denon) issue.  Nobody has been able to pinpoint the issue or solve it, except to the extent that I can stream from my PC by connecting my PC directly to the router using ethernet.  (This is impractical as both router and receiver are stored on a high shelf in a closet; furthermore I can apparently only stream from iTunes as there doesn't seem to be an Airplay icon for the desktop version of Spotify Premium).

 

I can confirm the following:

 

- I have tried unplugging everything, performing factory resets on both the router and the receiver, and then reconnecting everything one device at a time, to no avail.

 

- I have tried disabling firewalls (Verizon, Windows and AVG) and temporarily disabling security software (AVG).  (Should not matter as the problem affects the iphone in addition to the PC).

 

- I have tried temporaily disabling WPA2 security.  (Again, problem affects the iphone too, so shouldn't be relevant).

 

- All firmware and/or software is up to date in all devices (i.e. itunes, iOS, router, receiver)

 

- I have opened all the Airplay ports by manually configuring my router as suggested here: https://discussions.apple.com/thread/4046029?start=0&tstart=0

(This post is from someone in the UK; could ports be different in the U.S.?)

 

- My network is not hidden and does broadcast a unique name

 

- MAC address authentication is disabled

 

- The Denon's network settings are as follows: DHCP is set to "on"; IP control is set to "always on."  The network standby feature is set to "on."

 

 

Thanks in advance (very, very much) to anyone willing to help me grapple with this.

iPhone 4S, iOS 5.1.1
  • FredRx Calculating status...

    I have Fios and have the same problem, but I have the Denon AVR-991.  The Denon AirPlay speaker option no longer shows up on my iphone 4S, my ipad2, or my 2nd gen ipod touch.  I went through all the updating and resetting to no avail.  I don't believe the Denon is the problem as I am able to stream music from the Internet directly through the receiver.  At first I thought the problem was introduced by updating the iphone and ipad to the latest OS version, but because the Denon also disappeared on the older ipod touch, my gut feel is that it's a network and/or router issue.

     

    I called Verizon and they claim nothing has changed to cause this to happen.  I called Denon, they said to call Apple.  Where to go from here? I'm clueless at this point.

  • Aloke Calculating status...

    Airplay seems to dissappear, seemingly at random, from my Denon 2312ci AVR connected to my LAN through Netgear WNDR3800.  I also have an iPhone and an iPad.

     

    However, I have found a pattern and a possible source of the problem.

     

    If the AVR is initialized on the LAN after Bonjour has started up on my Windows 7 PC, then everything works as it is supposed to.  The AVR initialization can be done by switching to or from DHCP on the AVR.  It doesn't matter.  Airplay is available in iTunes, and on my iOS devices.

     

    However, if Bonjour is started after the AVR is on the LAN, like if I reboot my PC, then Airplay disappears from all 3 (iTunes and my 2 iOS devices)!!  The AVR is on the LAN, can be pinged, can be controlled via the browser on the PC, can stream internet radio and from my media server on the LAN.  If I stop the Bonjour service on the PC, Airplay reappears on my iOS devices (but not iTunes, which depends on Bonjour).

     

    Uninstalling iTunes and Bonjour and reinstalling from the latest download from Apple does not help.  As soon as Bonjour loads on my PC,and the AVR is already on the LAN from before, Airplay on the AVR gets disabled!!  If I stop Bonjour manually or shutdown my PC, Airplay shows up on my iPhone and iPad.

     

    My solution now: I have changed Bonjour to not load up automatically. Now, Airplay is available on my iOS devices (except iTunes).  When I need to run iTunes, I start Bonjour manually, run iTunes.  Airplay is disabled during this time.  When I'm done with iTunes, I close iTunes and shut down Bonjour.  Airplay is now available on my iOS devices. 

     

    It is a kludge, but it is a workaround.

     

    I googled Netgear and Airplay and someone suggested setting the RIP direction to "Both" and RIP version to "RIP_1" but that has not fixed the problem.

     

    Anyway, I am at my wits end.  Bonjour (and Airplay) is happy if the AVR is initialized on the LAN while Bonjour is running.  How do I make Bonjour cooperate with my 2312ci when the AVR is already initialized on the LAN and Bonjour starts up?

     

    Aloke

  • FredRx Level 1 Level 1 (30 points)

    I have my music files residing on my iOS devices and was previously able to stream directly to the Denon -- no PC was ever needed.  So the Bonjour issue wouldn't even come into play under this scenario, correct?

  • Aloke Level 1 Level 1 (0 points)

    You are correct.  If you are having problems seeing the Denon as an Airplay destination on your Apple devices when all your PC's are off then Bonjour is not an issue.

     

    Note that in my case, the Denon is always on the wired network.  I can ping it, control it using the web interface.  I can use internet stations.  Always.  However, if my PC is on and Bonjour is loaded on the PC (it is by default unless one stops the service on the PC manually), Airplay on the Denon disappears from my iOS devices.

  • FredRx Level 1 Level 1 (30 points)

    This is getting crazy:

     

    With my PC connected via cat5 to the network, I see the AirPlay icon in itunes, along with the Denon speaker option.  If I switch to a wireless network connection and unplug the cat5 from my PC, the AirPlay icon disappears instantly from iTunes.  In both cases, however, the Denon speakers don't appear on any of the iOS devices.

  • FredRx Level 1 Level 1 (30 points)

    Something had to change recently to intiate this problem -- but what?  I'd been streaming music to my Denon for 18 mos + without issues until now.

  • Aloke Level 1 Level 1 (0 points)

    HowlingF, your problem is different from mine. 

     

    If my PC is off, my iPad and iPhone see my Denon 2312 and streams audio to it without any problems. 

    My PC, connected to the router by ethernet through another switch, won't see the Denon in iTunes (unless the Denon is re-initialized on the network).

     

    My Denon is connected by wired ethernet to my router (through a switch).  The only wireless devices are my iPad and iPhone.  All other software, like my web browser, sees my Denon all the time without any problems.

  • Iton Calculating status...

    Hi there. I had exactly the same problem with airplay connected to denon. I tried so so many solution which i could find from internet. One solution i think it could be resolved was to disable WMM mode on router. Unfortunately, my router is 802.11n which doesn not allow to disable wmm, so i just hopeless. But finally i checked on my brother's router that he use for airplay with no any single problem and i found that WMM is disbale by default!! since his router is old model and support only maximum at 802.11g. I saw his wireless mode is set to b+g(mixed). Therefore i changed mine, suddenly everything resolved!!!!!

  • Aloke Level 1 Level 1 (0 points)

    Which problem are you talking about?  There are 2 different issues being discussed: Mine and HowlingF's.

     

    Is your Denon connected to your LAN via wired ethernet?

     

    By the way, if you disable WMM on your 802.11n router, you'll reduce it to b+g for all devices.

  • FredRx Level 1 Level 1 (30 points)

    Here's another snippet of troubleshooting that (I think) rules out AirPlay or iTunes having anything to do with the problem:

     

    With just my Denon and PC connected to the network (both wired and all Apple software uninstalled from PC), the Denon sees the PC as a 'media server'.  From the Denon GUI, I can select and stream music files that are on the PC without any problems.  But, as soon as I switch the PC to a wireless connection and unplug its CAT5, the music stops and the PC disappears from the Denon.

     

    Doesn't this indicate that there is a wired-wireless conflict somewhere on the network?

  • FredRx Level 1 Level 1 (30 points)

    I just tried this (switched router to 'legacy b & g' mode).  It didn't help.

  • Aloke Level 1 Level 1 (0 points)

    I'm stumped, since my problems are there even with all wired setup (my iTunes on my wired PC loses Airplay functionality if the PC is rebooted or Bonjour is restarted).

     

    I suggest taking this to the AVSForum (not AVSForums, which is a different copycat site!) which has LOTS of experts.  My receiver has a separate thread (below).  Maybe your reciever has one too:

     

    http://www.avsforum.com/t/1334369/the-official-denon-avr-xx12-model-owners-threa d

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.