5 Replies Latest reply: Oct 7, 2012 2:54 PM by mrminux
dhjdhj Level 2 Level 2 (160 points)

I've been trying for the last three days to order some prints --- (which I've done MANY times in the past).

 

Aperture appears to be uploading everything but ultimately stops and tells me "A connection could not be established at this time"

 

I'm fully connected (proof, you're reading this message!) and so I have no idea what's wrong.

 

Can't find anyone at Apple to call for help.

 

Any ideas?

  • 1. Re: A connection could not be established at this time
    Sketchyartist Level 1 Level 1 (10 points)

    I just had this same problem. I have spent the last 7 days working on my print order. I am running Aperture 3.3.1. There are a lot of people out there that have had this same issue. This is what I was able to determine while on the phone with Apple Print Service Support.

     

    (1) Check the number of images you have selected for your order. I had an order with 152 images (almost 300 prints) and it failed to order. I had broken that order into another order with 101 images and it was successful. I had another order with only 74 images and it was successfull. In both success cases I had more than 152 prints made. The first was 154 and the second 165 prints. So it is not the number of prints, but the number of images.

     

    (2) Wifi. I was informed that some people have problems with WIFI connections. I was on a hard line, or ethernet connection. So this was not my issue. I thought I would mention it because it was discussed.

     

    (3) Close all other applications. This might help to free up resources on the computer and make the process go a little smoother.

     

    (4) Check the Activity window. Go to Window>>Show Activity. This will open the Activity windows. If your order is not displayed in there with a status of Uploading, then the order never left the computer. This was the real issue I was having. I got this error after the order preperation was completed. I was never able to press the done button because of the error. The error also caused the upload to cancel. It is very frustrating because there were no places in Aperture to determine more regarding the error, or the status of the last order submission. Would be nice if the Activity windows showed that order as failed.

     

    (5) Size and mixed orders. I noticed (in my second 74 image order) that with mixed order sizes it takes a lot longer to process. I had several 8x10 and 5x7 prints. As well as 4x6 and wallet images. This complex order of print sizes caused the smaller image count order to take a lot longer to go from start to finish. It would appear the 8x10s may have contributed to that because of their size.

     

    (6) Hate to bring this up. It is not really related to the problem, but make sure you crop your images to the correct aspect ratio before ordering. I did not have this problem, but have made that mistake in the past. You cannot select an image that is formated for 4x6, print it as a 5x7 and expect it to come out normal and perfect. Crop them first. This creates another problem. The order application, tool, window (what ever it is called) does not provide indications of what the image is being displayed. Another words I have the same image as a 4x6 and 8x10. I rename the image to duplicates to have the aspect ratio in the name. However, in the order tool there is no way to view the file name. You can have two images that look very similar (5x7 and 8x10 for example) and not be able to determine which is the correct aspect ratio for the print selection. To work around this problem I had to print a contact sheet of those images as a pdf and then have it open while I entered my order. When I ran into this situation I would compare the order window image to the contact sheet and figure out a good guess for the image. At least it is better than not being able to see anything.

     

    Hope all this helps. Hopefully something will help you get your order done. I think that both (1) and (6) are software defects in Aperture. I think that Apple should fix those issues. That does not mean that they will be investigated, but I believe this problem you are experiencing, and I did too, is a software defect.

     

    Best Regards,

    Chris

  • 2. Re: A connection could not be established at this time
    dhjdhj Level 2 Level 2 (160 points)

    I can confirm a lot of this. I actually started sniffing the network and that error message is erroneous as no attempt is in fact made to upload.

     

    What I'm finding is that if I have a large number of images (and I had a single 8x10 as well as about 200 4x6s), it seems to spend a long time "preparing" and then dies. I don't know why, but I've plenty of disk space so unless it's running out of virtual memory (unlikely), I don't know what is going wrong but probably an exception is being generated that is being caught higher up and just presumed to be a connection error.

     

    I was also able to break up the order into a few smaller parts but apart from that being painful as you now have to wait for each chunk to be prepared so you can do the next bunch, there's also the problem of being charged multiple times for shipping.

     

    Now, I called Apple and had a most "interesting" discussion. First, the guy wanted to know when I had bought Aperture so he could determine whether I was entitled to free help. Then he decided that he wanted to check if there was a limit to the maximum number of photos that could be ordered so that I would be REQUIRED to break up the order and pay multiple shipping costs.

     

    Eventually, someone else took over, and combined my 5 orders into one.

     

    Apple definitely needs to look into this issue

  • 3. Re: A connection could not be established at this time
    estnyboer Level 1 Level 1 (0 points)

    SUBSCRIBE! This is a ridiculous problem. FIX IT!

  • 4. Re: A connection could not be established at this time
    mrminux Level 1 Level 1 (0 points)

    Same issue.

     

    I have been successul to send a small order of 10 or so prints to the store, but when trying to do large printing, I get a network error, which has no validity to my connection.

  • 5. Re: A connection could not be established at this time
    mrminux Level 1 Level 1 (0 points)

    As an FYI, when I order prints of all the same size, I do not recieve the network message.  It occurs only when I order prints, in the same order, of various sizes.

     

    I successfully ordered 50 large prints and 150 smaller ones, today.

     

    This is THE bug.