Skip navigation

USB 3 on MacBook Pro-R Does Not Work!

13945 Views 33 Replies Latest reply: Mar 7, 2013 10:42 AM by DileepVarala RSS
1 2 3 Previous Next
TKDigiCom Level 1 Level 1 (5 points)
Currently Being Moderated
Jul 6, 2012 2:54 PM

Hi All,

 

In 1 sentence:

I have a brand new MBP-R and I have found that external USB 3 drives do not work!

 

Details:

I have the base MBP-R, all updates installed.

I've bought and tried, 2 '11-'12 Seagate GoFlex Desk 3TB, 1 Mid '12 Seagate GoFlex Desk 3TB (white box), and 1 Western Digital My Book 3TB.

After formatting any of the Seagate's to Mac OS then ejecting the HD, none of them will re-mount.

After formatting the WD to Mac OS it will only operate at USB 2 speeds. I did not test the speed before formatting to Mac OS.

 

I've bought each of the HD's at Best Buy, and I have spent an hour with the Geek Squad working on the issue with no success.

 

I have spent over 3 hours with Genius’s at 2 different Apple stores with no success. No one at apple supposedly had heard of this problem. We did test a Seagate drive on 2 other MBP that the Apple store had on display and the drive would not mount to either MBP-R.

 

When I say the drives would not mount I mean that they do not show up in Finder or in Disc Utility.

 

Sometimes (not all the time) the drive is visible in the System Report.

 

One genius said the problem may be fixed in Mountain Lion… but it may not.

 

Basically I’ve spent thousands of $’s on a defective product with advertised features that that do not work. I am very disappointed in Apple.

 

BTW all the drives worked on my Windows PC!

 

Tim

MacBook Pro with Retina display, Mac OS X (10.7.4)
  • BGreg Level 6 Level 6 (17,500 points)
    Currently Being Moderated
    Jul 6, 2012 3:40 PM (in response to TKDigiCom)

    Since this is a new system, have you called Apple Support? You have 90 days of phone support, and they may have insights that the genius's dont have.

  • Bimmer 7 Series Level 6 Level 6 (10,265 points)
    Currently Being Moderated
    Jul 6, 2012 3:46 PM (in response to TKDigiCom)

    I'm just guessing on this one.

     

    Is it possible that your MBP-R USB port does not have enough power to make your external drives work?

     

    If you have one, try hooking up a powered USB hub, plug your external drive to the HUB and see if it mounts on your MBP-R.

     

    Again, that is only a guess.

  • Bimmer 7 Series Level 6 Level 6 (10,265 points)
    Currently Being Moderated
    Jul 6, 2012 3:58 PM (in response to TKDigiCom)

    Your external drives are fine then.  I didn't know they were powered drives.

     

    I thought they were being powered by the Retina's USB ports.....

     

    You don't need a HUB.  I think it's an issue with your MBP-R USB port.

     

    My suggestion is to take it to the genius bar and show them in person what your Retina is doing.

     

    Good luck...

  • Bimmer 7 Series Level 6 Level 6 (10,265 points)
    Currently Being Moderated
    Jul 6, 2012 4:14 PM (in response to TKDigiCom)

    You're welcome.......

     

    Sorry i couldn't much help.....

     

    I ordered a Retina and have 2-1/2 weeks left before I get it.  I hope I don't have the same issue since my external is not a powered one like yours.

     

    Have a good day....

  • keg55 Level 5 Level 5 (5,610 points)
    Currently Being Moderated
    Jul 6, 2012 4:18 PM (in response to TKDigiCom)

    Try some of the solutions at this link.

     

    My USB 3 ports worked right off the bat. However, after doing a speed test with a USB 3 (WD My Passport Essential) in the left port and a USB 2 in the right, the right port stopped identifying USB 3. All I did was unplug the USB 3 cable from the right port, unplugged the physical USB 3 drive from the cable, plugged the USB 3 cable into the right port and finally plugged the USB 3 drive into the cable. Opened System Report and the port showed USB 3 again.

     

    The above worked for me. There are other solutions in the link I provided. I don't know if any of that link will help with the issues you're experience with the drives not showing up. Check the "About this Mac / More Info / System Report / USB (under hardware)" and see if the drive(s) show up under any of the USB buses.

  • peterjay45 Calculating status...
    Currently Being Moderated
    Jul 6, 2012 4:24 PM (in response to TKDigiCom)

    If I am reading the last page of this thread correctly, https://discussions.apple.com/thread/4044696?start=45&tstart=0, Keg55 found that by removing the USB cable from his drive, plugging it into the USB 3 port and then into the drive caused it to be recognized and function correctly.  Not sure if this would assist your situation and you may have tried this already.

     

    peter

     

    I see Keg55 has already responded to this. 

  • keg55 Level 5 Level 5 (5,610 points)
    Currently Being Moderated
    Jul 6, 2012 4:38 PM (in response to TKDigiCom)

    Well, sorry to hear that. There's another user (Solorboy123) in the discussion thread that peterjay45 provided who is having the same issue as you. The flipping drive is just not showing up in Finder or Disk Utilities, but shows up in System Report. You might want to keep an eye on that thread too in case he fines a solution.

  • psedog Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 7, 2012 9:27 PM (in response to TKDigiCom)

    I have a 2012 Seagate GoFlex Desk 2TB and it refuses to work on Lion. I have loaded the latest DP of Mountain Lion and it works pretty well with speeds of 130MB read and write. I honestly think that these laptops were never supposed to run Lion, but Mountain Lion wasn't ready at launch. Anxiously waiting for ML to come out officially

    MBPr 2012-07-01 at 9.37.46 PM.png

  • MacKyver Calculating status...
    Currently Being Moderated
    Jul 11, 2012 8:16 PM (in response to peterjay45)

    Hi peterjay45, I tried all the solutions posted in that thread, but my freaking Lacie USB3.0 drive connected via ExpressCard34 just wouldn't show up in Finder or Disk Utility even though System Report says it's connected!!

     

    How frustrating.

  • akuska Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 19, 2012 4:25 AM (in response to TKDigiCom)

    Did yesterday's software update address this?

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.