7 Replies Latest reply: Jul 11, 2012 9:24 PM by MacKyver
MacKyver Level 1 Level 1 (5 points)

Just bought a 3TB Lacie Quadra Drive with USB3.0, Firewire 800 and eSATA interfaces. With USB3.0 being the fastest interface among them, I bought the Lacie ExpressCard/34 USB3.0 card to use this drive with my 17" MBP 2010.

 

However, the ExpressCard doesn't recongnize my drives, or any USB2.0 devices connected to it. I even had a replacement card sent to me, same results.

 

Lacie is advertising that their ExpressCard is compatible with OSX10.5 and above but the latest USB 3.0 driver that Lacie released was version 1.07 which came out last year. I have emailed Lacie many many many times about this issue and they just wouldn't admit whether there is something wrong with thier 1.07 drive which was released before Lion came out. They would not confirm if there will be an updated release of the USB3.0 driver either

 

Will Lacie eventually update their USB3.0 driver to wok with Lion? I don't know. They neither confirm nor deny if their 1.07 driver is faulty or it's a problem with Lion. There is no consumer forum on their website either so I don't know if other users are suffering from the same problem.

 

Basically I have a Lacie Expresscard/34 USB3.0 that has become a paperweight, while Lacie continues to be silent on this issue.   Anyone elseexperiencing the same thing?


Macbook Pro, Mac Mini, Macbook, iPhone4, iPad, Mac OS X (10.6.6)
  • 1. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    Ozymandias_ Level 1 Level 1 (0 points)

    Identical situation. I was able to get an external 1Tb LaCie Rikki USB3 drive to mount on my MBP (mid-2010) running 10.6 via the LaCie ExpressCard 34 - this wasn't very reliable with frequent disonnections, each time with the warning that "the drive had not been disconnected properly" but since upgrading to 10.7 nada, nothing....... I also am using the v1.0.7 LaCie USB3 driver for Mac OS 10.6

    I have logged a support ticket with them and will post their response....if I get one. I have specifically asked tham if the issue is sriver related.

    Fingers crossed.

  • 2. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    MacKyver Level 1 Level 1 (5 points)

    Any luck with your support request? I've logged a support ticket too a couple of months ago, but they had me check everything on my Mac only to include that the card was defective without admitting that it's a driver problem.

     

    Even after they've sent me a new card, the problem still persists as before so I think it's definitely their driver issue that they wouldn't publicly admit. My hope is counting on OSX 10.7.2 to "automagically" fix this problem but given the silence between Lacie and Apple, I really don't know if we'll ever get a fix.

  • 3. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    Ozymandias_ Level 1 Level 1 (0 points)

    Not as yet. Like a game of table tennis, I'm going back and forth from LaCie support. I think I might have a dodgy Rikki USB HDD as I could not reformat it following their exact instructions. However, like you, when I finally get the drive onto the desktop and check System Information, I'm told that the "USB Super Speed Bus" is operating at a speed "up to 480 Mb/sec" which as far as I know is the USB 2.0 standard not USB 3.0

  • 4. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    MacKyver Level 1 Level 1 (5 points)

    It's been some time since this was posted, have you managed to resolve the problem with them? My Lacie USB3.0 card is still in limbo land as of now.

  • 5. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    Ozymandias_ Level 1 Level 1 (0 points)

    No progress. I've tried everthing I know of and finally LaCie has offered me money back but I'm damned if  will let this beat me.....assuming of course that there are some people out their with the same MBP configurations successfully running with the LaCie ExpressCard 34.

    Problem is, I just don't have the time to keep trying. Over to you.......

  • 6. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    phvda Level 1 Level 1 (0 points)

    Astonishing to see that this problem should be long known to LaCie support, which was not the case when I called them for support (Belgium) on my failing 2big disks/USB3 card combi. I think I will exchange them for a more reliable esata/firewire version. Switching on your mac in the morning and not finding 6 TB of your main data you left there in the evening, that's no life. I think La Cie puts its reputation on stake, for this is not a good product, probably even not a product!

  • 7. Re: 2010 MBP with Lacie Expresscard/34 USB3.0 = fail on Lion?
    MacKyver Level 1 Level 1 (5 points)

    Now that Lacie has been bought by Seagate, I wonder if we'll ever see this supported? I just tried mounting the Lacie USB3.0 external drive on my MBP2010 with their own Lacie ExpressCard34 using their latest driver USB1.08 on Mountain Lion, even though "System Report" recognizes the "USB Super-Drive" but Finder just won't mount the drive and Disk Utility doesn't even show the drive either.