4 Replies Latest reply: Jul 12, 2012 11:04 AM by Devin Wyatt
Devin Wyatt Level 1 Level 1 (0 points)

Hi,

 

My company uses Office 365 for hosted Exchange email. We have 1 user who uses Apple Mail on OSX 10.7 to connect to the server in Exchange mode (using EWS). This was working great until a few days ago where he has sporadic connection problems. Reproducable situation below:

 

1) Select 100 emails in any given folder

2) Drag/drop those emails into another folder to move them there

3) They will start moving but it will fail at somepoint and give the message "Cannot execute move operation".

4) After that message appears it is usually several minutes before he can try again or send any emails.

5) Trying to send an email immediately after the error message results in the "Cannot send message using the server" dialog where you are prompted to select a different server to send the message. Choosing an SMTP server results in the message being sent but sometimes (and only sometimes) the message is resent a couple of hours later through the exchange system.

 

We are getting a million of the following assertion failure messages in the console:

 

06-06-2012 12:22:05.518  Mail: *** Assertion failure in -[EWSGetFolderResponseOperation handleResponseMessage:withObject:], /SourceCache/Message/Message-1278/MessageStores.subproj/EWSResponseOperation.m: 340

EWS did something wrong: An internal server error occurred. The operation failed. on EWS response <EWSGetFolderResponseOperation: 0x7fb9cb1ae620> (EXECUTING)

(

0   Message 0x00007fff8f712ef8 -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

1   Message 0x00007fff8f71308e -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

2   Message 0x00007fff8f662c64 -[EWSResponseOperation handleResponseMessage:withObject:] + 556

3   Message 0x00007fff8f656eb6 __-[EWSGetFolderResponseOperation executeOperation]_block_invoke_1 + 77

4   CoreFoundation 0x00007fff87979cee __NSArrayEnumerate + 718

5   Message 0x00007fff8f6572ae -[EWSGetFolderResponseOperation executeOperation] + 453

6   Message 0x00007fff8f73397f -[MonitoredOperation main] + 228

7   Foundation 0x00007fff9152e6b4 -[__NSOperationInternal start] + 705

8   Foundation 0x00007fff91541912 ____NSOQSchedule_block_invoke_2 + 124

9   libdispatch.dylib 0x00007fff8a798a86 _dispatch_call_block_and_release + 18

10  libdispatch.dylib 0x00007fff8a799965 _dispatch_worker_thread2 + 255

11  libsystem_c.dylib 0x00007fff8c83b3da _pthread_wqthread + 316

12  libsystem_c.dylib 0x00007fff8c83cb85 start_wqthread + 13

)

06-06-2012 12:22:05.518  Mail: Recieved EWS error: Error Domain=MFEWSErrorDomain Code=94 "An internal server error occurred. The operation failed." UserInfo=0x7fb9cecbb7c0 {NSLocalizedDescription=An internal server error occurred. The operation failed.}

 

We have tried deleting the account and making a new one. As well as removing the mailbox folder (~/Library/Mail/V2/EWS-*) and the Apple Mail plist file. We have also setup the email on a different Mac (also OSX 10.7) but we still get the same assertion failure message.

 

This user's email account works fine in Outlook on Windows and Mac (Outlook 2010 and 2011) and it also works fine through the online web portal. Outlook 2011 Mac uses EWS (the same protocol Apple Mail uses) and it's not throwing any errors and everything works properly so that is leading me to believe it's an issue with Apple Mail.

 

Perhaps related, perhaps not, but the user's iPhone and iPad have also stopped working properly with the account. They will sometimes connect but a lot of the time they give an error message about not being able to connect to the server. This leads us to believe it's an exchange server problem, but then why does it work in Outlook and the online portal without any problems? It's only the Apple products that are falling apart.


MacBook Pro, Mac OS X (10.7.4)
  • 1. Re: Apple Mail Assertion Failure
    IndyMichaelB Level 1 Level 1 (0 points)

    I'm having the exact same issue.  Did you ever solve it?

  • 2. Re: Apple Mail Assertion Failure
    Devin Wyatt Level 1 Level 1 (0 points)

    The problem ended up being the Office 365 Exchange server. Apparently (according to their tech support people) sometimes the web services start acting up and causing problems with all EWS clients (Apple Mail, Outlook 2011 Mac) and all ActiveSync clients (iPhone, iPad, etc.). Once they determine that the server is acting up they shift the user account to a different server and fix the old one. As soon as this shift happened (I noticed it because the server address in account settings automatically changed to the new server) the problem disappeared.

     

    So unfortunately I don't have a solution that you can use to fix the problem. Are you also using Office 365?

  • 3. Re: Apple Mail Assertion Failure
    IndyMichaelB Level 1 Level 1 (0 points)

    Devin, thanks for the quick response.  Yes, we are also using Office 365

  • 4. Re: Apple Mail Assertion Failure
    Devin Wyatt Level 1 Level 1 (0 points)

    I ended up having to reproduce the problem in Outlook 2011 Mac before O365 support would help me. Apparently Apple Mail isn't one of the officially supported clients so they weren't going to figure it out for me. Once they ran out of ideas they just gave me the "Apple Mail is officially supported" excuse and stopped helping me.

     

    Although we weren't initially having the problem in Outlook 2011 Mac it did start giving tons of errors during certain operations (with a -19907 error code) after a while. Not sure why it started doing that ... but it did. This was only happening with one of our user's accounts so it had to be something server-side that was the problem. I eventually got a support ticket in their system (despite being a P1 plan holder) so that they could call me. We did some Wireshark capturing to try to diagnose the problem but by that time the problem had fixed itself.