Skip navigation

Getting Permission Errors with 10.7.3

2332 Views 10 Replies Latest reply: Oct 18, 2012 4:35 PM by mb_spikefin RSS
Mirsky Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 1, 2012 11:57 PM

Hello, a few hours ago I installed the update from Lion 10.7.2 to 10.7.3

 

Now, I can't save in some of my programs. I get errors saying I don't have permission to save the documents. So far, I've found this error in Pages 09 and Rapidweaver 5. I'm guessing other programs are also affected but those are the two programs I've tested so far. Both programs are important for me because of some work I'm currently doing in them.

 

I restarted in the Recovery Partition and ran Disk Utility to Repair permissions on my startup drive. It found errors and repaired them. Then I restarted with my startup drive. However, Rapidweaver and Pages are still giving me the errors.

 

The specific wording of the errors is:

 

"The document ___ could not be saved. You don't have permission. To view or change permissions, select the item in the Finder and choose File > Get Info".

 

I did go to Get Info > File but I didn't know what to change. Also, I don't want to have to change permissions one file at a time.

 

I have no idea how to fix the problem and it's really affecting my ability to get some necessary work done.

 

Thanks.

  • dwb Level 6 Level 6 (19,695 points)
    Currently Being Moderated
    Feb 2, 2012 4:37 AM (in response to Mirsky)

    Running the Disk Utility permissions repair isn't going to solve your problem. What it fixes and what you have going on are two different things.

    sample.xls Info.png

    When you select a file or folder and do Get Info you'll see a dialog box and the picture above is what's at the very bottom. You may have to click the disclosure triangle next to Sharing & Permissions to see it. There are three permissions to a regular file. The first is the owner (which should be your account name) the second is staff (which we can ignore for now, it's useful on networks but not so much to individual users) and everyone. As you can see, I have Read & Write privileges. I suspect you're going to find that either your files belong to another account or that your privilege is no longer R&W. Another possibility is that you've disappeared as the owner.

     

    Click on the lock icon to edit the file's permission to change it. To change a permission click on the permission to see the options - you'll want read & write. If your account name is missing click on the plus and add your account name exactly as you use it to log in. You can perform this on an entire folder by selecting a folder of documents, changing the permissions of the folder and then clicking on the gear icon next to the + and select Apply to enclosed items...

  • Pekka K Calculating status...
    Currently Being Moderated
    Mar 6, 2012 3:04 AM (in response to dwb)

    Hi,

     

    Screen Shot 2012-03-06 at 8.00.14 AM.png

     

    I'm having the same problem. It's occuring with Xcode. The Read & Write privileges seem to be in order. I even can't quit Xcode because of the autosave feature. Needless to say, I'm not able to do any work before the problem gets solved.

     

    pk

  • Pekka K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2012 3:26 AM (in response to Pekka K)

    This is how I fixed it:

     

    >cd /private/var/folders

    >sudo rm -Rf *

  • stefanvincent Calculating status...
    Currently Being Moderated
    Apr 27, 2012 5:15 PM (in response to dwb)

    I also upgraded to OS X I0.7.3. I followed dwb instructions to the letter. I am the owner, have r&w permission and have been applying it to enclosed items. Problem NOT solved. I cannot save, move files, rename, sometimes not even OPEN the file... What is wrong with Security & Privacy permissions?

    Stefan

  • samuelg0rd0n Calculating status...
    Currently Being Moderated
    Jul 12, 2012 10:58 AM (in response to Mirsky)

    I have the problem with permissions too but it's not related only to Preview. Sometimes, I am not even able to save something in Photoshop. Right know I wanted to save my work in iWork - Numbers and it's not working! I am quite irritated. All the permissions ARE definitely correct so it's not an actual permission error. I have the strange feeling that it started after I ran disk permission repair!

  • samuelg0rd0n Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2012 11:17 AM (in response to Mirsky)

    I believe I have found the solution. It's only a couple of minutes testing now but everything works so far. Follow this tutorial http://blog.chron.com/techblog/2011/09/want-to-really-repair-permissions-on-your -mac-try-this/ Big thanks :-)

  • mb_spikefin Calculating status...
    Currently Being Moderated
    Oct 18, 2012 4:35 PM (in response to samuelg0rd0n)

    I am having the same problem for all my iWorks apps. Running 10.7.5 (just run s/w update which believe created the issue).

     

    samuelg0rd0n, I tried the steps suggested in the blog. Done also:

    - Quit app, restart Mac

    - Disk Utilities > Repair Permissions

    - Checked permissions for the "Autosave Information" folder(s)

     

    Anybody has any other suggestions?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.