Skip navigation

Mail NOT sending when setting main.cf relay host

968 Views 1 Reply Latest reply: Jul 13, 2012 7:50 AM by Tony Baker RSS
Tony Baker Level 1 Level 1 (55 points)
Currently Being Moderated
Jul 13, 2012 7:16 AM

I have a client with a legacy Xserver running 10.4.11 ( dont ask - I just have - and have to work with it)

 

I have a script that sends mails to various external addresses and one internal address

 

If I leave this machine to its own devices (mailservices = off)

The mail tries to send out to an external public address and the external mails are sent, but the internal ones are not with the following message being recorded in /var/spool/postfix/defer

delivery via cyrus: temporary failure. Command output:

   couldn't connect to lmtpd: Connection refused_ 421 4.3.0 deliver: couldn't

   connect to lmtpd_

 

There are no logs in /var/spool/mail.log   at all - nothing

 

If I set the main.cf file to use

 

relayhost = mail.company.com

 

nothing gets sent at all   -   with the following being logged

 

<tony@shop.co.uk>: delivery via none: Host or domain name not found. Name

   service error for name=mail1.company.local type=MX: Host not found, try again

 

Here is my postconf -n

 

services:/etc/postfix root# postconf -n

command_directory = /usr/sbin

config_directory = /etc/postfix

daemon_directory = /usr/libexec/postfix

debug_peer_level = 2

enable_server_options = yes

html_directory = no

inet_interfaces = localhost

local_recipient_maps = proxy:unix:passwd.byname $alias_maps

luser_relay =

mail_owner = postfix

mailbox_size_limit = 0

mailbox_transport = cyrus

mailq_path = /usr/bin/mailq

manpage_directory = /usr/share/man

mydestination = $myhostname,localhost.$mydomain,localhost,company.co.uk,company.local,companygr oup.co.uk

mydomain = jbw.co.uk

mydomain_fallback = localhost

myhostname = services.company.co.uk

mynetworks = 192.168.121.0/24,192.168.121.70/32,127.0.0.1

mynetworks_style = host

newaliases_path = /usr/bin/newaliases

queue_directory = /private/var/spool/postfix

readme_directory = /usr/share/doc/postfix

sample_directory = /usr/share/doc/postfix/examples

sendmail_path = /usr/sbin/sendmail

setgid_group = postdrop

smtpd_tls_key_file =

unknown_local_recipient_reject_code = 550

 

 

Anyone have any ideas why

Nothing is being logged at all in mail.log

 

I do have the following in /var/log/asl.log

[Time 2012.07.12 22:03:36 UTC] [Facility local6] [Sender deliver] [PID 5441] [Message connect(/var/imap/socket/lmtp) failed: Connection refused] [Level 3] [UID -2] [GID -2] [Host services]

[Time 2012.07.12 22:03:36 UTC] [Facility local6] [Sender deliver] [PID 5440] [Message connect(/var/imap/socket/lmtp) failed: Connection refused] [Level 3] [UID -2] [GID -2] [Host services]

[Time 2012.07.12 22:20:12 UTC] [Facility local6] [Sender deliver] [PID 5515] [Message connect(/var/imap/socket/lmtp) failed: Connection refused] [Level 3] [UID -2] [GID -2] [Host services]

 

How I can get the mail delivered to the internal address sent as well as the externals?

Xserve, Mac OS X (10.4.8), Intel and PPC systems

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.