1 2 Previous Next 17 Replies Latest reply: Sep 5, 2012 1:06 PM by J. Night Branched to a new discussion.
cmtulo Level 1 Level 1 (0 points)

This lag is debilitating.  So far I have only experienced it on the Windows 7 (64 bit) side of my Bootcamp partition, but I have not attempted to run such applications in the OSX side.

The Problem:  About every 5.1 to 5.2 seconds, the framerate drops to a standstill.  As this happens over and over again, the duration of the stutter increases until after about an hour it is equal parts smooth and lagged.  Despite the increased duration, the periodicity remains between 5.1 and 5.2 seconds by my stopwatch.  Eventually, the lag becomes so great that the applications become unusable.

I have found this problem in the following applications:

TERA Online

Guild Wars2

Star Wars The Old Republic

I have also found forum discussions citing the same symptoms in Diablo 3, although I have not played or installed that game on my own system.

 

This appears to be a common problem across all these graphics-intensive games specifically centered around the iMac.  This is why I am bringing this up to the Apple community.  Has anyone else seen this phenomenon?  Is there a solution?   I did just update the Radeon HD 4850 graphics drivers.  Could that have something to do with it?


iMac (27-inch Late 2009), Windows 7
  • 1. Re: Periodic lag experienced in graphics-intensive application
    The hatter Level 9 Level 9 (58,880 points)

    update your graphic driver there are bookmarks and more here and try that

     

    use something like AIDA64 Extreme to monitor fans, temps, gpu and memory

     

    clean up your registry and system with CCleaner and Driver Sweeper 3.2

     

    All of those are here and Google or from Cnet and Softpedia.

  • 2. Re: Periodic lag experienced in graphics-intensive application
    cmtulo Level 1 Level 1 (0 points)

    One other thing I forgot to mention:  This lag occurs no matter what graphic settings I use in the applications (although I didn't exhaust all graphic settings permutations).  It does not go away unless I reboot the system.  Closing and re-opening the client software does not fix it.  And as I mentioned, I did  get the latest drivers from AMD/ATI.

  • 3. Re: Periodic lag experienced in graphics-intensive application
    The hatter Level 9 Level 9 (58,880 points)

    Most people, esp. in the past had major problem updating GPU driver (thanks AMD to making it better) but isn't straight forward.

     

    So just surprised and making sure you did - latest Boot Camp 4.01 is not the latest though some seem to think it is up to Apple to do so.

     

    Also, the auto detect program AMD has generally does not work on most Mac models.

     

    The other part of my post was to do some deep cleaning and sytem maintenance - which you have done too?

    After that I'd see what fans and temps (fans do not work properly under Windows on Mac)

    chkdsk

    memtest from Windows 7 DVD

    Disk Cleanup

    Make sure to limit the size of page file if you have 8GB

    Insure you have 10-20GB of free space

     

    Look at Resource monitor of course to see what may be cause

     

    Microsoft Security Essentials and Malwarebytes have a light footprint but it is possible a security suite or even high ping from your ISP

  • 4. Re: Periodic lag experienced in graphics-intensive application
    cmtulo Level 1 Level 1 (0 points)

    Interestingly, when I turned on my computer this morning, it got stuck in the boot process.  The revolvong timer under the apple logo took about three minutes to clear and then I got stuck on the blue screen that appears before you see your desktop wallpaper.  I had to manually turn it off and restart it.  It started fine the second time.  The only thing I had done the day before was move my bootcamp folders into the privacy section of Spotlight as recommended on another forum. 

     

    When I launched bootcamp, I noticed one difference immediately:  the clock was correct.  I know this sounds silly, but the computer clock in Windows had been five hours off for over a week.  I've had to manually set it each time I boot into bootcamp.  Not today.  Also today there has been no lag as I have described above.  Whatever the problem was (or is), the symptoms have disappeared.  I wonder if it was related to the clock, and/or Spotlight. 

     

    In any event, I also took your advice and downloaded CCleaner and performed a drive analysis, cleaned it and my registry today.  I'll conduct some more tests, but so far the symptoms seem to have gone away.

  • 5. Re: Periodic lag experienced in graphics-intensive application
    gadget9 Level 1 Level 1 (0 points)

    I'm having the same problem with my early 2011 Macbook Pro. I'm trying to play TERA Online at the moment and it barely loads. I'm sure I downloaded the wrong drivers...any one know where I can find the correct ones?

  • 6. Re: Periodic lag experienced in graphics-intensive application
    cmtulo Level 1 Level 1 (0 points)

    I spoke too soon.     I took a few hours off the computer, came back, and the symptoms have returned.   I'm going to reboot to see if that resolves it again.  Man, this is frustrating.

  • 7. Re: Periodic lag experienced in graphics-intensive application
    MittoSFX Level 1 Level 1 (0 points)

    Have you come to a solution? I'm experiencing the same problem on my brand spanking new MacBook Air 13" Mid 2012 with 8GB upgraded RAM.

  • 8. Re: Periodic lag experienced in graphics-intensive application
    cmtulo Level 1 Level 1 (0 points)

    MittoSFX, For several weeks, I did not experience those symptoms, but they just started up again two days ago (12 July).  I saw it in The Secret World game.  That is too much of a coincidence with your post.  I am wondering if it was due to the latest Windows update.

  • 9. Re: Periodic lag experienced in graphics-intensive application
    MittoSFX Level 1 Level 1 (0 points)

    Thanks for your fast response cmtulo, I can best explain these periodic lags as random jitters on my MacBook Air 2012 w/ 8GB RAM upgrade. To my dismay, I get these lags when I'm playing a game on Boot Camp Windows AND Lion. Games like League of Legends, Team Fortress 2. I have noticed that these games scorch my CPU up to 90 degrees celcius in temperature. So when I thought that lag was due to a heat problem, it wasn't when I experienced those same lags even when I'm playing a less-intensive, simple 2D game on Boot Camp! And yesterday morning, the keyboard input and HD video on Youtube started showing the same symptoms on Lion. So overall, TL;DR, random jitters (periodic lags) everyday, everytime, everywhere.

     

    I'm beginning to believe that this is a hardware problem, because I reinstalled my Windows via Boot Camp 3 times now and still experiencing the same lag AND in Lion. This is not cool. This is not what I got my new MacBook Air for. In the worst case of scenario, I might have to visit an Apple Store and have it checked.

  • 10. Re: Periodic lag experienced in graphics-intensive application
    The hatter Level 9 Level 9 (58,880 points)

    And apparently Turbo Boost does not work in Windows on the 2012 MacBook Air from multiple people confirming this lack of support... if that helps.

     

    And you ARE now using AMD driver, right? just to know, and see if it makes a difference.

  • 11. Re: Periodic lag experienced in graphics-intensive application
    J. Night Level 1 Level 1 (10 points)

    i recently posted a thread about the same problem i think.

     

    https://discussions.apple.com/thread/4251700

     

    no fix yet? ;( it's killing me! i can't stay on guild wars 2 without restarting my friggin mac every 30-40 mins.

  • 12. Re: Periodic lag experienced in graphics-intensive application
    MittoSFX Level 1 Level 1 (0 points)

    Much to my surprise, it stopped. I mean it really stopped. It doesn't exist anymore. I think it happened ever since I upgraded to Mountain Lion. No system lag (when CPU usage is low) and when I'm playing a game like Guild Wars 2 on Boot Camp (when CPU usage is high).

     

    Try removing Windows first (if you haven't after upgrading to Mountain Lion) then install Windows again through Boot Camp. I know, it's going to be tiring, but at least its worth a try for the future.

  • 13. Re: Periodic lag experienced in graphics-intensive application
    cmtulo Level 1 Level 1 (0 points)

    Just remember that Bootcamp and Windows 7 DO NOT include the latest drivers for your video card.  If you're running in OSX your graphics card is supported by Apple, but if you're running in windows, you're going to have to get the latest drivers yourself.  Your selection of operating system at start-up determines which drivers are loaded.  I think the July or August driver update from AMD addressed the lag issue.  I have not seen it since I updated earlier this month (August 2012).  Either that or some other issue was discovered and resolved. 

    Please post again if you ever see this lag issue come up again.  We all have a stake in this.

  • 14. Re: Periodic lag experienced in graphics-intensive application
    J. Night Level 1 Level 1 (10 points)

    I never used boot camp before until last week.. which was of course after upgrading to mountain lion since it was released. and i was aware of the video card drivers issue too. i tried to download the latest ones but they wouldn't install. i did some more reading and found out that i have to uninstall the boot camp drivers then could only install beta amd drivers. any other full releases just won't install, saying the video card is not compatible or whatever.

     

    this lagging problem is seriously ******* me off and i'm already considering getting a gaming laptop.. which is too extreme for me. its either that, or wait some more till the new imacs. hopefully sometime soon..

1 2 Previous Next