Skip navigation

Aperture 3.3.1 suddenly won't launch

953 Views 14 Replies Latest reply: Sep 14, 2012 8:28 AM by Jabberwocky85 RSS
Localboy56 Calculating status...
Currently Being Moderated
Jul 15, 2012 10:03 AM

My 2009 iMac 21.5" had to be replaced after the hard disk and logic board both suddenly failed. Luckily I had backed up my data recently. I started by migrating data and apps from my 2007 Macbook. Then I updated the Aperture library from the vault on my external hard disk. So far so good with one anomaly, the Aperture trash  wouldn't show any files unless I clicked on the individual projects. Other than that it worked OK. BTW I notice that the trash in the Aperture on my Macbook also doesn't show files at the root level of the trash folder. Anway, Aperture was working normally up to maybe a couple of days ago.

 

Today I tried to open Aperture and it bounces once in the dock and then will not launch. Several restarts did not fix whatever the problem is.

 

I tried trashing the Aperture application as well as the pref file and application support folder then reinstalling Aperture from the Mac App Store. No luck there. I also tried reinstalling OS 10.7.4 from the combo update and no success. Aperture still bounces once in the dock then... nothing. I noticed in my Library folder that no new Aperture preference file or app support folder have been created.

 

Things I'm considering doing next:

• Copy the Aperture Library from my Macbook onto the iMac and see if that one opens?

• Copy the Aperature pref file and app support folder from my Macbook onto the iMac?

 

 

I'm kind of at a loss for how to proceed so any help would be appreciated!

iMac, Mac OS X (10.7.4), Aperture 3.3.1
  • windhoveruk Level 2 Level 2 (300 points)
    Currently Being Moderated
    Jul 15, 2012 12:51 PM (in response to Localboy56)

    Hi...

    I think your issue is because you migrated apps... Not good to do this. Never migrate apps. Always do a fresh install....

     

    Here ( at the bottom of the page ) is detailed instructions on how to do a fresh install... This may resolve your issue....

     

    BE SURE TO DO A BACK UP BEFORE COMMENCING WITH A FRESH INSTALL....

     

    http://support.apple.com/kb/HT3805

     

    Kind regards... Gerry

     

    Message was edited by: windhoveruk

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 15, 2012 2:06 PM (in response to Localboy56)

    Are there any clues why it will not launch? Error messages or diagnostics in the Console window?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 15, 2012 2:38 PM (in response to Localboy56)

    Your crash report shows that your system library is corrupted and a framework is missing, the NyxAudioAnalysis framework. Did you install any new multimedia applications lately?

     

    To fix your system library the best option would be to reinstall your operating system: I'd us the

    OS X Lion Update 10.7.4 (Client Combo)

    to  renstall.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 16, 2012 2:29 AM (in response to Localboy56)

    Hmm. the Combo Update should restore the Libraries. If it did not do so, go ahead and restore from your Time Machine backup.

     

    Maybe there is a problem with your system hard drive. It would not hurt to let Disk Utility check the file system.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 16, 2012 6:38 AM (in response to Localboy56)

    You are welcome.

    Great, that you could get Aperture fixed and your pictures back.

    Still some mysteries to me

    I have never seen that particular framework missing. If you happen to remember something particular that happened at that day and might have changed the libraries - any installation, crash, please let us know. It is really peculiar, that the plug-in manager framework was the sole survivor. Usually this framework (and an installation of final cut) is the source of library trouble.

     

    Regards

    Léonie

  • Glenn Cogar Calculating status...
    Currently Being Moderated
    Sep 3, 2012 2:02 AM (in response to Localboy56)

    Hi all,

     

    it sounds like this particular issue has been resolved but just in case others are looking for an answer and this does not work (like me until earlier today) See https://discussions.apple.com/thread/4147538

     

    I found that by going to the System Preferences and logging out of MobileMe worked for me.  Ive been using iCloud for a while but never thought I had to also log out of MobileMe on my non Mountain Lion Macs.  I thought that as I was now using iCloud and MobileMe was finished there would be no need.

     

    For some strange reason Aperture was affected by me being logged into MobileMe and once I logged out Aperture started normally.

     

    Just a tip for anyone else still looking for an answer to Aperture not starting and you have already tried some of the other tips.

  • Jabberwocky85 Calculating status...
    Currently Being Moderated
    Sep 14, 2012 8:28 AM (in response to Glenn Cogar)

    Just wanted to say thanks for this. I have been struggling for weeks with a non-launching Aperture on my mid-2007Macbook which I cant update to Mountain Lion....

     

    ... signed out of MobileMe, and voila ... Aperture works!!!

     

    So thank you very much for the post.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.