Skip navigation

Printer job "On hold (authentication required)"

101104 Views 72 Replies Latest reply: Apr 6, 2014 2:53 PM by Ber121b RSS
  • matthewdebeyer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 17, 2012 2:53 AM (in response to caw35slr)

    Anyone still battling with this "Authentication Required" when connecting to a shared printer connected to a Windows 7 PC try what I did, sorted out the issue.

     

    Open keychain access and delete all passwords/items linked to the problem printer.

     

    Try send a print through again.

     

    It should now give you a dialog box to enter a username and password.

     

    Enter guest/guest.

     

    Check remember in keychain.

     

    Ok.

     

    This worked for me after trying everything else.

     

    Good luck!

  • Macounette Level 1 Level 1 (5 points)

    I got this problem after a very long troublefree period - so long in fact that I didn't remember how I had solved it in the first place. Everything went fine until we changed our network setup (new router, modem, yadda).

     

    - In the Printer & Scan pref. pane, delete the printer

    - Create a new printer, BUT don't give it the same name as before. So in the "Name" field, enter something else.

    - Proceed as usual. Select the driver, etc. Save. Print.

     

    This worked for me after trying a lot of other, far more sophisticated options.

  • Quentin Reidford Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 16, 2012 6:50 AM (in response to Macounette)

    Hi

     

    I have just experienced this problem and I do not wish to attempt describing why it may have happened!

    I am all OSX with two laser printers networked all worked as expected until the arrival of a new machine running Lion, although an upgrade to that carried out on my Power Book did not give me any problems at all.

     

    I discovered that although networked through hubs there is a computer assigned as the print server - to find which this is go to printer/fax in preferences use the + as if to add another printer - in the add printer dialog choose the windows tab (I know! you don't use windows either) then click workgroup and the computer acting as the server should be there and when you expand thatyou should see the problematic printers.

     

    In the system preferences of the 'server' computer go to print/fax and remove all the printers - then do exactly the same in the prefs. on the problematic computer. Back to the server and add back the printers, Finally add the required printers on the 'problematic' computer and test the results - which should now be fine.

  • myztiko Level 1 Level 1 (0 points)

    Hi,

     

    Your solution worked for me.  When the login window shows I just used guest/guest and the printing job works perfect.

     

    Thanks...

  • philipco Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2012 4:51 AM (in response to myztiko)

    I just deleted the printer and reinstalled it. That worked. However, as a new Macbook user, I must make the following comments:

     

    It is outrageous that things like this should happen without ANY input from Apple who are responsible for this OS.

     

    The operating system is an amateurish joke. It is unstable, and appears untested. I really don't know how Apple get away with it. Since switching from Windows my productivity has gone through the floor.

     

    As the Macbook itself is a nice piece of hardware, I am going to buy a copy of Windows and install that. Had enough. Apple can shove their OS where the sun don't shine. They ought to call the next major release "Dead Parrot", because its likely to be about as useful.

  • PlutoM Level 1 Level 1 (0 points)

    Thank you... mine is now working...

  • suhamdysham Level 1 Level 1 (0 points)

    Works for me too. Well, after a half working day. My setup was Mountain Lion and Canon LBP3050 on a Windows 7 shared printer. Downloaded the driver from Canon Support Site and installed it. Add printer via "Print & Scan" and discover the printer using "Windows" tab. Just use the Guest account for the first time the setup ask and use the same Guest account for the 2nd time (Being asked when you want to print). Smooth!

  • wortell Level 1 Level 1 (0 points)

    @matthewdebeyer - (you rawk!) thx for taking the time to put this on the forums. Saved the day for me And, my 2.5 yr old who wanted the .pdf of some disney character printed out .  The popup was driving me bananas.

  • Marion Dobbs Level 2 Level 2 (175 points)
    Currently Being Moderated
    Sep 10, 2012 9:01 PM (in response to Macounette)

    Macounette...This solved my printer authentication problem, thanks!

  • itsmillertime65 Level 1 Level 1 (0 points)

    @matthewdebeyeryou sir are a printing pimp! Your directions helped a lot. One comment though... I'm on OS X Mountain Lion and even after deleting the keychains linked to the printer and trying to print again the user/password box wouldn't pop up. I had to go to Jobs>Resume Job and then the password dialog appeared.

  • ruthelycan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 18, 2012 8:09 AM (in response to caw35slr)

    Thanks Matt! I literally struggled for two days getting this right - yours works! Simple as that?!

  • Sandoer Level 1 Level 1 (0 points)

    Well done and thank you Matthew! Solved the problem perfectly.

  • HTChan Level 1 Level 1 (0 points)

    This solved my problem!! thank you so much!!

  • Kevin Neal Level 2 Level 2 (475 points)
    Currently Being Moderated
    Oct 24, 2012 1:43 AM (in response to HTChan)

    or simply

     

    dseditgroup -o edit -a everyone -t group _lpadmin

  • tageek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2012 5:50 PM (in response to caw35slr)

    In the printer queue, where you see the "Hold for Authentication" message, just click the refresh icon.  A dialog should appear where you an enter your network credentials.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.