4 Replies Latest reply: Nov 21, 2012 7:42 AM by Clif H
TechAddict Level 1 Level 1 (0 points)

Been battling for hours trying to get the bog standard reader to work with a new MBP running 10.7.4.  It downloads and installs OK and I get the licensing page but after clicking 'Agree' I just get 'An Internal Error Occurred'.


Suffice it to say this is driving me mad now.  I've tried deleting, re-installing, eliminating all traces of Adobe from User and Root libraries under Application Support, Preferences and also Internet Plug Ins.  I've also tried the (not) fix of installing Java Runtime.


All in all, epic fail. NOTHING seems to fix it and I think it's time to give up with Adobe Reader and find something else or just stick with preview.  So much time to fix a bog standard application (maybe I should stick with Windows where "It just works").  Really is a royal PITA.  I've scoured the net for problems and I'm just wondering if it's a commong problem seeing as I don't see many others reporting it.  I certainly don't plan on doing a full system restore just to sort this out.


Anyone come across it or got any ideas to save me wasting yet more of my life on this?  Any hep appreciated.

  • 1. Re: Adobe Reader 10.1.3 - Internal Error Occurred??
    TechAddict Level 1 Level 1 (0 points)

    Having done more digging - I have a second 'admin' user on the Mac, just in case I ever have problems with the one I use day to day.  When I logged is as THAT administrator, Reader opened and worked.  So it seems it's something to do with where it's installing the files and, more importantly, what permissions it's granting.  Will try deleting that user account and reinstalling again where it effectively only has one route to go.  Why on eart it's creating these problems I don't know.  I would not think it uncommong for some machines to have more than one admin.  Something isn't right though. Just hope that this fixes it so I can get on with what I SHOULD be doing rather than faffing around with rubbish installers!!

  • 2. Re: Adobe Reader 10.1.3 - Internal Error Occurred??
    TechAddict Level 1 Level 1 (0 points)

    Right. After almost a day I finally sorted the problem.


    Adobe Reader worked under the spare Admin account so I deleted that in case it was confusing the installer.  I then rerpaired persmissions.  I then re-installed Reader.  Same problem "Internal Error"!!


    So, I re-created another Admin account and opened Reader.  No problem.  After clicking accept licence it opened up with a question to make default or not.  After this I hunted through every folder and found that Under 'User/Librarary/Application Support/Adobe' there was an Acrobat folder.  When I checked the account I normally use there wasn't, and never was??  So I copied pasted a copy of the Acrobat folder into the same location on the non working account and all is fine.


    Problem for me is, why did this happen?  I wasted almost a day on this. Is it a problem with the installer, the Macbook or Permissions.  I checked permissions and they are identical to those on the spare Admin account.  So why did the installer not create the Acrobat folder on the main account from where it was installed?  Reason it concerns me is with regard to updates.  Will they also screw up?


    I'll try to explore further as times goes on but for now I have to say I've had enough of Acrobat and Lion for one day.  "It just works".  Really???

  • 3. Re: Adobe Reader 10.1.3 - Internal Error Occurred??
    Cohi Level 1 Level 1 (130 points)

    Just had the same symptoms, in my case Library/Application Support/Adobe was owned by root, for whatever reason, once I fixed that Reader worked as expected (i.e. it works but slooow).

  • 4. Re: Adobe Reader 10.1.3 - Internal Error Occurred??
    Clif H Level 1 Level 1 (115 points)

    Yes. Just delete the ~/Library/Application Support/Adobe folder, reinstall Adobe Reader, and working fine for me.