Skip navigation

Unable to open domain file (tried most tips here)

371 Views 5 Replies Latest reply: Jul 19, 2012 11:46 AM by Old Toad RSS
BeatingAround Calculating status...
Currently Being Moderated
Jul 18, 2012 5:39 AM

I recently performed a clean install of OSX over a wiped disk and, after having transferred my data, then discovered that I couldn't open my site in iWeb. I looked on the forums here and discovered that I had to recover my domain file from Time Machine. I tried that but was told that I didn't have permission to do so. Even after changing permissions through the info dialogue, I am still told I can't recover the file.

 

I have also tried simply copying and pasting the old domain file and am then told iWeb can't open the file (again having altered permissions). I have tried wiping the preferences and cache, as suggested here, and the file still won't open.

 

Am at a loss. I really need to be able to edit my site: I am applying for a new job and my online profile on my site is out of date, which looks sloppy and confusing.

 

Any further suggestions much appreciated in advance.

 

Thanks

  • Old Toad Level 10 Level 10 (113,225 points)

    What system are you using? If it's Lion did you try the following:

     

    In Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    To open your domain file in Lion or to switch between multiple domain files Cyclosaurus has provided us with the following script that you can make into an Applescript application with Script Editor. Open Script Editor, copy and paste the script below into Script Editor's window and save as an application.

    do shell script "/usr/bin/defaults write com.apple.iWeb iWebDefaultsDocumentPath -boolean no"

    delay 1

    tell application "iWeb" to activate

     

    You can download an already compiled version with this link: iWeb Switch Domain.

     

    Just launch the application, find and select the domain file you want to open and it will open with iWeb. It modifies the iWeb preference file each time it's launched so one can switch between domain files.


    WARNING: iWeb Switch Domain will overwrite an existing Domain.sites2 file if you select to create a new domain in the same folder.  So rename your domain files once they've been created to something other than the default name.

     

     

    OT

  • Old Toad Level 10 Level 10 (113,225 points)

    Since the previous didn't help try:

     

    1. move the domain file from your Home/Library/Application Support/iWeb folder to the Desktop (already done I guess from your post).
    2. launch iWeb, create a new test site, save the new domain file and close iWeb.
    3. go to the your Home/Library/Application Support/iWeb folder and delete the new domain file.
    4. move your original domain file from the Desktop to the iWeb folder.
    5. launch iWeb and try again.
  • Old Toad Level 10 Level 10 (113,225 points)

    Try running Disk Utility on your Time Machine hard drive and see if that will help. Otherwise ask in the OS X forum that you're running, Lion?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.