Skip navigation

PowerMac G4 (MDD) won't turn on - HELP!

4742 Views 17 Replies Latest reply: Apr 12, 2014 10:40 AM by BDAqua RSS
1 2 Previous Next
Richard Tanner Level 1 Level 1 (55 points)
Currently Being Moderated
May 28, 2011 3:19 AM

I've just bought a PowerMac G4 (MDD) Dual 1Ghz off eBay.

Connected it to my ADC monitor and power, pressed the power button and... nothing.

 

The power light comes on while I'm pressing it, but that's all.

 

I opened the machine, removed the RAM and tried it - nothing. I reseated the RAM and tried again - nothing.

I swapped the battery - nothing. I pressed the Reset PMU button for a few seconds - nothing.

I plugged in an old keyboard with a power button on it - but that did even less than pressing the button on the machine.

 

I have noticed that very occasionally a couple of lights on the main board come on for less than a second.

Occasionally the fan on the fold-down door will spin for a second.

 

I have tried to remove the main power cable to clean it, but I couldn't get it off the logic board. Instead, I lifted it as much as possible and then reseated it. That seemed to make the lights come on slightly more often and the fan spin a bit more - but I cannot be sure.

 

I've contacted the seller and asked if they had any problems - and not heard back at all.

The eBay description for the item shows it running, so I really hope it's nothing I've done (I'm sure that plugging it in and connecting it to a monitor shouldn't harm it!) but I really want to get it working, rather than my only other option - strip out all the useful parts and then try to sell what's left on eBay to try to recoup a bit of money.

 

Am desperate for advice that isn't just "Sounds like the PSU is dead" because those things are rare and usually more money than I paid for the whole stinking machine. PLEASE HELP!

  • Texas Mac Man Level 8 Level 8 (44,245 points)
    Currently Being Moderated
    May 28, 2011 6:02 AM (in response to Richard Tanner)

    Resetting the Logic Board

     

    Resetting the logic board can resolve many system problems. Whenever you have a

    unit that fails to power up, you should follow this procedure

    before replacing any modules.

    1 Unplug the computer.

    2 Press the Power On button on the front of the unit.

    3 Open the side access panel.

    4 Remove the battery from the logic board.

    5 Wait at least 10 minutes before replacing the battery.

    6 Make sure the battery is installed in the correct +/-

    direction.

    7 Reassemble the computer and test the unit.

     

    Note:

    This procedure resets the computer’s PRAM. Be sure to

    check the computer’s time/date and other system parameter settings

     

    Power Mac G4: Computer Does Not Power On, No Fan Movement

    http://docs.info.apple.com/article.html?artnum=95038

     

     Cheers, Tom

     

    anim-appleguy.gif

    PM G4 1.25HGz MDD, PB 12" G4 1.5GHz, Mac OS X (10.5.8), (10.4.11, 9.2.2) iSight 
  • Brewster Magneto Level 1 Level 1 (40 points)
    Currently Being Moderated
    May 28, 2011 8:04 AM (in response to Richard Tanner)

    I'd try unplugging/replugging the power supply's Molex connectors that connect to the logic board. With older electronics, sometimes simply reseating connectors makes a difference. But your power supply might've given up the ghost, too. One source is www.dvwarehouse.com/G4-Power-Supply-c-247_476.html.

  • Felini Calculating status...
    Currently Being Moderated
    May 28, 2011 8:56 AM (in response to Richard Tanner)

    I had the same symptoms as you're having on my MDD 1.25 a couple of months ago.  Went through all the possible culprits that you did...resetting pmu, removing/reinstalling ram, removing battery and disconnecting the powersupply from the main board, booting with the adc monitor detached, leaving it unplugged for days...etc. etc. nothing worked.

     

    I ended up getting a refurbished psu off of ebay and that was the problem for mine.  The one I got was ~$85 shipped to Hawaii but I've later seen refurbished ones for as low as $30. I was on the fence about parting it out or fixing it too.

     

    Good luck and hope you get it worked out.

  • BDAqua Level 10 Level 10 (114,765 points)
    Currently Being Moderated
    May 29, 2011 10:37 AM (in response to Richard Tanner)

    Can you check the voltages on the PSU?

     

    http://www.jcsenterprises.com/Japamacs_Page/Blog/D275729F-09DA-4FBB-96B3-BEEEB2C 04619.html

     

    You can convert an ATX PSU to use in an MDD...

     

    http://jimmykirk.com/?p=34

  • motox299 Calculating status...
    Currently Being Moderated
    Jun 10, 2011 5:24 AM (in response to Richard Tanner)

    I have all the same issues as described by Tanner, and have done the same.

    Has anyone tried New or Refurb MDD power supply or logic bd and gotten anywhere?

  • BDAqua Level 10 Level 10 (114,765 points)
    Currently Being Moderated
    Jun 10, 2011 10:14 AM (in response to motox299)

    It would all depend what is wrong, if it is one of those items that is defective, then there are many reports of replacing them curing the problem... but it caqn be so many things with MDDs.

  • jellero Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 8, 2012 10:23 AM (in response to Richard Tanner)

    i have the mdd  1.25 and one morning i turned it on and went to shower. came out and it was dead and my modem had restarted so i assume the power went off or surged. computer didn't do anything when i hit the button. i bought another one just like it for $100, pulled the hard drive and ram and put it in the newer one and all is well. now i am running two hard drives and have the older one for parts. i am suspecting the power switch is bad though because the newer one is so easy to turn on. i had to push the button just right and hard on the older one. j

  • DrakkenWar Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jun 10, 2012 11:16 PM (in response to Richard Tanner)

    While I have never owned a MDD, I did encounter the same issues with a QuickSilver a few years ago. Also purchased from eBay. Running in the pictures, and asured to run just the same when it arrived.

     

    http://www.everymac.com/systems/apple/powermac_g4/specs/powermac_g4_733_qs.html

     

    In the end, it did turn out to be a faulty power supply. While I would have loved to sink the money into the fix, I had a back Digital Audio Dual/533 that seemed to out pace the Quick in every way, so I ended up selling it on Criag's List for parts. I don't know if this will help. But I would be willing to say it's the PSU, if you can find one for a reasonable price, and if this is your primary mac it might be worth the money.

     

    ~Drake

  • OS 9.1 is the best!!! Calculating status...
    Currently Being Moderated
    Jun 21, 2012 3:16 AM (in response to Richard Tanner)

    hey seems like a common problem with this G4!!! cross finger my Gigabit ethernet G4 never got that symptom...

     

    didn't see that thread so I did my own...

     

    https://discussions.apple.com/message/18700021#18700021

     

    basically I thank everyone for the info I'm trying everything possible

  • OS 9.1 is the best!!! Level 2 Level 2 (195 points)
    Currently Being Moderated
    Jun 21, 2012 8:39 AM (in response to Texas Mac Man)

    actually texas man for me your info from the apple knb has gotten me back to the no power and just fast light when pressing the power button

     

    I did what people told (see my post) to remove the cooler plate from the processor and restart without it! this is a great stuff it works any time! but then I'm still stuck with no image and red light on the motherboard with no little fan turning

     

    the strange stuff is when pressing Shift + power when switching off the comp the actual small fan attached to them motherboard is turning so their is something  that doesn't its job.

     

    I tried another proc but nothing, another vid card nothing...

     

    cheers

  • OS 9.1 is the best!!! Level 2 Level 2 (195 points)
    Currently Being Moderated
    Jul 20, 2012 1:07 PM (in response to Richard Tanner)

    helllo all

     

    fortunetly I haven't bought a new power suply did the voltage test and it's in perfect working order the logic board is obviously dead

     

    cheers

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.