5 Replies Latest reply: Jul 22, 2012 11:28 AM by Ralph Johns (UK)
Border Heeler Level 1 Level 1 (55 points)

Hello!  I am having trouble with Messages beta - or having trouble configuring it correctly.  When I send a message from my desktop (using Messages beta) to another person with a Macbook (who has an Apple ID and iCloud account and all that), it will go to only her Macbook.  If I send a message from my iPhone, it will either go to her iPhone or her laptop, but not both, and I can't tell which one it will go to in advance.  That is particularly frustrating, as it seems to randomly choose which device to send the message to.  What do I need to do to make sure that all messages go to all of her devices?  Or, if I can't do that, how can I tell in advance which device I am sending it to when I use my iPhone to send a message?  Thanks for any help!

  • 1. Re: Messages aren't going to all devices
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    HI,

     

    It pays to make sure that All devices have no Messages of Any sort on them before adding the Apple ID to Settings > Messages > Received at > Caller ID

     

    Otherwise iPhone Number (original iMessages) can be excluded from Syncing.

     

     


    10:08 PM      Friday; July 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: Messages aren't going to all devices
    Border Heeler Level 1 Level 1 (55 points)

    Thank you, Ralph.  OK, I think that one or both of us on my end may have some settings incorrect.  I changed the settings - originally, the other person did not have her Apple ID listed in her Messages settings.  I set up both our settings this way:   For Settings > Messages > Receive at > Caller ID, I now have our email (Apple ID) checked, and NOT the phone number.  What is happening now is that messages sent from the phones are only going to the phones, and messages sent from the computer are only going to the computer.  Ralph Johns, can you help me out a bit with this?   Should we have our email address or our phone number checked at Settings > Messages > Receive at > Caller ID ?

     

    Also, can you clarify a bit what you mean by having no messages on the iPhone before setting the Apple ID?  Do you mean I should delete all messages first, and then add our Apple IDs?  I assume I can delete all messages and then remove and then re-add my Apple ID.

     

    Also, are there any special settings I need to have on our computers so that the messages go all places?  Lots of questions - sorry about that!

     

    Thank you!

     

    - BH

  • 3. Re: Messages aren't going to all devices
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    HI,

     

    ON the "Old Messages" front.

     

    Obviously the iOS devices could do iMessages to each other before Messages beta came out.

     

    If you are like me you keep some "Conversations" in a sort of "Open" state by keeping the last few Messages on the iPhone.

    I tend to be lazy and keep my wife's and children's messages still on show.

     

    As these tend to be iPhone to iPhone or iPad to iPhone (As the iPad Apple ID was to the iPhone's Number) they tend to get isolated from syncing with the Apple ID that is added to the phone.

     

    What seems to happen is people keep using those "old Messages" to call the contact again so the iMessages goes from the iPhone Number to whatever the contact called from.

    As Messages Beta is an Apple ID only it will not sync with the iPhone Number due to the old messages being on the phone.

     

    You end up with  sort of division of the ID's (the Phone Number being an ID in this case) and one set on conversation can appear to be "Private" from the other.

     

    I would delete all the Messages and as you say Delete and re-add the Apple ID.

     

    Once the iPhone in particular has the iPhone  number and Apple ID linked you should not have any trouble syncing and therefore seeing all messages on all devices.

     

    NOTES

    In the Address Book (Contacts lists) on the Mac the Address Card for the Contact should include the Apple ID and the iPhone number.

     

    Then when you start a New Message (See File Menu) and click the Blue + sign top right you should get the choice in the Contacts List to chose either the Number or the ID.

    Chose the ID to makes sure the other iOS devices like iPads also get the messages.  (it should sync either way but making it simpler will always help).

     

    Once you have a Contact listed in the "To:-"  Spot you can use their name like a drop down and select an ID or a iPhone Number.

    Obviously you can use this method to Check how you are calling someone.

     

     

     

     


    7:37 PM      Saturday; July 21, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 4. Re: Messages aren't going to all devices
    Border Heeler Level 1 Level 1 (55 points)

    OK, you are officially a genius.  This worked perfectly - all phones and computers are sending messages to all relevant phones and computers.  I cannot thank you enough - I never would have thought to try what you suggested. 

     

    Huge thanks!!

     

    - BH

  • 5. Re: Messages aren't going to all devices
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    Hi,

     

    You are welcome.

     

    Thanks for the Points

     

     


    7:28 PM      Sunday; July 22, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously