Skip navigation

"Waiting for changes to be applied"

62571 Views 43 Replies Latest reply: Feb 16, 2014 8:35 AM by Htangye RSS
  • mvb2717 Calculating status...
    Currently Being Moderated
    Nov 8, 2011 12:26 PM (in response to Element905)

    Okay.  I deleted all voice memos, closed all running apps on phone...it no longer is stuck on "waiting for changes to be applied", now it has been stuck on "waiting for items to copy" for 10 minutes!  I'm getting really tired of this, I just want to finish a **** sync on my phone, something I've never had a problem with.... I'm also waiting for all of my ringtones to come back on my phone, since half of them are missing, even though they are all there on itunes....  Any more suggestions with this new message??

  • mvb2717 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2011 12:42 PM (in response to mvb2717)

    LOL, spoke too soon, tried syncing again and it's now back to "waiting for changes to be applied".....

  • pardthemonster Level 4 Level 4 (1,140 points)
    Currently Being Moderated
    Nov 10, 2011 2:21 PM (in response to Element905)

    I just started getting this message on my iPhone 4S immediatelly after upgrading to 5.0.1.

  • Enabler1 Calculating status...
    Currently Being Moderated
    Nov 16, 2011 2:41 AM (in response to mvb2717)

    I was unable to sync using the cable. I had to disconnect and goto iTunes summary for the phone and check allow to sync with wifi. Then I went to the settings on the phone and selected wifi sync and started sync. I hope this helps.

  • David Bourne Level 2 Level 2 (345 points)
    Currently Being Moderated
    Nov 24, 2011 9:33 AM (in response to pardthemonster)

    My problem has been with my wife's iPad. All relevant software updated. I was able to sync all except photos (well apps, some music). While reading these messages I was 'waiting for changes to be applied', iTunes showed 'not responding...' at which point I've been force quitting. Following a comment about open apps on the iphone/ipad I decided to quit all the ipad apps. iTunes became 'responsive' again and indicated it was copying photos. It has stopped now but no photos on the iPad... I thought it was starting to work...

  • staubinr Calculating status...
    Currently Being Moderated
    Mar 2, 2012 5:56 AM (in response to Element905)

    I just has this same issue with my iP 4.  All I did was shutdown all open apps, ejected my iphone, plugged it backin then selected transfer purchases when I received the message "waiting for changes to be applied" I clicked apply and voilà it finally started to transfer.  BTW I did not have to delete my voice recordings.

  • elvis4prez Calculating status...
    Currently Being Moderated
    Apr 3, 2012 9:11 PM (in response to mvb2717)

    I got the "waiting for items to copy" error then the "waiting for changes to be applied" with the big "other" all in yellow.  I could not uncheck each subitem (contacts, music, podcasts,...) without it restarting the sync then going nowhere and hanging.  I deleted voice memos including the ones under Music, still nothing.  I retried syncing several times after restarting iPhone but still the same endless loop.  Despite all this info seemed to go back and forth like a regular sync.  I think it somehow got a corrupted file; I had a duplicate copy of a ringtone in my phone not seen on the iTunes Library that I think may have been the problem (it had the ! before it when I clicked on it).

     

    With my phone connected, I made another backup (right click on the connected device i.e. iPhone).  Then in Settings / General / Reset option hit Erase All Content and Settings.  I called this the "Nuclear Option" and prayed it would not take too long to recover.  I then started phone and restored from backup and most everything came up right except a few setting changes (default ringtone, no passcode lock) that didn't take too long.  Big hurrah: it went through the normal sync cycle okay without hanging on either message.

     

    Hope that helps.  I wasted a lot of time like a lot of the rest of you including a trip to the Apple Store Genius that was limited by the rarity of this (his words) though he did find the Voice Memo "fix" that helped a lot of people (not me!) and suggested the above pathway.  It may be related to the phone coming off midsync with a in-process writing of a file that left it corrupted (per the Genius).

  • FazalAhmad Calculating status...
    Currently Being Moderated
    Apr 22, 2012 5:53 PM (in response to Element905)

    i went to file then sync_____.

    hope it works

  • BoyterJim Calculating status...
    Currently Being Moderated
    May 13, 2012 7:36 PM (in response to FazalAhmad)

    I had the problem of iTunes never copying the sync to my iPod Touch. ITunes would go through step 5 then quit. After trying a lot of possible solutions, I uninstalled Mcafee Total Protection and the sync worked fine. I am going. To reinstall Mcafee but I am not sure that the sync will work afterwardsl. I am not sure that I want to try.

  • BoyterJim Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 10:02 AM (in response to BoyterJim)

    I take that partially back. My photoes were not synced to the iPod as rewuested. I am still working on tat problem.  My Aps and songs were synced as requested after removal of security software,

  • chiny3r3 Calculating status...
    Currently Being Moderated
    Jul 20, 2012 3:03 PM (in response to Element905)

    Well, I did a backup as soon as I connected my ipad to the new computer, it got stuck on step 3 for hours. So, I restored from backup then right clicked on the device on iTunes and selected transfer purchases and for some reasons, it started copying.

     

    Hope this helps

  • Patricia W Level 3 Level 3 (685 points)
    Currently Being Moderated
    Sep 27, 2012 10:06 AM (in response to chiny3r3)

    I just restored my iPhone to iOS6 and I have progressed from my iPhone not finding my iMac to getting hung "waiting for changes to be applied" ... however, as I was composing this I noticed that the progress bar on iPhone was moving and also on iTunes and it looks like the sync was successful.

  • sbojja Calculating status...
    Currently Being Moderated
    Sep 28, 2012 4:09 AM (in response to Element905)

    I ran into same issue. I unchecked the Tones from Sync. My Tones folder was missing and i guess it is looking for tones files. After the tones is unchecked, the sync is complete.

  • mr jimmy Calculating status...
    Currently Being Moderated
    Oct 24, 2012 7:16 AM (in response to AndyLeesES)

    shutting down the apps running in the background solved the waiting for changes to be applied

     

    thanks

  • Ronaldfrommt Calculating status...
    Currently Being Moderated
    Jan 1, 2013 12:54 PM (in response to Element905)

    I figured it out I just reset the device by going to gen.erace all settings and just reloaded the devive from my pc

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.