1 2 Previous Next 24 Replies Latest reply: Mar 14, 2013 3:05 AM by jur12
armenjc Level 1 Level 1 (0 points)

SYSTEM:

I'm on an 8-core 2.8GHz Intel Xeon with 10 GB RAM, 10.6.8 using Logic 9.1.7. in 64-bit. I keep my Logic files on a separate WD 1TB drive that is only 50% capacity. 

 

ISSUE:

I am getting a "Disk is too slow or System Overload" error when I add audio to my session.  In this last session I had only 14 stereo files, no plug-ins - audio only. And there seems to be no rhyme or reason in regards to the I/O LED being low or spiking and stopping the file from playing. I know it can't be a Sudden Motion Sensor because 1) aren't those only on lap tops? and 2) my computer is perfectly still and I get this error whether my file is playing on any one of my other 3 internal HDDs.

 

I've been reading similar discussions all over this board and there doesn't seem to a be a solution that's worked.  I've fussed with the audio settings, changing my buffer range from medium to large, my buffer size is always at 1024 when mixing,  Track/Mute is at SLOW RESPONSE, and Sample Accurate Information changed to OFF.  I've even moved my session to a different internal HDD and the same thing occurs.  I've repaired permissions, run Disk Warrior and TechTools Pro 6 and AppleJack, deleted preferences, blah blah blah.

 

I'm starting to think that there is no solution to this problem and that Logic and/or this computer is buggy or maybe this is totally normal and I'm expecting too much from this computer.  Any idea what might be going on and if there is a fix to this (other than switching to Nuendo on Windows)?

 

Screen shot 2012-07-19 at 4.18.32 PM.png


Logic Pro, Mac OS X (10.6.8)
  • 1. Re: slow disk audio
    Pancenter Level 5 Level 5 (7,640 points)

    What sample rate / bit-depth are the audio files?

     

    Also, set the I/O buffer to 256 and the process buffer to medium or small.

     

    Your external drive was formatted MacOS Extended by you, correct?

  • 2. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    Audio files are 44.1, 24-bit.  The HDD drive I use for audio is one of my four internal drives (not my system drive) formated MacOS Extended by me.  Changing the I/O buffer to 256 and the process buffer to small or medium didn't make a different. I prefer to keep my I/O buffer at 1024 when I mix since I use a UAD2 card for DSP.  Thank you for replying though.

  • 3. Re: slow disk audio
    Eriksimon Level 6 Level 6 (10,820 points)

    Have you set all you audio tracks to No Input ? That sometimes helps. Also, is it your CPU meter that's peaking, or the Disk Activity meter?

    The fact that the message mentions the SMS, doesn't mean it is the cause. The message lists three possible causes. It can be any of these three, or any two of these three, or all three.

  • 4. Re: slow disk audio
    Pancenter Level 5 Level 5 (7,640 points)

    Ok, you didn't mention the UAD in your original post..

     

    The UAD plugins aren't being used when this happens, correct, you said... "no plugins"

     

    Whenever UAD/Mac/Logic is involved I always suspect (as Erik hinted) a system bus overload rather than a disk overload. The system bus has become saturated and all of the data cannot be transferred without an error. A combination of the UAD hardware and MacOS, this type of behavior has been around quite a while.

  • 5. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    Eriksimon, all audio tracks are set to NO INPUT.  However, It doesn't seem to make a difference whether there is an input or not on the audio channels. I get the same result if there are inputs.

     

    It is the Logic CPU meter is peaking - see photo.

     

    meter.png

  • 6. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    Pancenter,

    There are no plug-ins. I had set my buffer to 1024 in preperation to mix. However, attempting to add the UAD2 plug-ins just as an experiment made no difference.

     

    I was able to run 60+ audio channels with UAD plug ins, and stream 20+ plug-ins (including BFD, Kontakt, all the Spectrasonics stuff) all at the same time on my dual-core 1ghz machine 9 years ago.  It makes no sense that I cannot run less than 30 audio tracks alond sans plug-ins on this 8-core.

     

    I have ruled out the file being corrupt because the last 2 files I created with audio tracks had the same issue. Also, freezing the tracks makes no difference. 

  • 7. Re: slow disk audio
    Pancenter Level 5 Level 5 (7,640 points)

    Don't get me wrong... I understand and agree with you... Nine years ago you had a dual processor G5 or G4, Intel Macs weren't available until 2006. Also the operating system was a lightweight speed demon comparable to the bloat nowdays.

     

    Just curious, the UAD is an internal PCIe card  correct? What is you audio system.

     

    Anyway..  this is probably why I stuck with 9.1.3 on 10.6.8 I don't seem to be having any of those problems.

     

    Looking at the pic you posted, you're Disk I/O is slammed into the red, does it stay like that or is it just a peak that levels out?

  • 8. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    A friend of mine suggested I trying running in 32-bit and that solved the problem.  In a piece of music that ran 1:30 in length there was one moment where the I/O went up maybe 10% for a split second. But for the other 1:29 of the track, my CPU meter looked like this:

    meter 32.png

     

     

    Even when I added all my plug-ins and midi/streaming, etc, the 8-cores ran at about 5% and the Disk I/O still showed almost no activity (below)

    meter 3.png

  • 9. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    Pancenter,

    >Just curious, the UAD is an internal PCIe card  correct?

    Yes, I have 2 of them: a Quad and Solo UAD2.

     

    >What is you audio system.

    I'm using a Fireface 800.  While I was in 64-bit, I tried using the built-in in/out in my Logic audio settings and was having the same problem.

  • 10. Re: slow disk audio
    Pancenter Level 5 Level 5 (7,640 points)

    I won't venture a guess but I bet if you put L back in 64-bit mode and removed one or both UAD cards you would see normal CPU/Disk use.

     

    Either that or the Fireface driver is having some serious issues at 64 bit.

  • 11. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    I spoke too soon. I closed Logic and re-opened in 32-bit a second time and having the same problem again. Even though the UAD cards are not being used, I turned them off in the UAD meter and it made no difference.

  • 12. Re: slow disk audio
    Eriksimon Level 6 Level 6 (10,820 points)

    armenjc wrote:

     

    Eriksimon, all audio tracks are set to NO INPUT.  However, It doesn't seem to make a difference whether there is an input or not on the audio channels. I get the same result if there are inputs.

     

    It is the Logic CPU meter is peaking - see photo.

     

    meter.png

    The meter is called CPU/HD, the peaking meter is labeled Disk I/O - how have you concluded that this shows it's the CPU? It's clearly the disk, on this screen. Also, on your other screens I can see absolutely no peaking CPU activity. So, how fast is your Audio Files/Project disk?

  • 13. Re: slow disk audio
    armenjc Level 1 Level 1 (0 points)

    7200 RPM. They are SATA 2 WD Caviar Black drives

  • 14. Re: slow disk audio
    Pancenter Level 5 Level 5 (7,640 points)

    I'm thinking this has something to do with running the UAD cards/drivers in 64-bit.. even though they can be disabled in software they are still loading the bus. If the bus is saturated the drives cannot deliver data fast enough.

     

    It may be the running two UAD cards in 64 bits is the problem, it shouldn't be acting like this but you can't be certain until you remove one of the cards. Might check on the UAD boards to see if there's anyone else running two cards and Logic at 64 bits, just a hunch.

1 2 Previous Next