Skip navigation

Safari Webpage Preview Fetcher / Safari Web content hogging RAM

9750 Views 15 Replies Latest reply: Apr 7, 2014 4:04 PM by Ronald Brown2 RSS
1 2 Previous Next
mdankovsky Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 11, 2012 7:43 AM

hi,

recently safari started taking up more & more ram. i have a standard setup 4gb ram on 2011 macbook pro / lion os x and i am left with 5-10mb ram when opening safari = crippled system entirely. no extensions, using top sites tho. no idead how it came about, hate using ff on mac, please help

MacBook Pro, Mac OS X (10.7.3), Safari
  • Klaus1 Level 8 Level 8 (43,365 points)

    If Safari is getting very slow:

     

    (Presumably you regularly empty your Safari cache by deleting the following file:

     

    Home/Library/Caches/com.apple.Safari/cache.db

     

    and clear your History)

     

    Adding Open DNS codes to your Network Preferences, should give good results in terms of speed-up as well as added security, (including anti-phishing and redirects) (Full information about Open DNS is here: http://www.opendns.com/home/nobloat )

     

    If you are using a single computer: Open System Preferences/Network. Double click on your connection type, or select it in the drop-down menu, and in the box marked 'DNS Servers' add the following two numbers:

     

    208.67.222.222

    208.67.220.220

     

    (You can also enter them if you click on Advanced and then DNS)

     

    Sometimes reversing the order of the DNS numbers can be beneficial in cases where there is a long delay before web pages start to load, and then suddenly load at normal speed:

     

    http://support.apple.com/kb/TS2296

     

    If your computer is part of a network:please refer to this page: http://www.opendns.com/start/best_practices/#your_network and follow the advice given.

     

    If you use a Router, make sure it has the latest firmware installed.

     

    One reason for a slowness in page loading may be the 'DNS Pre-fetching' feature of Safari 5.x as is described here:

     

    http://support.apple.com/kb/TS3408?viewlocale=en_US

     

    You can cancel DNS pre-fetching by going to Terminal and typing:

     

    defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false

     

    You have to restart Safari for it to take effect.

     

    If Safari seems to hang for ages:

     

    If you have a lot of tabs open and/or a lot of pages running Flash, Safari can sometimes 'hang', requiring a restart of Safari. This can often be inconvenient, and as it is rarely Safari itself that is hanging but merely one of its plug-ins, usually Flash, there is a way using Terminal to restart the plug-ins (without restarting Safari and losing your tabs) by quitting the WebPluginHost process:

     

    Open the Terminal from the Utilities folder in /Applications and type

    killall -9 WebKitPluginHost

    Note that this command kills all Safari plug-ins, not just Flash. All plug-ins should start back up when you reload the page.

    Then go back to Safari and refresh any pages that were using the Flash plug-in. This also fixes the Beachball of Death. Try this whenever Safari gets slow or freezes. The latest versions of Flash 10.1 onwards appear to have improved the situation somewhat, but haven't completed eliminated it.

    For this and other reasons Apple switched their websites to HTML5 in January 2011:

    http://www.appleinsider.com/articles/11/01/26/apple_revamps_its_public_website_u sing_html5.html

  • DeJuan_5050_Stephens Level 1 Level 1 (0 points)

    This is great to know. I bookmarked this the moment I read fixes " Beachball of Death ". I have a similar issue on my Macbook 2011. Running OS X Snow Leoard and 2gb 1067 MHz DDR3, 2.4GHz Intel Core 2 Duo. Right now I'm posting this from my Macbook Pro mid-summer 2012. 8gb 1600 MHz DDR3, 2.6 GHz Intel Core i7.

     

    The issue I'm having is occuring on my Macbook 2011 model. Right now I have Skype running with the activity monitor UI up. It's telling me I have free 7.6Mb, wired 437.1Mb, Active 1.04Gb, Inactive 533.8Mb, Used 1.99Gb. When I scroll through the activity monitor list of processes. I noticed this Safari Webpage Preview Fecther, and it's taking up 1.04 GB! First off what does this process even do and why does it take so much? Can I close this process to free up the storage? Is this cause for the hanging at all? Also my free space seems pretty dymaic now for some reason it's changing going up and down. I was wondering what causes this to happen.

     

    I do use an app to clear my cache memory. The app is called " Clean my Mac ", and I use Sophos Anti-Virus. I recently ran a virus scan and Clean my Mac yesterday because I was a little worried my Mac may have been targeted by the " Virus " epicdemic that was suppose to happen Jul-9-2012. My virus scan came back clean, and I preceeded to clean the mac cache, and that seems to help it process at a normal speed, but I still get these occassional hangs from time to time, and I would like to get to the bottom of it. Any help will so much appreciated.

     

    Thank You

    DeJuan Stephens

     

    Message was edited by: DeJuan_5050_Stephens

  • Bruno Medeiros Level 1 Level 1 (0 points)

    I'm having the same problem, which started just a couple days ago (maybe following an update? I didn't notice). Mine is a 2011 Macbook pro with OS X Lion. I always quit the process and everything seems to work fine.But it is really annoying to do that all the time.

    I hope Apple fixes that soon!

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    I think you want this Terminal command:

     

    defaults write com.apple.Safari DebugSnapshotsUpdatePolicy -int 2

  • Allan Jones Level 7 Level 7 (29,575 points)

    If you find you don't really rely on Top Sites but are uncomfortable with using Terminal commands and changing DNS numbers (some people are), you can isolate Top Sites within the normal Safari Preferences. I personally find Top Sites about as useful as alunimum siding on a brick house, so I isolate it via these steps.

     

    1) In Safari > Reset Safari... check the following boxes:

     

    ---Reset Top Sites

    ---Remove all Webpage Preview Images

     

    then hit Reset.

     

    2) In Safari > Preferences > General tab, find these two entries:

     

    ---New Windows open with:

    ---New Tabs open with:

     

    and select anything but "Top Sites."

     

    3) In Safari > Preferences > Bookmarks tab, for "Bookmarks Bar," uncheck "include Top Sites" to remove its icon from the bookmark bar, That keeps curious visitors from invoking Top Site by clicking an icon.

     

    The TS function is still there if you need it in the future and can be reactivated quickly. All you're doing with the above actions is clearing existing images and hiding the "switches" that cause the Fetcher to activate.

    iMac 27-in; Mid 2010 2.93G i7 Quad, Mac OS X (10.6.8), 4GB RAM; ATI5750 1G VRAM
  • Neville Hillyer Level 4 Level 4 (1,845 points)

    I don't think this addresses the original issue ie:

     

    "Safari Webpage Preview Fetcher / Safari Web content hogging RAM"

     

    As far as I am aware the Terminal command is the only way to turn off preview images, save RAM and increase speed.

  • Allan Jones Level 7 Level 7 (29,575 points)

    It works on the Fetcher side which, for me, was the big hitter in the Safari performance issue.

     

    I have used the above technique since Top Sites first appeared in Safari and at least the Fetcher never shows up in Activity Monitor set to show "All Processes." I've set it up that way on a number of new and older Safari-capable Macs and it's worked on all of them. They now show normal RAM usage and completely acceptable speed with stability.

     

    I find no issue with what you posted. However, sometimes people here need an option that is less daunting. That's why I posted it. Why not give it a try to see what you find.

  • Kwales66 Level 1 Level 1 (0 points)

    Neville Hillyer wrote:

     

    I think you want this Terminal command:

     

    defaults write com.apple.Safari DebugSnapshotsUpdatePolicy -int 2

     

     

    Hi Thanks for this - my Safari Fetcher process ( in fact two  ) were about 100% each - Ive run this terminal command as you suggested and now everything seems just fine - Could I ask if you could explain a bit more what this does - ie Have lost any functionality ?

     

    Thanks

     

    K

  • Kwales66 Level 1 Level 1 (0 points)

    PS I too Have only noticed this in the last week - so maybe an update somewhere has caused this problem ?

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    The site I got it from said the only downside was loss of Top Sites - my Safari was faster after the command - there is a way to reverse it if necessary.

     

    Apple now has a way to update preferences over the web without telling you - not sure how often it is done but the method exists and is installed - I could probably find details and a fix to stop this - downside is that it will be the same for all applications.

  • Kwales66 Level 1 Level 1 (0 points)

    Thanks - Im very happy with this fix - And Top sites Doesnt matter as much as reducing such CPU Usage.

     

    Thanks again for the fix

     

    K

  • kap man Level 1 Level 1 (0 points)

    That all seemes very complicated. I just turned the preview fetcher off.

    Safari / Preferences / Bookmarks / Uncheck: Include Top Sites

  • pedrochamorro Level 1 Level 1 (0 points)

    I can say I've tried many ways to manage this issue, for example by using "purge", apps to free memory, tweaking settings, deleting caches, etc. etc. but those are only workarounds. By now I switched to Chrome and the difference in speed is huge. Apple should fix this asap though...

  • wewright Level 1 Level 1 (0 points)

    it will probably be a bad webpage that Safari is trying to preview.

     

    Normally the preview fetcher will update the previews very quickly in the background, and you don't even notice.

     

    But if it gets hung up on a page on your top sites screen, the preview fetcher goes nuts and takes all the processor it can get.

     

    Edit the top sites page and delete a whole bunch of previews. You'll end up finding the one that's causing the problem.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.