Skip navigation

Duplicate songs on iPhone after iCloud download

189230 Views 116 Replies Latest reply: Mar 28, 2014 12:46 PM by bigjohnsta RSS
  • jciannelli Calculating status...
    Currently Being Moderated
    Jul 19, 2012 10:35 AM (in response to ejb87)

    Didn't work for me. I delete all music and the gray dups remain.... and I can't swipe and delete the gray dups. Re syncing just adds the black working songs... but does nothing to rid me of the gray songs. So frustrating.

  • ChuckieCFinster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2012 2:15 PM (in response to jciannelli)

    Kay! I just fixed this issue for me! On your iPhone or iPod ( I have latest update not sure if it matters) Go to your artist and swipe across the name of the artist and it should show DELETE. DELETE ALL MUSIC FROM YOUR PHONE OR IPOD. Then RE-SYNC with itunes. Give it time to sync them all it took a good 10 minutes for me. Hope this helps =)

  • ChuckieCFinster Level 1 Level 1 (0 points)

    Then again I had 832 songs which is why it took awhile but it fixed the issue. =)

  • dsmlibrarian1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2012 10:53 AM (in response to clevercubed)

    I just encountered this problem on my Ipad 1. Purchased an album yesterday and was confused why there were dups. I have Icloud for my calendar and contacts.  I guess since I have the "back up to Icloud" option checked on the summary tab, I have music on the same set up. I'm a novice. Please bear with me.

     

    But what I just tried that worked for me was this: On Itunes I have my music set to sync all items. (My music library is still small enough to permit this option!) On the summary tab under options, I checked "Sync only checked songs and videos."  Bingo - this removed the duplicated songs on my Ipad.

     

    I tried the single swipe on my Ipad originally but the dups returned when I resynched. Plus I am leery of the other suggestions to wipe out and resync.  I have a lot of old music I copied over from CD's and I have not tried ITunes match yet etc.  So if this option continues to work for me then fabulous. 

     

    Thank you everyone for your suggestions and advice.

  • Substance 586 Level 1 Level 1 (0 points)

    I have been suffering from this problem on my iPhone for months.  I finally sat down and tried to find a solution last week and came across this thread.  The suggestion of (for iOS6 users) deleting the artist that contains a duplicated track and then resyncing worked for me without any snags.  Thanks for the suggestion!

  • leslie22 Level 1 Level 1 (10 points)

    Deleting the artist then syncing worked - thanks for the idea!

  • swag72 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 21, 2012 1:05 PM (in response to Linda Custer)

    Not only did that work, but it left all the songs on my phone and only deleted the duplicates. Thanks

  • jay_gord Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2012 3:28 PM (in response to yalli)

    yalli, you are awesome. Thanks for the tip. This totally helped. I assumed I could only delete songs via itunes and the duplicates do not show up on itunes when I plug in my phone.

  • cathryn23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2012 10:23 AM (in response to clevercubed)

    HI all - I've had this problem, and even asked at the Genius bar, and the 'genius' told me he'd never heard of this problem and had no idea how to fix it. (?!). He took my name & number and said he'd be in touch if he heard about the problem again. (This is Georgetown, DC Genius bar - seems it's not worth the parking fees to visit it, eh?)

     

    I tried deleting all the music from iPhone iTunes and re-syncing, but that didn't work.

     

    Swiping the artist and deleting worked on the couple songs I tried it for, but I have over 600 songs! This is going to take a lonnnnng time.

     

    Long story short -- why is Apple letting this problem persist?

    (and who's training the geniuses at the Genius bars?!)

  • TheAnimaster Calculating status...
    Currently Being Moderated
    Dec 11, 2012 4:57 AM (in response to clevercubed)

    I'm having the same problem here!!! I just purchased Lenka's new album (didn't even know I was purchasing an LP album, but oh well) -- DOUBLE SONGS, minus the music videos. The music videos aren't duplicated.

     

    I tried erasing the songs on my iPhone 5 -- it worked, BUT THE LENKA ALBUM WAS STILL THERE!!! Remember -- I had NOT been using iTunes Match on my iPhone since I realised it drained the battery (downloading the music)! All these problems only started happening (at least with me) with iTunes 11!!  I see that it goes past that, but nevertheless, I think it's an iTunes problem ... iTunes and the cloud.

     

    So yeah, all my music is now gone -- sans the Lenka album, and guess what -- I CAN'T PLAY THE MUSIC IN THAT ALBUM. They are all greyed-out. It's as if iCloud is saying "Hey, you got this nyeh nyeh, but you don't have an internet connection to download it" HUH?? Or it's also what you get if you interrupted SYNCING, such as what I did when trying to resync the iPhone. Later on I completed the sync and now I have my music back..

     

    ... AS WELL AS THE GREYED-OUT DUPLICATES.

     

    Granted, the duplicates don't play, and they don't seem to take up any space. 3MB of space, that's all. For ten songs?? That don't play??

     

    APPLE NEEDS TO FIX THIS!!!

     

     

     

    ---------------------------------------

     

    UPDATE: The fix above works!!! WOOHOO~!! THANKS A BILLION! What I did was go to the artist (Lenka) and because I have songs from two of her albums, I just deleted the album (by swiping it on the iPhone 5) that contained duplicates (TWO). Then a re-sync with my macbook pro put it back, without duplicates!

  • John Unsworth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 14, 2012 9:23 AM (in response to clevercubed)

    I had the same problem (duplicate cloud tunes showing up).  In Preferences, under Store, I unchecked "show iTunes Purchases in the Cloud" and all duplicates disappeared. 

  • cathryn23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 14, 2012 10:28 AM (in response to John Unsworth)

    Hmmm. So I manually deleted all the duplicates, re-synced, etc. That worked.

     

    But just a couple days ago, I noticed all the duplicates were back. Same thing - they're on my iPhone as not downloaded songs, so when I play 'shuffle' and it gets to one of these duplicates, it starts trying to download the song. But it can't download any of them. It's like they're shadow duplicates...

     

    So now I just did what John Unsworth (above) suggested. New question - when this preference is unchecked "Show iTunes Purchases in the Cloud", does that mean that my iTunes purchases won't be backed up anywhere?

     

    Thanks all - this is a crazy bug that should be fixed by Apple.

  • TurboClown Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 12, 2013 11:01 AM (in response to clevercubed)

    I'm new to this.  But with iOS 6 on the iPhone,  I went into settings and turned off iTunes Match and Show All Music under Music.  Then turned both back on and all the duplicates were gone.   Did the same on my iPad.

  • cary99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2013 4:15 AM (in response to TurboClown)

    I finally found where if I purchased music from my iphone, it seems to automatically check the artists inside of my itunes application on my imac.  so everytime i synced (and with only playlists selected), it would pull down the artists list as well.  So I had to go uncheck the artists i had purhcased musci from my iphone to keep the duplicates and songs i didn't want from syncing again.

  • E-Dave Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2013 9:18 AM (in response to clevercubed)

    I just learned a new trick while trying to figure out how to correct that same problem on my phone.

    In the "Song" or "Artist" view,,, drag the unwanted entry to the right of the screen,,, as if you are trying to move it off the screen. This will prompt a "Delete" button to appear. Touch the delete button and 'Viola', it's gone.

    You can delete individual songs or complete artists/albums.

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.