Skip navigation

iBook G4 charging problems

3291 Views 23 Replies Latest reply: Sep 24, 2012 2:55 AM by bigvoice RSS
1 2 Previous Next
Jagoche Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 20, 2012 6:26 AM

While charging my iBook the charging process stops from time to time.

 

If I slightly push the power adaptor plug or port the charging continues for a while. To me it seems as if the power adoptor port doesn't have a firm contact with the motherboard. But I may be wrong.

 

The battery is also old, so that may be another possible source of the problems.

 

Any suggestion will be appretiated. Thanks.

  • Knucklesmac Level 4 Level 4 (2,225 points)
    Currently Being Moderated
    Jul 20, 2012 6:41 AM (in response to Jagoche)

    Hello,

     

    Over the life of the power adapter the 'barrel' becomes perforated and moves outward slightly. While connected to the iBook it looks to be a perfect contact, but its not. What I've done in the past to over come this problem is used some very fine pliers grips and pulled the circular rim around the barrel of the adapter into shape. Not by a lot mind you, Very small amount of movement. Once connected it has better contact with the DC in board and should work fine. Do try not to bend the barrel out of shape.

     

    The battery shouldn't make a lot of differnce, unless it's a dead battery that just wont charge.

     

    Best of luck

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Jul 21, 2012 9:56 AM (in response to Jagoche)

    What is the percentage of charge showing on the battery when you notice the adapter's condition fluctuating between "Charging: No" and "Charging: Yes"?

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Jul 22, 2012 3:56 AM (in response to Jagoche)

    Jagoche wrote:

     

    The percentage shows 99% (the battery itself is on 48% of original capacity).

    I'm not sure what you mean by this.

     

    If the percentage showing is 99%, then that is normal that it would not be charging. No problem there, so no need to jiggle the adapter plug to try to make it get to 100%

     

    http://support.apple.com/kb/TS1909?viewlocale=en_US&locale=en_US

     

    I assume you mean that the battery condition as shown in the System Profiler or by a third-party battery monitoring application shows that the battery's condition is at 48%?

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Jul 22, 2012 7:39 AM (in response to Jagoche)

    Have you tried resetting the PMU?

     

    The PMU (Power Management Unit) controls the charging function, so resetting it may help.

     

    If that doesn't help, it could be the fault of the adapter itself. I always keep an extra on hand in case mine fails. I've had half a dozen adapters, both Apple adapters and third-party adapters, fail.

     

    It could also be a faulty DC-in board (the part of the iBook which contains the power adapter port).

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Jul 22, 2012 3:32 PM (in response to Jagoche)

    /___sbsstatic___/migration-images/189/18989653-1.png

  • Ronda Wilson Level 8 Level 8 (40,560 points)
    Currently Being Moderated
    Aug 25, 2012 6:40 AM (in response to Jagoche)

    I'm glad to read that you have found and corrected the problem.

     

    Good luck with it from here on out.

  • bigvoice Calculating status...
    Currently Being Moderated
    Sep 22, 2012 11:24 AM (in response to Jagoche)

    I'm having a similar problem. iBook won't start, good power adapter, original battery (I think) showing 4 green lights (but I realize the battery is probablly too old). When I press the power on button a hear a very faint click and the screen changes for a millisecond. Not really a flash, but like it is trying to flash (if that makes sense!). With the power adapter plugged in and the battery removed, nothing when power button is pressed. I have changed the DC in board and have the exact same result. Any other ideas?

     

    Thanks!

  • bigvoice Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 6:42 AM (in response to Jagoche)

    If the battery was bad, shouldn't the iBook start up with the battery removed? I get nothing with the battery out.

     

    Thanks!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.