Skip navigation

iMac very slow & unresponsive following software update

7584 Views 14 Replies Latest reply: Jul 23, 2012 6:35 PM by camurphy01 RSS
mitchy_ocker Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 15, 2012 1:28 AM

Hi all,


Really need some help. After going through the software update motions today (which i have done many time before) my Mac has basically turned into a dog.


Here are the symptoms;


- any button i click instantly brings up the rainbow wheel thing - and takes at least 5 seconds to respond

- garageband initialiizes for over an hour everytime i open it - and now cannot find certain audio units & plug ins

- the typing lags - letters appear seconds after i type

- sub folders take 10 mins or more to show their contents

- it takes some minutes to open applications - itunes / mail / safari / firefox etc, and they are near unusable when opened

- toggling between apps / screens doesn't work - i have to click on the app in the dock & even then it takes many seconds to open


Everything was perfect before the update. I don't even know what updates i installed- i just followed the motions.


Can i restore from a previous date using my time machine back up - will this help ?


Should i just install the Lion operating system & garageband '11 ? Will this do the trick ?


please please help...pretty please. I'm about to throw the mouse out the window.


thank you

iMac, Mac OS X (10.6.8)
  • fane_j Level 4 Level 4 (3,655 points)

    mitchy_ocker wrote:


    my Mac has basically turned into a dog.

    From Panthera uncia to Canis familiaris. Quite a transmogrification.

    Can i restore from a previous date using my time machine back up - will this help ?

    It may or it may not help. I think it's best to troubleshoot it in the usual way.


    First, make sure you have enough disk space on your boot drive, and use Disk Utility to verify the disk. Although repairing permissions is usually a waste of time, you can also do that, given that you have applied some updates.


    Second, boot in Safe Mode and see if the issue persists. Some third-party software may be incompatible with the most recent updates.


    Third, create new user and test if the issue occurs in the new account. If it doesn't, then the problem must be located in the user domain.


    Other troubleshooting steps are outlined in


    Mac OS X: How to troubleshoot a software issue



    Isolating issues in Mac OS X





  • fane_j Level 4 Level 4 (3,655 points)

    mitchy_ocker wrote:


    what is latin for 'coffee table' ?

    Mensa caffearia? Only Jove knows…

    Second, i created a new account & wow, everything works beautifully.


    Thirdly, i booted in safe mode, logged into my original account and everything works fine.

    Second indicates that the problem is restricted to that user domain; thirdly, that it's probably some third-party software (which is disabled in Safe Mode). So now you have to hunt it down. Start by checking


    System Preferences > Accounts > [your account] > Login Items


    and the contents of




  • fane_j Level 4 Level 4 (3,655 points)

    mitchy_ocker wrote:


    I can't seem to find a Library/Startup folder though...

    It doesn't have to exist.

    In the accounts > login items... i see 4 apps - 2 of which were ticked to not open at login.

    No, the checkbox only indicates if they are to be hidden. All four are going to be launched.


    It's probably best if you post the list here, as well as the list of the launch agents. Together we can probably figure out what shouldn't be there.

  • fane_j Level 4 Level 4 (3,655 points)

    mitchy_ocker wrote:




    Itunes helper (ticked) - Unknown

    This is a problem. There is a process called "iTunesHelper" (not "itunes helper"), but it should not appear in your login items. You should check where it is located; either ctrl-click or right-click on it and choose "Reveal in Finder", or just hover over it and its path should pop up.

    CrossOver CD Helper (ticked) - Unknown

    This is also an issue. CrossOver CD Helper is part of the CrossOver install, but you shouldn't have it twice. As above, find out where it is located.


    Once you've noted the paths of these two items, you can remove them from the Login Items list. (Select them and click the – sign.)

    In the Library / LaunchAgent... i see;



    All the others are normal (including the Adobe file, which is the update check for Acrobat Reader). However, this one raises up a huge red flag.


    It looks like you've made the mistake of installing MacKeeper. This is the prime suspect for causing your troubles, and you need to remove it completely from your Mac. The instructions from




    are recommended by several experienced contributors to this forum.


    First, remove MacKeeper, then deal with the other two items, and then test again your system's behaviour.

  • WZZZ Level 6 Level 6 (11,880 points)

    fane_j wrote: There is a process called "iTunesHelper" (not "itunes helper"), but it should not appear in your login items.

    I have iTunesHelper in my login items. I never understood what it was doing there, but it has never caused one wit of trouble and I've left it alone.

  • WZZZ Level 6 Level 6 (11,880 points)

    You don't have to rely on the information at that site, which, for all I know may be out of date. Get EasyFind and search for MacKeeper and zeobit. Set it to scan all files, case insensitive, show invisible, show package contents. Use EF's move to trash or destroy, but if that doesn't work then use reveal in finder and manually trash an item, giving your admin password. EF should find it all.


  • WZZZ Level 6 Level 6 (11,880 points)

    Glad to help anytime for a CrapKeeper uninstall. You're welcome.

  • camurphy01 Level 1 Level 1 (0 points)

    Hello.  I believe I am dealing with a similar issue.  Over the past few days I have experienced very slow/poor performance.  I followed the steps outlined  in this thread.  I set up a new user and my system worked  perfectly.  I booted in safe to my existing account and experienced slow performance.  I verified permissions for both of my hard drives (internal 1TB and external 2tb)


    I also found ITunesHelper in LoginItems.  No path could be found for it and I removed it.   The only other items I have in LoginItems are:





    not sure how to search in the <~/Library/LaunchAgents> or




    Any help is appreciated


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.