Skip navigation

Mail app shows 3 unread emails when there isn't.

197576 Views 101 Replies Latest reply: Apr 2, 2014 9:50 AM by jalley1987 RSS
  • Daan Swakman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2012 11:37 PM (in response to atyree)

    I had the same issue when I installed the gmail app. The solution that worked for me after some searching, was that there apparently was some unread mail for me, hovering in limbo inbetween my inbox, my spam box and the archive.

     

    If you type "is:unread" (without qoutes) in the gmail search field, it will perform a search and show all unread items. By simply opening and closing those emails, making them read, the badge disappeared.

     

    Hope it helps.

  • EllisonD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2012 9:16 AM (in response to atyree)

    One more possibility for solving this problem. I had the same in gmail on my macbook air. If you have been using an automatic reply while away on vacation, search for the sent replies and delete them all. You may find some hidden unread emails among them. At least that solution finally worked for me...

  • chrisgleim Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 12:35 AM (in response to atyree)

    The key here seems to be that there are, in fact, unread emails in your inbox.

     

    I saw this issue myself, and it seems to show up if you search for old emails.  When you search on the server, the mail app recognizes all the old unread emails.  The problem is that it doesn't show them to you, so you can't read them.  Not very helpful...it just results in a badge on the app icon you can't get rid of.

     

    For me, I solved the issue by going to my desktop email client and deleting (or reading) the old emails.  The mail app doesn't recognize this unless you tell it what specific emails to look for...I found it easier to just delete the account and re-add it.

     

    I'm very surprised Apple hasn't addressed this yet.

  • Plaideleon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 12:31 PM (in response to mac68)

    Thank you mac68 !!! I had totally forgotten I had set up my icloud and since I did it from my phone the 1 unread message I had was only showing up there and not on any other devices.

  • bd1212 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 12:15 PM (in response to atyree)

    Found a glitch in iOS 5 that allows you to mark all emails as read! It saved me the hassle of having to figure out which email was unread.

     

    Open the Mail app and click on the "Edit" button in the top right corner, then click on an email and click the button in the bottom right that says "Mark", then click on the "Mark as unread" button. After you've done that, click on the "Edit" button again and click on the email that you just marked as unread, then HOLD down the "Mark" button in the bottom right corner with one finger, and then with your other hand (WHILE STILL HOLDING DOWN ON THE MARK BUTTON) click on the email that is unread so that it is no longer selected. Once you've done that, you can take your finger off of the "Mark" button. Give it a second and the "Mark as read" button will appear. Click on it and it will mark all of your unread messages as read.

     

    Here's a video that will help you understand if the directions I posted were confusing lol:

     

    http://www.youtube.com/watch?v=CmaqzeXfO5s

  • discdogger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2012 8:36 AM (in response to atyree)

    There are no unread emails yet it shows four. This is Gmail calendar issue.

     

    One at a time, I turned off my mail accounts via Settings and isolated the unread emails. They are not emails exactly. They are in Gmail settings, notes, which appears as an account in OS5 Settings. So I can look all day for unread mail and won't find them. I tried accessing Gmail via Safari and Important and Unread shows nothing. I am fairly sure the root of this is in calendar invitations, but I can't figure it out.

     

    For now I am turning off Gmail calendars, settings. I use my phone and Mac more for this anyway ans both handle Gmail properly.

  • dbutler85 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 20, 2012 1:31 PM (in response to atyree)

    For any of you on an exchange server with this problem, here is the fix for when your mail app show an unread message and there is not an actual unread message...go to settings/mail/the offending mail account/and change your "mail days to sync" to No Limit. Then go into your email box to let it start downloading all emails until it finds the mail item that it thinks is unread. This download process will update your phone so that it realizes that the email it thought was unread is actually read. Then go back and change your mail days to sync back to its original setting.

  • DBONINI Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2012 12:20 AM (in response to atyree)

    I'm having the same problem-have 4 mailboxes setup. What's strange though is that my hotmail is showing with 11 unreads but when I check there aren't any. However, the all inboxes tab shows 0 unread mails. I think this is a problem since upgrading to ios6 but can't be sure...

  • jessefromeast amherst Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 11:07 AM (in response to atyree)

    HERE IS THE SOLUTIO!!!  I had the same problem a couple times.  It occurs when do a search for an email "on the server".  It will find the email that first time (say you are looking for a specific email with a specific subject line "tacos").  If it finds 2 emails, and they are unread, then they will show up on your phone as "unread".  The issue is that if you exit and go back those emails are "gone" if they are beyond the limit you have set on your phone (for example, only show past 50 messages.)   To find them, you may need to remember what you searched for when your problem came up.  In the "taco" subject line example, you would go to settings and change your email to show the 1,000 recent messages.  Then you can go back in to your email and search for what ever it was your originally searched for, in this example "tacos".  If that was what was causing the problem, the 2 emails will show up.  You read them and the badge will go away.

  • ProxisTech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 8:40 AM (in response to shaarp)

    Thanks. This resolved the problem. Shutting it off and the having the mail program read the mail back into your inbox fixes it.

  • stuguru Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 7:37 AM (in response to atyree)

    I had the exact problem with iOS 6 and tried all the suggestions in this thread. The only thing that worked was to delete the mail account and then set it up again from scratch.

  • componentgeek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2012 3:06 PM (in response to shaarp)

    Thank you shaarp... that worked!! 

     

    "I just had this issue when setting up an email account on my iphone.. I tried everything that was mentioned but to no resolution. I then went into the Email Settings and switched "Mail" to OFF (Do Not Delete Account), then switched "Mail" back ON. This resolved my issue."

  • Duluthmike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2012 8:39 AM (in response to shaarp)

    That worked for me. I had 1 "unopened" e-mail on my exchange.  Your solution was the simplest and it worked...Thanks

  • LadyPzaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2012 12:12 PM (in response to ProxisTech)

    Thank you so much, proxis tech! This worked for me! It was driving me crazy!! Lol

  • hardkicks66 Level 1 Level 1 (0 points)

    Thank you **jessefromeast  amherst** !

    Your solution worked perfect!

1 2 3 4 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.