Skip navigation

Aperture video import and playback with Mountain Lion GM

2581 Views 18 Replies Latest reply: Jan 5, 2013 11:17 AM by floridajoseph RSS
1 2 Previous Next
jimbim Calculating status...
Currently Being Moderated
Jul 24, 2012 3:25 AM

Hi,

 

I recently upgraded my new, latest generation MacBook Air to Mountain Lion (Gold Master). Since then, Aperture won't play the videos in my library anymore. It does display the thumbnail preview images (they have obviously been generated before), but it can't play the video and does not even show the video controls for playback. The videos I am talking about are all taken with my Sony NEX-3, which should be supported out-of-the-box.

Right now I can not even import new videos from my camera, as Aperture just tells me it does not know how to handle the video files (and proposes to just save the files somewhere in the file system instead of importing them into my Aperture library).

 

Is my installation corrupt? Am I missing some basic video codecs? Is Aperture not (yet) ML-compatible?

 

Any hints?

 

Cheers,

Dan

Macbook Air, Mac OS X (10.5.3)
  • Michigan One Fly Level 2 Level 2 (240 points)

    " I recently upgraded my new, latest generation MacBook Air to Mountain Lion (Gold Master)."

     

    Do you have some sort of inside track ?? Mountain Lion........to my knowledge has not been released yet.  I have heard that it will be available tomorrow July 25 th. 

    Are you perhaps on LIon ? Your signature is OSX 10.5.3 ?

     

    Also what version of Aperture are you using  and what codec is your camera recording in?  I think your camera has a few different codecs it can be set to for recording.

  • William Lloyd Level 6 Level 6 (19,195 points)

    Mountain Lion releases are available to registered Apple Developers and other means.  So there are "official" ways to get pre-releases of Mountain Lion.

     

    That said, these programs have an NDA as well, which generally prohibits any of this sort of discussion prior to the general release of the product.  There ARE places this can be discussed (developer forums or elsewhere depending on how you got Mountain Lion).

     

    Questions/answers related to Mountain Lion here... should wait until it ships, which looks to be tomorrow.

  • léonie Level 8 Level 8 (46,350 points)

    jimbim,

    we asked the community host in similar cases how to deal with Aperture questions, if Aperture is running in combination with pre release software, and the hosts advised us not to discuss these questions here. And as we are all guests here we should respect their wishes.

     

    It would be difficult anyway; we could not ask for screenshots, console messages, crash logs, terminal listings. everything would be in violation of the non-disclosure agreements.

     

    Some general advice with videos that will not play:

    • - Are the videos referenced? Try, if they will play if you make them managed.
    • - Aperture has been known, to not to be able to play video, if the library is in a shared folder.
    • - Check, if you have third party video codecs installed, like the 3ivx codec.

     

    Aperture 3: About Video and Audio formats in Aperture:

    http://support.apple.com/kb/HT4025

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,350 points)

    (until this afternoon?)


  • léonie Level 8 Level 8 (46,350 points)

    O.K., I also have ML-GM installed, but not your camera. For your camera the codecs are listed as part of Mac OS Lion, directly built into the system.

    Maybe in ML it will help to register the camera with the lauch services database - see this post by Alan Roseman

    :Aperture 3 preview of raw file greenish, but read the follow up posts first (the lsregister command) as well, on how it is supposed to work andhow to correct the typos.

     

    This worked previously, when some cameras were not registered, but the support was built into the OS.

     


  • Snoopy5707 Level 1 Level 1 (5 points)

    Same Problem here!! All old Videos cant open in Aperture!!

     

    Regards

  • SierraDragon Level 4 Level 4 (2,665 points)

    The new update claims to bring ML and Aperture into compliance with each other:

     

    http://www.macnn.com/articles/12/07/25/aperture.iphoto.get.mountain.lion.compati bility/

     

    -Allen

  • léonie Level 8 Level 8 (46,350 points)

    I just checked again the list of supported video for Aperture. This list is not exhaustive, but I am not longer sure that your camera's video is supposed to supported.

     

    Aperture 3: About Video and Audio formats in Aperture:

    http://support.apple.com/kb/HT4025

     

    and the Sony NEX 3 is not on that list. Can it be that you had third party video codec installed previously, like flip-for-mac, that you not yet installed after upgrading to Mountain Lion?

  • Snoopy5707 Level 1 Level 1 (5 points)

    i think is not a Problem with Aperture 3, but with ML. I have a lot of videos that were already in the library and also worked. I go back with TM to older Libriary and Aperture, but same Problem. No play and no import with any Videos.

    Now i make a clean ML install and test again.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.