1 2 3 Previous Next 371 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Branched to a new discussion.
henrijacobs Level 1 Level 1 (0 points)

I have just installed mountain lion.

All went good, but now i have à problem with wifi.

 

My connection is ok, i get an ip adress, but i cant get On internet.

 

Safari says it has no internet connection.

 

When i connect on ethernet i have internet.

 

Do anyone know what The problem is?


MacBook Pro, OS X Mountain Lion
  • 1. Re: Mountain lion wifi problems
    DrVenture Level 2 Level 2 (180 points)

    Interesting.

     

    You can connected via Wi-Fi to your router but Safari reports you have no internet connection.

     

    First lets see if your dns entries are good.

     

    Open a terminal and try to ping apple like this:

     

    ping www.apple.com

     

    Let the ping command run a few times then hit control c to stop the pings.

     

    Do the pings go through to www.apple.com or are you getting timeouts? Also, copy and paste the output from the terminal to this thread.

     

    If you are getting pings to go through, can you run this command in terminal:

     

    scutil -r www.apple.com

     

    And then paste the output here of the above command.

     

    Let's start here.

  • 2. Re: Mountain lion wifi problems
    henrijacobs Level 1 Level 1 (0 points)

    I get this message:

     

    localhost:~ henri$ ping http://www.apple.com

    ping: cannot resolve http://www.apple.com: Unknown host

     

    when i try to ping www.apple.com

  • 3. Re: Mountain lion wifi problems
    henrijacobs Level 1 Level 1 (0 points)

    And when i do it whit my ethernet i get response from www.apple.com

  • 4. Re: Mountain lion wifi problems
    DrVenture Level 2 Level 2 (180 points)

    I should have been a little more clear. Ping cannot resolve a hostname like that.

     

    the command should be:

     

    ping www.apple.com (leave the http:// off of the hostname).

     

    You could also try the following:

     

    1. trash the system config PLISTS and reboot (note you will loose your iMac's network settings, so if you are using static entry's IP address, DNS, etc be sure to write them down before attempting this).

     

    Open a terminal and do the following commands:

     

    mkdir ~/Desktop/old_sys_configs

    sudo cp -pR /Library/Preferences/SystemConfiguration/* ~/Desktop/old_sys_configs

    cd /Library/Preferences/SystemConfiguration/

    rm -rf *.plist

     

    The above commands will save a copy of your current network settings to a folder on the Desktop. Reboot your iMac. When your Mac comes back, try to connect to your Ethernet network or Wi-Fi network and see what happens.

     

    If you wanted to restore your old network configuration (since the files are on the desktop) all you would need to do is the following in terminal:

     

    sudo cp -R ~/Desktop/old_sys_configs/* /Library/Preferences/SystemConfiguration/

     

    And then reboot.


  • 5. Re: Mountain lion wifi problems
    av_a_go Level 1 Level 1 (0 points)

    Check your router settings and see if you have Wireless QoS (WMM) enabled? If so, diable it. This fixed my problems, and had the benefit of speeding up my wifi in the process.

  • 6. Re: Mountain lion wifi problems
    hbklau Level 1 Level 1 (0 points)

    Bro, you must be having the same problem with many of the guys are facing. It's a known bug and waiting for apple to come out with solution. I suggest you stick to wired connection first. At least you are lucky. I am using iPad to reply you as I have the same problem as you. This also shows my internet wifi is good.

  • 7. Re: Mountain lion wifi problems
    Ju1ia Level 1 Level 1 (0 points)

    I had the WiFi issue too with my late 2010 iMac... had to change the router settings to WPA2 instead of WEP security. According to Apple Care, the WEP security is too old school for the new software. HTH.

  • 8. Re: Mountain lion wifi problems
    santranyc Level 1 Level 1 (10 points)

    I noticed today that AirPlay didn't work for more than 30 seconds on my 2007 MacBook Pro (trying it for the first time after installing ML).  My 2010 Air, iPhone 4S, and iPad3 had no problem with AirPlay.  I connected the 2007 MBP to my Airport Extreme with an Ethernet cable, and bingo the problem was immediately solved.

     

    So I thought, oh, I must be part of this problem where a lot of people are having wi-fi connectivity issues with ML.

     

    Called Apple, they had me boot in Safe Mode (hold down Shift while booting), which runs diagnostics and fixes like most of what runnuing Disk Utility would do, and now Airplay is fixed and working perfectly, just as it did before ML was installled.

     

    tl;dr: solved wi-fi problem(s) by rebooting into Safe Mode and then rebooting.

     

    (The next two steps would have been PRAM reset and then SAC reset.)

  • 9. Re: Mountain lion wifi problems
    jfsiman Level 1 Level 1 (0 points)

    I changed my MTU to 1300 on the WiFi network and it solved my problem.  Please try it and let us know if that solved it for you.

     

    Go to System Preferences -> Network -> Advanced -> Hardware

     

    check to Manually, MTU: 1300

  • 10. Re: Mountain lion wifi problems
    santranyc Level 1 Level 1 (10 points)

    4 hours later and problem returned.  I feel burned.

     

    The Apple specialist said, "Whenever there is an upgrade, 90% of user problems are because there was something wrong with their machines—it's not the OS update."

     

    I took him at his words.  What a fool I was.

     

    I should have known when he told me he'd been doing his job for Apple for nine years.  How many people in tech these days keep the same job at the same company for that long?  It's just dumb.

     

    I told him I'd in been in IT for 30 years; he just got more patronizing.

     

    jfsiman, I will try your fix.  Then PRAM and SAC reset.

     

    Folks, just between us and the wall, I think it's an ML problem.

  • 11. Re: Mountain lion wifi problems
    santranyc Level 1 Level 1 (10 points)

    jfsim wrote:

     

    >I changed my MTU to 1300 on the WiFi network and it solved my problem.  Please try it and let us know if that solved it for you.

     

    Nope, this didn't work.  Nor did PRAM reset.  Nor SAC reset.  Nor making sure NONE of my other devices were set to any AirPlay Airport Express in my Loft.

     

    Houston, we have a problem.

     

    I'm calling Apple back.

  • 12. Re: Mountain lion wifi problems
    Kauai Guy Level 1 Level 1 (0 points)

    Tried the same things with the same results - none.  The fact that everyone else (non-upgraded) on the exact same network I am on is still fine and surfing smoothly while the only thing I did was to upgrade to 10.8 without adjusting anything else puts egg on my face as well as putting me in hot water with my employer as I cannot get things done!  Angry and frustrated at Apple right now for releasing something that was NOT ready.

     

    -----------------------------------------------------

    17" MBP 2011, 2.4Ghz i7, 8GB Ram

  • 13. Re: Mountain lion wifi problems
    henrijacobs Level 1 Level 1 (0 points)

    Hi everyone,

     

    Thanks for all tips and trucks,

     

    but nothing helped, it is a problem with my router and the update,

     

    but i bought a TC en an airport express (that was already in my mind before the update)

    And now it all works fine.....

  • 14. Re: Mountain lion wifi problems
    nico4659 Level 1 Level 1 (0 points)

    I tried to press cmd+r at startup, and connectet to the wifi spot that way. Worked for me...

1 2 3 Previous Next