9 Replies Latest reply: Aug 23, 2012 1:50 AM by John Caradimas
Jim Bridger Level 1 Level 1 (5 points)

Has anyone else noticed that Aperture is not automaically ejecting the SD card after an Import even thogh that option is checked on the Import window? I've loaded two cards since the upgrade and so far neither time has it ejected the card as expected.


Mac OS X (10.6.7)
  • 1. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    dbmoore Level 1 Level 1 (105 points)

    I have noticed this since 3.3.1.  Had to learn an extra step of throwing the mounted disk in the trash.

  • 2. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    léonie Level 9 Level 9 (51,720 points)

    I am happy it does no longer eject it automatically.

     

    Now I can import the images and the videos to different applications, or import a large set of images in different import sessions without having to mount the card reader over and over again.

  • 3. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    Jim Bridger Level 1 Level 1 (5 points)

    LeonieDF,

     

    Glad you're happy it no longer ejects the card after import. However, that's not the way it's supposed to work if you have the eject card option checked. Once they get if fixed to work properly you can have your cake too by just making sure the option is not checked. Pretty simple don't you think?

  • 4. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    léonie Level 9 Level 9 (51,720 points)

    Jim,

    Glad you're happy it no longer ejects the card after import. However, that's not the way it's supposed to work if you have the eject card option checked.

    thank you, I think

     

    The way it is supposed to work is not described in the manual, for it is depending on the make of your camera. The manual only states:

    Note: The options offered in this dialog depend on the way your camera is made available when it is connected. Some cameras connect as mass storage devices. When you import from these cameras, the Erase and Eject options appear. Other cameras simply connect as cameras, and you will not see either Erase or Eject after the import is completed. In that case, you can erase the images directly in the camera.

    I see for all cameras different controls. For my Lumix camera I see the "Eject" button, but no option to choose, if I want automatic eject. The Canon camera does not show any options at all. The automatic "Eject" option I have never seen for any camera I had - only an automatic "Erase", that I never used, for it is dangerous. So up to now I had to live with auto eject, because there never has been an option to select differently.

     

    Apple certainly could improve the documentation of this feature in the otherwise very good manual.

     

    Regards

    Léonie

  • 5. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    Jim Bridger Level 1 Level 1 (5 points)

    Ok LeonieDF, the difference between our two situations is I never attach a camera to download images from. I always us an external card reader. Maybe that's why my Eject was always on option. Yea, Apple good offer better documenation for lost of things in the manual. Thanks for helpig out on this.

  • 6. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    Kirby Krieger Level 6 Level 6 (11,945 points)

    Hi Jim,

     

    Not sure what the status of this thread is.  I have used all of:

    - the on-board SD readers in my old MBP

    - the on-board SD reader in my new rMBP

    - and two different card readers

    and I've not encountered the "not being ejected" problem.  Sometimes I want the card ejected, sometimes I don't -- whichever I select works as expected.

     

    Have you tried other card readers?  Other cards?

  • 7. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    Jim Bridger Level 1 Level 1 (5 points)

    Have tried several different cards, both CF and SD. Have used the same two card readers, one CF and one SD that I used before the new aperure update was released. They worked without a hitch prior to the release. The card readers are a SanDisk and a Targus SD. Guess it must be something I'm doing since their is so little be registered here on this thread. Thanks for your input.

  • 8. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Jim,

     

    I never have used it, but the box is there with use of my card readers.  It has never been clear to me what it would do, given the two button commands.  Since I never, ever, would allow Aperture or OSX to delete from the card, I have always chosen to manually eject the card from a Finder window, rather than find out what it would do with the Delete vs Leave options.

     

    Also, like Leonie, I often multi-stage my import workflow.

     

    Ernie

  • 9. Re: Aperture 3.3.2 Not Ejecting Card After Import?
    John Caradimas Level 1 Level 1 (10 points)

    I just noticed this too. I am not sure if it presented itself after the latest Mountain Lion upgrade on my Macbook, or of it was there before, I haven't shot too many pictures during the previous month, but I shot a lot during our vacations now, and the card never gets ejected, even if the "Eject card" box is checked, I just verified it now.

     

    And for sure, that's not the way Aperture was working before, nor is it the way Aperture should work. If you tell the program to eject the card, the card should be ejected.

     

    Just for clarifying things, I am using a late 2008 13" Macbook, with OS-X 10.8, Aperture 3.3.2 and a Transcend card reader, reading both CF and SD cards.