Skip navigation

Mountain lion wifi problems

123683 Views 371 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz RSS Branched to a new discussion.
1 2 3 ... 25 Previous Next
henrijacobs Calculating status...
Currently Being Moderated
Jul 25, 2012 2:13 PM

I have just installed mountain lion.

All went good, but now i have à problem with wifi.

 

My connection is ok, i get an ip adress, but i cant get On internet.

 

Safari says it has no internet connection.

 

When i connect on ethernet i have internet.

 

Do anyone know what The problem is?

MacBook Pro, OS X Mountain Lion
  • DrVenture Level 2 Level 2 (180 points)
    Currently Being Moderated
    Jul 25, 2012 3:30 PM (in response to henrijacobs)

    Interesting.

     

    You can connected via Wi-Fi to your router but Safari reports you have no internet connection.

     

    First lets see if your dns entries are good.

     

    Open a terminal and try to ping apple like this:

     

    ping www.apple.com

     

    Let the ping command run a few times then hit control c to stop the pings.

     

    Do the pings go through to www.apple.com or are you getting timeouts? Also, copy and paste the output from the terminal to this thread.

     

    If you are getting pings to go through, can you run this command in terminal:

     

    scutil -r www.apple.com

     

    And then paste the output here of the above command.

     

    Let's start here.

  • DrVenture Level 2 Level 2 (180 points)
    Currently Being Moderated
    Jul 26, 2012 4:18 PM (in response to henrijacobs)

    I should have been a little more clear. Ping cannot resolve a hostname like that.

     

    the command should be:

     

    ping www.apple.com (leave the http:// off of the hostname).

     

    You could also try the following:

     

    1. trash the system config PLISTS and reboot (note you will loose your iMac's network settings, so if you are using static entry's IP address, DNS, etc be sure to write them down before attempting this).

     

    Open a terminal and do the following commands:

     

    mkdir ~/Desktop/old_sys_configs

    sudo cp -pR /Library/Preferences/SystemConfiguration/* ~/Desktop/old_sys_configs

    cd /Library/Preferences/SystemConfiguration/

    rm -rf *.plist

     

    The above commands will save a copy of your current network settings to a folder on the Desktop. Reboot your iMac. When your Mac comes back, try to connect to your Ethernet network or Wi-Fi network and see what happens.

     

    If you wanted to restore your old network configuration (since the files are on the desktop) all you would need to do is the following in terminal:

     

    sudo cp -R ~/Desktop/old_sys_configs/* /Library/Preferences/SystemConfiguration/

     

    And then reboot.


  • av_a_go Calculating status...
    Currently Being Moderated
    Jul 30, 2012 3:59 AM (in response to henrijacobs)

    Check your router settings and see if you have Wireless QoS (WMM) enabled? If so, diable it. This fixed my problems, and had the benefit of speeding up my wifi in the process.

  • hbklau Calculating status...
    Currently Being Moderated
    Jul 31, 2012 3:24 AM (in response to henrijacobs)

    Bro, you must be having the same problem with many of the guys are facing. It's a known bug and waiting for apple to come out with solution. I suggest you stick to wired connection first. At least you are lucky. I am using iPad to reply you as I have the same problem as you. This also shows my internet wifi is good.

  • Ju1ia Calculating status...
    Currently Being Moderated
    Jul 31, 2012 2:02 PM (in response to henrijacobs)

    I had the WiFi issue too with my late 2010 iMac... had to change the router settings to WPA2 instead of WEP security. According to Apple Care, the WEP security is too old school for the new software. HTH.

  • santranyc Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 1, 2012 7:47 AM (in response to henrijacobs)

    I noticed today that AirPlay didn't work for more than 30 seconds on my 2007 MacBook Pro (trying it for the first time after installing ML).  My 2010 Air, iPhone 4S, and iPad3 had no problem with AirPlay.  I connected the 2007 MBP to my Airport Extreme with an Ethernet cable, and bingo the problem was immediately solved.

     

    So I thought, oh, I must be part of this problem where a lot of people are having wi-fi connectivity issues with ML.

     

    Called Apple, they had me boot in Safe Mode (hold down Shift while booting), which runs diagnostics and fixes like most of what runnuing Disk Utility would do, and now Airplay is fixed and working perfectly, just as it did before ML was installled.

     

    tl;dr: solved wi-fi problem(s) by rebooting into Safe Mode and then rebooting.

     

    (The next two steps would have been PRAM reset and then SAC reset.)

  • jfsiman Calculating status...
    Currently Being Moderated
    Aug 1, 2012 10:43 AM (in response to henrijacobs)

    I changed my MTU to 1300 on the WiFi network and it solved my problem.  Please try it and let us know if that solved it for you.

     

    Go to System Preferences -> Network -> Advanced -> Hardware

     

    check to Manually, MTU: 1300

  • santranyc Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 1, 2012 12:49 PM (in response to santranyc)

    4 hours later and problem returned.  I feel burned.

     

    The Apple specialist said, "Whenever there is an upgrade, 90% of user problems are because there was something wrong with their machines—it's not the OS update."

     

    I took him at his words.  What a fool I was.

     

    I should have known when he told me he'd been doing his job for Apple for nine years.  How many people in tech these days keep the same job at the same company for that long?  It's just dumb.

     

    I told him I'd in been in IT for 30 years; he just got more patronizing.

     

    jfsiman, I will try your fix.  Then PRAM and SAC reset.

     

    Folks, just between us and the wall, I think it's an ML problem.

  • santranyc Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 1, 2012 1:27 PM (in response to jfsiman)

    jfsim wrote:

     

    >I changed my MTU to 1300 on the WiFi network and it solved my problem.  Please try it and let us know if that solved it for you.

     

    Nope, this didn't work.  Nor did PRAM reset.  Nor SAC reset.  Nor making sure NONE of my other devices were set to any AirPlay Airport Express in my Loft.

     

    Houston, we have a problem.

     

    I'm calling Apple back.

  • Kauai Guy Calculating status...
    Currently Being Moderated
    Aug 1, 2012 1:37 PM (in response to santranyc)

    Tried the same things with the same results - none.  The fact that everyone else (non-upgraded) on the exact same network I am on is still fine and surfing smoothly while the only thing I did was to upgrade to 10.8 without adjusting anything else puts egg on my face as well as putting me in hot water with my employer as I cannot get things done!  Angry and frustrated at Apple right now for releasing something that was NOT ready.

     

    -----------------------------------------------------

    17" MBP 2011, 2.4Ghz i7, 8GB Ram

  • nico4659 Calculating status...
    Currently Being Moderated
    Aug 2, 2012 5:13 AM (in response to henrijacobs)

    I tried to press cmd+r at startup, and connectet to the wifi spot that way. Worked for me...

1 2 3 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.