Skip navigation

Aperture 3.3.2 Not Ejecting Card After Import?

641 Views 9 Replies Latest reply: Aug 23, 2012 1:50 AM by John Caradimas RSS
Jim Bridger Level 1 Level 1 (5 points)
Currently Being Moderated
Jul 25, 2012 3:02 PM

Has anyone else noticed that Aperture is not automaically ejecting the SD card after an Import even thogh that option is checked on the Import window? I've loaded two cards since the upgrade and so far neither time has it ejected the card as expected.

Mac OS X (10.6.7)
  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    Jul 25, 2012 3:56 PM (in response to Jim Bridger)

    I have noticed this since 3.3.1.  Had to learn an extra step of throwing the mounted disk in the trash.

  • léonie Level 8 Level 8 (46,365 points)
    Currently Being Moderated
    Jul 25, 2012 11:02 PM (in response to Jim Bridger)

    I am happy it does no longer eject it automatically.

     

    Now I can import the images and the videos to different applications, or import a large set of images in different import sessions without having to mount the card reader over and over again.

  • léonie Level 8 Level 8 (46,365 points)
    Currently Being Moderated
    Jul 26, 2012 11:50 PM (in response to Jim Bridger)

    Jim,

    Glad you're happy it no longer ejects the card after import. However, that's not the way it's supposed to work if you have the eject card option checked.

    thank you, I think

     

    The way it is supposed to work is not described in the manual, for it is depending on the make of your camera. The manual only states:

    Note: The options offered in this dialog depend on the way your camera is made available when it is connected. Some cameras connect as mass storage devices. When you import from these cameras, the Erase and Eject options appear. Other cameras simply connect as cameras, and you will not see either Erase or Eject after the import is completed. In that case, you can erase the images directly in the camera.

    I see for all cameras different controls. For my Lumix camera I see the "Eject" button, but no option to choose, if I want automatic eject. The Canon camera does not show any options at all. The automatic "Eject" option I have never seen for any camera I had - only an automatic "Erase", that I never used, for it is dangerous. So up to now I had to live with auto eject, because there never has been an option to select differently.

     

    Apple certainly could improve the documentation of this feature in the otherwise very good manual.

     

    Regards

    Léonie

  • Kirby Krieger Level 6 Level 6 (11,550 points)
    Currently Being Moderated
    Jul 31, 2012 9:20 PM (in response to Jim Bridger)

    Hi Jim,

     

    Not sure what the status of this thread is.  I have used all of:

    - the on-board SD readers in my old MBP

    - the on-board SD reader in my new rMBP

    - and two different card readers

    and I've not encountered the "not being ejected" problem.  Sometimes I want the card ejected, sometimes I don't -- whichever I select works as expected.

     

    Have you tried other card readers?  Other cards?

  • Ernie Stamper Level 8 Level 8 (37,430 points)
    Currently Being Moderated
    Aug 1, 2012 5:21 AM (in response to Jim Bridger)

    Jim,

     

    I never have used it, but the box is there with use of my card readers.  It has never been clear to me what it would do, given the two button commands.  Since I never, ever, would allow Aperture or OSX to delete from the card, I have always chosen to manually eject the card from a Finder window, rather than find out what it would do with the Delete vs Leave options.

     

    Also, like Leonie, I often multi-stage my import workflow.

     

    Ernie

  • John Caradimas Calculating status...
    Currently Being Moderated
    Aug 23, 2012 1:50 AM (in response to Jim Bridger)

    I just noticed this too. I am not sure if it presented itself after the latest Mountain Lion upgrade on my Macbook, or of it was there before, I haven't shot too many pictures during the previous month, but I shot a lot during our vacations now, and the card never gets ejected, even if the "Eject card" box is checked, I just verified it now.

     

    And for sure, that's not the way Aperture was working before, nor is it the way Aperture should work. If you tell the program to eject the card, the card should be ejected.

     

    Just for clarifying things, I am using a late 2008 13" Macbook, with OS-X 10.8, Aperture 3.3.2 and a Transcend card reader, reading both CF and SD cards.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.