Skip navigation

smart mailboxes missing

2681 Views 18 Replies Latest reply: Apr 14, 2014 9:55 AM by Patrick Gibson RSS
1 2 Previous Next
Andrew Smith15 Calculating status...
Currently Being Moderated
Jul 25, 2012 4:04 PM

Nothing devastating, but after ugrading to Mountain Lion and having my email converted over to Mail 6.0, all of my smart mailboxes I set up are missing. I assume the emails are still in the system, but the smart mailboxes do not appear.

 

I will note that I can set up new smart mailboxes, which appear correctly in the side panel.

 

Andy

  • Malacandrian Calculating status...
    Currently Being Moderated
    Jul 26, 2012 7:20 AM (in response to Andrew Smith15)

    Same thing here. 

     

    Do you use InDev software's MailTags?  It has a nice feature allowing you to share rules and Smart Mailboxes via DropBox, and that setting had disabled when I opened Mail in Mountain Lion, though it had been set (and working) previously.

     

    But whether it's implicated or not, it's a drag to lose a good dozen mailboxes.

  • greenev Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 26, 2012 8:10 AM (in response to Andrew Smith15)

    Smart mailboxes are still there. It says smartmail boxes but shows nothing at all. Just click on smart mail boxes and a small dialog pops up that says show or hide. It is defaulted to hide. click on show and there you go. Took all but a sec to figure that one out.

     

    Pete

  • Malacandrian Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 8:13 AM (in response to greenev)

    greenev: that wasn't the case for me. 

     

    There was no SMART MAILBOXES header at all until I created a new smart mailbox.

  • guitarbruc Calculating status...
    Currently Being Moderated
    Aug 2, 2012 11:21 AM (in response to Andrew Smith15)

    On mine, the prior 'smart mailboxes' are there, after you un-hide the "ON MY MAC" but they are no longer smart mailboxes. They are just like any other folder that you drag mail to. I did create a new Smart Mailbox with the same criteria that I recalled from one of the old Smart Mailboxes and it populated with all the mail that was in the folder that used to be the Smart Mailbox. Does that make sense?

     

    It just seems like Mountain Lion just lost the Smart Mailbox functionality in the conversion. The mail is still there but the criteria that got it there is absent.

  • Henk Smets Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2012 3:00 AM (in response to Andrew Smith15)

    You're smart folders are stil there, I think.The solution is somewhere in /Users/ACCOUNTNAME/Library/Mail (in finder use alt-key to go to library or use terminal).

     

    Apparantly some things changed towards a more cloud-synced model.

     

    I had a similar problem with my rules and I solved it to by copying the rules to the file "unsyncedRules.plist".

     

    I found my old smart folders in the file SmartMailBoxes.plist and some other .plist files wich seem related to the smart mailboxes, but I didn't succeed in getting it to work by copying my SmartMailBoxes to the other files.

     

    I gues I'll have to recreate them. This has been a very troubled update so far (had some problems with filevault also). I waited untill 10.8.1 to avoid them, but alas.

  • Michael Miles Calculating status...
    Currently Being Moderated
    Oct 7, 2012 8:49 PM (in response to Andrew Smith15)

    I also think the problem lies with iCloud.  It does not sych Smart Mailbox rules as did MobileMe -- and similarly does not sych keychains.  This is a big loss with iCloud. So now I have 3 different sets of Smart Mailboxes on my 3 different macs. Really good job of integration, Apple.

  • DonMigell Calculating status...
    Currently Being Moderated
    Feb 24, 2013 11:31 AM (in response to Michael Miles)

    Experiencing missing mailboxes should have been a problem sorted. It's now Feb 2013 and I'm having this same problem. Is there a definitive answer to sorting this problem?

  • Eric Root Level 6 Level 6 (13,850 points)
    Currently Being Moderated
    Feb 24, 2013 11:46 AM (in response to Andrew Smith15)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Feedback

  • DonMigell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 24, 2013 1:06 PM (in response to Eric Root)

    Will do.

  • Edouard Puginier Calculating status...
    Currently Being Moderated
    Jul 20, 2013 11:08 AM (in response to Andrew Smith15)

    I solved it! — Hope this will work for you!

     

    Hi folks!

     

    After facing the problem since the original release of Mountain Lion (don't ask me to describe how I was frustrated), I've finally decided I had to find a solution. I was heavilly using Smart Mailboxes and today was the day I was not able to handle waiting another day with no solution from Apple!

     

    So here's the solution to get all your bunch of Smart Mailboxes back on Mail.app!

     

    • Quit Mail.app
    • Press  + Shift + g and go to your folder "~/Library/Mail/V2/MailData/" (without quotes)
    • Make a backup of this folder somewhere
    • Here, locate and open with a text-editor SmartMailboxes.plist and SyncedSmartMailboxes.plist
    • SmartMailboxes.plist should look like this:

    OldSmartMailboxes.png

    • SyncedSmartMailboxes.plist should look like this:

    SyncedSmartMailboxes.png

    • Edit SmartMailboxes.plist and REMOVE the necessary lines after <plist version="1.0"> so it match the look of SyncedSmartMailboxes.plist. I personnaly had to remove:

     

    <dict>

              <key>globalDisplaySortOrder</key>

              <array>

                        <string>CE2C3DB9-443F-489A-9DA4-4EA5DE6B8B82</string>

      —a bunch of them—

              </array>

              <key>mailboxes</key>

     

    • Scroll down to the end of the file and remove

     

    <key>version</key>

    <integer>2850</integer>

    </dict>

     

    • Verify SmartMailboxes.plist so it's structure seems to match the one of SyncedSmartMailboxes.plist
    • Select all the text of SmartMailboxes.plist, Copy and Paste on SyncedSmartMailboxes.plist
    • Save both files
    • Press  + Shift + g and go to your folder "~/Library/Mobile Documents/com~apple~mail/Data/MailData" (without quotes)
    • Locate and open with a text editor the file ubiquitous_SyncedSmartMailboxes.plist
    • Select all the text of SyncedSmartMailboxes.plist, Copy and Paste on ubiquitous_SyncedSmartMailboxes.plist
    • Save ubiquitous_SyncedSmartMailboxes.plist
    • Close all files
    • Restart Mail.app

     

    BOOM!

    All your Smart Mailboxes are instantly here! And guess what, sync is working: I wake-up my second computer which add the same problem and Mail instantly updated without having to relaunch the app.

    Now, I'm really happy!

     

    I really hope this will work for you guys!

    Take care.

     

    Édouard

     

    <Link Edited By Host>

  • ADeweyan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2013 10:02 AM (in response to Edouard Puginier)

    This is for anyone (like me) who experienced a somewhat different problem and ended up on this thread. This post pointed me in the right direction.

     

    My SmartFolders disappeared one day. They came over into Mavericks without a problem and worked fine for months -- but when I started Mail.app a day ago, the Smart Folders simply weren't there.

     

    Following the instructions in Édouard's post, I took a look at the ~/Library/Mail/V2/MailData/SyncedSmartMailboxes.plist file and found that it had been cleared.

     

    I restored the file from a TimeMachine backup, and all was good.

     

    If you have trouble getting to the TimeMachine backup of a Library file (because the Library can remain hidden even in TimeMachine) you can follow other instructions to make it visible (I followed these: http://www.macobserver.com/tmo/article/how_to_permanently_restore_the_visibility _of_the_users_library_folder. )

     

    Thanks Édouard!, and I hope this helps someone else!

  • Patrick Gibson Level 1 Level 1 (95 points)
    Currently Being Moderated
    Dec 16, 2013 3:51 PM (in response to ADeweyan)

    I've had the same problem since shortly after upgrading to Mavericks. One day, all of my Smart Mailboxes were gone. Even if I restore the SyncedSmartMailboxes.plist from a backup, as soon as I launch Mail, it just zeros the file out. I was hoping that today's 10.9.1 update would solve my problem, but it didn't. On a whim, I tried restoring a working SyncedSmartMailboxes.plist file and then locking it with the Finder. When I load Mail, I see my smart mailboxes! I can't make any changes, mind you, but it's a small price to pay to have them back. I've spent far too long trying to work out what could be wrong... I'm not actually sure why it's using a file called "SyncedSmartedMailboxes.plist" when I don't have any iCloud Mail syncing, but there you go...

  • Patrick Gibson Level 1 Level 1 (95 points)
    Currently Being Moderated
    Dec 16, 2013 4:11 PM (in response to Andrew Smith15)

    I've filed a bug report to Apple (Radar #15673722). I encourage others to do so as well.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.