Skip navigation

Exchange under Mountain Lion

291428 Views 831 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine RSS
  • trevorbsmith Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 5:02 PM (in response to m@zo)

    I am also having issues with my work exchange serve and Mountain Lion's Mail application.

     

    After reading this and another thread, I found that if I open Mail's preferences and go to the Accounts pane, my "Internal Server" has indeed been set to "sites" by some bug in Mail. If I set it back to the actual name of my internal exchange server, mail begins coming in properly. Everything seems to work ok.

     

    As others have noted, though, if I close Mail and reopen, the Internal Server gets set back to "sites" andI have to reset it, CLOSE the program, then reopen.

     

    So, change, save, close, reopen = Mail starts working. THEN close and reopen one more time, and Mail STOPS working (because it gets reset to "sites").

     

    (I also deleted all references to my mail exchange server in my keychain using the /Applications/Utilities/Keychain Access tool. Not sure if that was necessary or helpful.)

  • Mick Shrimpton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 5:35 PM (in response to trevorbsmith)

    I finally got this to work only after I deleted every conceivable reference to this exchange account in keychain, and then deleted and recreated my account in mail. Rediculous, but working now.

  • Mick Shrimpton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 5:58 PM (in response to Mick Shrimpton)

    Nevermind. I am still getting the issue described by the previous poster. Absurd...

  • Emma Richardson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 6:14 PM (in response to Mick Shrimpton)

    Sorry for your trouble but I thought that might happen.  I spent all day on this to no avail. I am now using Outlook for Mac to access my exchange account and mail for the rest - what a mess!

  • Ondray Wells Jr. Level 2 Level 2 (225 points)
    Currently Being Moderated
    Jul 26, 2012 6:32 PM (in response to m@zo)

    I'm having the exact same issue.  All of my Exchange enabled apps that worked fine in Lion now will not connect to the Exchange server in Mountain Lion.  I set all of these apps to use the EWS server for a reason.  That way it did not matter if I was at work on the corporate network or at home on my own network. All the apps just worked! Now Mountain Lion is trying to be too clever by half.  I went to System Preferences and selected my Exchange account and clicked Details ... hoping to be able to modify the server settings.  Unfortunately, you are only able to enter your name and password.  I've never used the internal server or entered its information on any app.  So ML must be getting that info automatically by using the domain name in the email address.  That was bad enough that my settings were changed.  It was downright infuriating to find out that when I changed it back ML decides to override what I explicitly told it to use.  I was able to enter the EWS server in the External Server setting.  I also checked the Use SSL checkbox.  That sort of works for Mail. If you aren't on the corporate network it still stupidly gives you an error message several times because it tries to connect using the Internal Server first instead of recognizing you aren't on the network and using the External Server by default.  But after clicking Continue it seems to behave itself.  Taking this same approach in Calendar and Contacts doesn't result in these error messages but unfortunately, these apps simply refuse to connect using the External Server at all.  The Reminders app has the same issue because even though it has its own UI it's still using Calendar under the hood. I don't use Exchange Notes so I can't speak to whether it works or not.

     

    Bottom line?  I can't work remotely outside of Mail.  There's simply no excuse for a major bug like this to make its way into a public release.

  • Ondray Wells Jr. Level 2 Level 2 (225 points)
    Currently Being Moderated
    Jul 26, 2012 7:31 PM (in response to Ondray Wells Jr.)

    It appears the workaround of editing the /etc/hosts file as suggested earlier works.  For those less technically inclined this is how to do it:

     

    1. Close Mail.  Wait a few seconds and then open it back up.  Got to Preferences - Accounts.  Select your Exchange server entry and see what value ML insists upon putting in Internal Server.  Write this down somewhere.

     

    2. Open up Terminal.  Type "ping server.domain.com" (no quotes) where server.domain.com is the value that you previously used in the Internal Server setting for Mail.  If you're lucky the server will respond at least once.  Write down the IP address (xx.xx.xxx.xx).

     

    3. Open up Finder.  Select Go-Go To Folder menu.  Enter /etc in the dialog and click Go.  Find the file named "hosts".  Copy it to the  Desktop. 

     

    4. Open up the "hosts" file on the Desktop in TextEdit.  At the end enter the Internal Server name you wrote down in step 1 on the left.  A few spaces over on the same line enter the IP Address you wrote down in Step 2.  Save the file and close TextEdit.

     

    5. Drag the updated "hosts" file on the Desktop back into the Finder window display the /etc directory from Step 3.  You will need to authenticate with your password.  Be sure to select the replace option.

     

    6. All the Exchange enabled apps should work now.

     

    What this does is tell the OS that "server.domain.com" should resolve to the IP address of the actual external server you want to use ... rather than the IP address it actually has.  You've basically "tricked" the system in order to get around this boneheaded change.  So far I haven't seen any issues.  Emails in the Exchange inbox sometimes disappear ... but I have the feeling that's a separate bug.  Switching from one mailbox to another and coming back often fixes this issue.  Restarting Mail seems to fix it consistently when it occurs.

     

    Hope this helps!

  • dwalthour Calculating status...
    Currently Being Moderated
    Jul 26, 2012 7:36 PM (in response to Ondray Wells Jr.)

    Thanks for posting this.  I was just about to write this up myself and then I saw your explaination.  I can add that I have been using this workaround for the last 24 hrs and it has resolved my issues with Mail for the time being.  I hope apple gets this one fixed real soon.

  • Rlaughl0 Calculating status...
    Currently Being Moderated
    Jul 26, 2012 10:22 PM (in response to Ondray Wells Jr.)

    I'm glad if this does work for you. My question is your Calendar up and running too?

     

    If you're good to go if you could write those out in a bit more simplistic terms that would be very helpful for me. I have been working on this all day. I'm trying to keep it from engulfing my entired Friday too.

     

    Thanks for the help!

  • C.Onen Calculating status...
    Currently Being Moderated
    Jul 27, 2012 1:01 AM (in response to m@zo)

    Thank you, after spending many hours trying to figure this problem. I have seen your solution and it worked like a charm.

  • yiiit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 2:30 AM (in response to m@zo)

    OK guys - the problem is, that Mail.app under ML changes the server adress automatically into "server", means the server adress e.g. "192.168......" gets changed into "server".

     

    That's why the calendar, contacts and the mails are not getting synct. You can change/correct the server adress directly in the prefs of Mail.app and it's gonna work again - BUT the funny part is, that Mail.app still changes the adress each time you quit and restart Mail.app.

     

    So humm, shall we still call Microsoft to get support for this issue?

     

    Don't know if this is sth that can be fixed through Terminal.app, but maybe someone can call Apple again to let them know the issue? Shouldn't be that big deal to fix this with an update - hopefully.

  • Micro67 Calculating status...
    Currently Being Moderated
    Jul 27, 2012 4:38 AM (in response to Ondray Wells Jr.)

    Thanks for the tip and a straightforward explanation. I tried it with various success. Most of the lost folders came back, but then dissapered again. They seem to come back again after restarting the Mail app. But Mail has to resync all lost folders every time. My mail has a lot of different folders and thousands of emails. So it takes a while. 

     

    I cant receive emails without quitting and restarting the Mail app. Everything has worked before as a charm, but after upgrading to ML it stopped.

     

    Another problem I have is that the Mail app unexpectedly quits frequently. Never done that before the ML upgrade.

     

    Having similar problems on other computers. Fortunately all folders and mail seems to work on the iPad. So I guess I nothing is permanently lost. But its frustrating enough. Hopefully Apple will come out with a fix in a very very short time. My holiday stops on Monday.

     

    Apple, please hurry up.

  • Emma Richardson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 4:50 AM (in response to Ondray Wells Jr.)

    I don't know how everyone else's networks are set up but the ip address for my mail server is different if I am at the office to if I am at home.  Are you reconciling the internal address to the internal ip and then Mail is switching over to the external when that doesn't work?  Or are you reconciling it to the public ip which means it will not work when at the office!

  • yiiit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 4:58 AM (in response to Micro67)

    The problem you're talking about is the same problem a lot of people had with Lion (10.7) - discussing here. Apple never did react on this issue - besides warning/asking users who were calling for a petit**n.

     

    It seems they didn't solve this problem with 10.8, honestly - I have the same problems right now. There are several improvised ways to fix that problem - but nothing official from Apple and it's not clear, which way is the right way to fix this.

     

    Apple at least could publish a work around if the problem is Microsoft's Exchange Server software.

  • yiiit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 5:00 AM (in response to Emma Richardson)

    That's a good question I would like to see an answer as well. Does Apple mail switch automatically to internal/external server adress, if the mac is within or outside the Server's network?

  • Emma Richardson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 5:19 AM (in response to Micro67)

    I think the reason the emails are disappearing and reappearing is that it appears that Mail is creating two different inboxes - one for the local address and one for the external address.  And then it is getting confused as to which Inbox to access.  I think they were trying to set up authentication more like Outlook pulling different addresses for internal and external when they should have just left it alone!  It is ain't broke, don't fix it, Apple!!!  Give us our Exchange accounts back please!!

1 2 3 4 5 ... 56 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (62)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.