1 2 3 Previous Next 70 Replies Latest reply: Oct 10, 2012 1:21 PM by movery
Phillip Breske Level 1 Level 1 (60 points)

The hits just keep on comin'! Last week my Aperture library was corrupted and I had to restore some files from a backup and delete some preference files to get it to work again. Now I'm having a new problem....

 

Aperture 3.3.2 launches and I get the "Opening Aperture library" window, but it never progresses to the usable application. Only a Force Quit allows me to try again. Launching Aperture while pressing the Option key allows me to select a different library (I set up a "dummy" library just for this purpose) and once the application is open, I choose File>Switch to Library>Other/New... and pick the main library, which then opens without further complaint. I can initially choose a dummy file on the same external hard drive as my main library, or I can choose a dummy from the Mac's hard drive—either one allows me to successfuly launch the application and proceed to opening the main library.

 

If I then quit the application and immediately attempt to re-launch it, the same thing happens again. I need to use the alternate library to launch, then switch from the active application.

 

I can switch to the alternate before quitting the app and it remembers the alternate library as the new default. It will then launch fine to the new default (alternate) library. At that point I can quickly switch to the main library.

 

So, I know the problem must be in the main library, but I can't figure out why it will launch successfully only after opening a different library.

 

I repaired permissions and rebuilt and repaired the database, but none of these seemed to fix the problem I'm having.

 

Any ideas?


iMac, Mac OS X (10.7.2), 27" iMac Core i7 Quad 12GB
  • 1. Re: Aperture 3.3.2 hangs on launch (library issue)
    Francis Gagnon Level 1 Level 1 (15 points)

    Hi Phillip. Same problem here, although I can quit Aperture when using the menu bar. I also repaired the permissions and the library, and rebuilt the database. I was able to open 3.3.2 for a few days before this problem came up. I installed Moutain Lion, thinking it could be a compatibility problem. No luck. I called Applecare, but I was way past my 90 days of phone support so they sent me to this page on the basics of troubleshooting. I've done everything short of reinstalling Aperture.

     

    Thanks a lot for sharing your tip of creating a new library - at least it gets me access to my normal library, until the problem is solved.

  • 2. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    Oh, jeez. I didn't even think to use the Quit command from the Aperture menu. Duh. Okay, that works for me, too.

     

    And now that I've tried it, I can make a launch attempt to my main library (which, of course, results in a hang) and before quitting I can switch to the alternate library. The switch doesn't immediately open the alternate, but I can quit and re-launch to the alternate. Once the alternate library is open, I switch to the main and I'm good.

     

    Thank you for the obvious tip about using the menu to quit.

     

    I also just upgraded to 10.8 Mountain Lion, but it didn't resolve this issue.

  • 3. Re: Aperture 3.3.2 hangs on launch (library issue)
    dc cma Level 1 Level 1 (35 points)

    Restored Aperture 3.1.1 from 06.28.12 Time Machine backup ~ Aperture (Original) now working again.. waiting for an Apple tweaka until I go back/forward

  • 4. Re: Aperture 3.3.2 hangs on launch (library issue)
    @rnopier Level 1 Level 1 (0 points)

    Dears

     

    I don't know how that is possible but Aperture works again after the same problems we know !

    I made all the things describe above and like every body nothing happen.

    And I try to make a new "library" and import the all one by File>Import>Library ... not enough place (my library is over 350000 pictures ... I was nervous ....) !

    And I I try File>Switch to Library>Other/New ...

    And ... and ... the complete lLibrary appear ! after 2 sad and *.:,,=!¡?¿ days !!!

    Hope that works for you too ...

  • 5. Re: Aperture 3.3.2 hangs on launch (library issue)
    @rnopier Level 1 Level 1 (0 points)

    Ok, now I know how to, because I quit Aperture and that did it again.

    The problem is  the interface of Aperture don't open with the old Library.

    Open Aperture with "option" and choose an old library if you have one, hope you have ...

    This old Library open easy

    And I I try File>Switch to Library>Other/New ...

    And ... and ... the complete lLibrary appear !

  • 6. Re: Aperture 3.3.2 hangs on launch (library issue)
    @rnopier Level 1 Level 1 (0 points)

    It's just a trick please Apple give us a patch to solve that !

  • 7. Re: Aperture 3.3.2 hangs on launch (library issue)
    dbmoore Level 1 Level 1 (105 points)

    I too had a crupted lib file that would not open without using the switch lib trick.  I used my Vault and built a new lib.  Now all is well so far.....

  • 8. Re: Aperture 3.3.2 hangs on launch (library issue)
    Jonathan Hudson Level 1 Level 1 (25 points)

    Same thing happened to me last night. Aperture was running fine. I quit it, then restarted it to do one more thing-- and it is now hanging at "Opening Aperture library." I can't get it to open the library.

     

    Aperture 3.3.2 on 10.8

  • 9. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    Try this:

     

    1. While it's showing the "Opening Aperture library" notice, use the File > Switch to Library > Other/New... command.

     

    2. Click Create New and call it "Alternate Library" or something like that. Click Create to open the new library. This won't work, but you need to fool Aperture into setting a new default library. At this point, the application should briefly show the "Opening Aperture library" notice, but it may disappear. The application should still be stuck in an endless hang. 

     

    3. Use the Quit command to exit the application and re-launch. The newly created empty library should open normally.

     

    4. Once the alternate is open, use the Switch to Library command again and you should see the name of your main library in the next menu. Just select it and your main library should open normally. (If the main library isn't listed, use the Other/New... command to find your main library and select it.)

     

    We're just going to have to use this workaround until Apple gives us a permanent fix for this issue.

     

    The new, empty library will be about 6.5MB in size (Really? There's nothing in it!). I created my alternate on the same external hard drive as my main library, but I tried this on the iMac's internal drive and it worked just as well.

  • 10. Re: Aperture 3.3.2 hangs on launch (library issue)
    dbmoore Level 1 Level 1 (105 points)

    Again did you try making a new lib from your Vault???   It helped me so I dont have to use the switch lib trick.

  • 11. Re: Aperture 3.3.2 hangs on launch (library issue)
    Phillip Breske Level 1 Level 1 (60 points)

    I don't have a vault. All of my image files are referenced on an external drive and that drive is backed up with Time Machine.

  • 12. Re: Aperture 3.3.2 hangs on launch (library issue)
    dbmoore Level 1 Level 1 (105 points)

    So you could go back to a previous time machine Lib and copy that to another location on the hard drive and try that.   I dont think apple will come up with a permanet fix for a crupted lib.  My images are referenced also but I use the Vault for a back up of the Data Base/Library.     good luck   cheers

  • 13. Re: Aperture 3.3.2 hangs on launch (library issue)
    @rnopier Level 1 Level 1 (0 points)

    The problem is not crupted lib or not, the problem is why ! And if you make a backup your file is also crupted.

    Here if we can open the lib by a "back trick door" it's because the file or the lib or what you want is not crupted otherwise it's done ! That happen when i upgrade iPhoto and i think the problem come here ! And we are not alone, it's a professional soft we are waiting for a professional answer !

  • 14. Re: Aperture 3.3.2 hangs on launch (library issue)
    Sanjaya Kumar Level 1 Level 1 (10 points)

    Philip,

     

    I have the same problem, but the procedure you outlined didn't work for me. I am able to create a new dummy library (6.5 MB). But then Aperture hangs on opening that library as well. I get the same spinning gears while trying to open the newly created empty library. I am not sure what I should try next.

1 2 3 Previous Next