Skip navigation

Downloaded apps will not finish their installation

7993 Views 13 Replies Latest reply: Jan 25, 2013 3:14 AM by Ah Kenn RSS
nikmyers Calculating status...
Currently Being Moderated
Jul 28, 2012 4:05 AM

I hadn't used the App Store in about a month until yesterday after I installed Mountain Lion, so I can't know for sure whether this would have occured in the month before the upgrade. I cannot get *any* application to install and as soon as one of the apps in question finish downloading a dialog explaining that the app failed to download and to try again from the purchases page (which also doesn't work).


I've restarted, deleted the App Store cache folder, deleted the App Store cookies, and scoured the internet for a solution.


If anyone can figure out where this problem came from I would be extraordinarily grateful.


Screen Shot 2012-07-28 at 6.45.39 AM.png

Screen Shot 2012-07-28 at 6.46.16 AM.png






Message was edited by: nikmyers [Added second screenshot]

  • Carolyn Samit Level 10 Level 10 (84,060 points)
    Currently Being Moderated
    Jul 28, 2012 6:51 AM (in response to nikmyers)

    Try turning off the Firewall in System Preferences > Security  & Privacy > Firewall


    And if you have anti virus software installed, you may need to disable that before downloading apps..



    A side note..   I see you were trying to download CCleaner.


    Third party cleaning utilties are not necessary on Mac and often do more harm than good. Your Mac runs maintenance for you.

  • AStemerman Level 1 Level 1 (0 points)

    Carolyn Samit pretty much nailed it. This is usually caused by a firewall or virus scanning software.

    Next, you can try a hard reboot by unplugging your modem, router and computer.

    If you have neither of this than you should check your ISP connection as some companies don't send a consistant signal making downloads pause constantly.

  • citrus101 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jul 28, 2012 3:47 PM (in response to nikmyers)

    Are you able to deactivate the red error warning in MAS?


    If you are not, try to open MAS > click "Store" in menu bar > reload page


    This fixed this issue in my case. I had to download the app a second time, but then the installation worked as expected.

  • citrus101 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jul 28, 2012 4:27 PM (in response to nikmyers)

    Yes, I had this issue, too. Same story. I had to wait 24 hours, but then it worked again (after reloading the page).


    I downloaded iPhoto and the download finished to 100%, but the installation never started and I saw this red error warning. Wired ... I think it was a corrupt download in my case.


    Probably you have just to wait until the error warning disappears.

  • doug.wp Level 1 Level 1 (0 points)

    I have the same problem as Nik. Reload doesn't work. The firewall is off. I've had the problem with a couple different apps over the last several days -- ever since downloading Mountain Lion.

  • mrhangz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 2:54 AM (in response to nikmyers)

    I got this problem probably by leaving my Mac on idle while downloading.

    I fixed this by running "killall Dock" in the terminal, and re-downloading the apps from purchases page.

    Hope this help.

  • GeekNeck Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2012 5:48 AM (in response to nikmyers)

    I also had this problem, but none of the solutions worked.  I finally resolved the issue by looking in Console, and I found this entry:

    11/21/12 8:13:48.141 AM storeagent[542]: underlyingError Error Domain=NSURLErrorDomain Code=-1100 "The requested URL was not found on this server." UserInfo=0x7fed724f4300 {NSUnderlyingError=0x7fed75394630 "The requested URL was not found on this server.", NSErrorFailingURLStringKey=file:///var/folders/7d/ptxyzbjx29121pm279b9y3vm0000g n/C/, NSErrorFailingURLKey=file:///var/folders/7d/ptxyzbjx29121pm279b9y3vm0000gn/C/co, NSLocalizedDescription=The requested URL was not found on this server.}

    I simply removed the offending file in Terminal thusly:

    mv /var/folders/7d/ptxyzbjx29121pm279b9y3vm0000gn/C/ zps6156376318489886776.pkg ~/.Trash/

    Note that you will need to substitute the file name as it appears in your log.  Also note that "rm <file>" would have also worked, but I wanted to play it safe :-)


    Once the file was gone, I hit the Install button in the App Store app, it re-downloaded and installed just fine.  I hope this works for you!

    MacBook Pro (17-inch Early 2011), Mac OS X (10.7.3), 8 GB RAM
  • Ah Kenn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2013 3:14 AM (in response to nikmyers) loads/


    I had the same problem, read this article and it worked for me. Maybe you could give the delete app store cache thing another go?


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.