2 Replies Latest reply: Aug 1, 2012 4:49 AM by Tony T1
Tony T1 Level 6 Level 6 (8,380 points)

I use a mini for a music server, but ML is putting the mini to sleep in 10 seconds after a WOL.  I've tried using caffeinate via a launch agent, but there is not enough time to run it, and ML sleeps the mini.

 

Any suggestions?  (Energy Saver settings have no effect)

 

(It will be ironic if I have to keep the mini on 24/7 becasuse of this).


MacBook Air, MacBook, Mac mini, OS X Mountain Lion
  • 1. Re: ML Sleep is too aggressive - HELP!
    thermo2 Level 1 Level 1 (5 points)

    I have noticed a possibly related problem since upgrading to ML.  I have programs like SETI at Home that are supposed to be running all the time, but the computer is put to sleep at the time interval in system preferences.  Ironically my problem with Lion was the opposite - it would not go to sleep at the specified time even when nothing was running.  My workaround is to set the computer to never sleep, but it would be nice to know what is going on.

  • 2. Re: ML Sleep is too aggressive - HELP!
    Tony T1 Level 6 Level 6 (8,380 points)

    There may be a solution for your issue.

    Try the following from Terminal:

        caffeinate -i open -W -a SETIatHome.app