10 Replies Latest reply: Jul 31, 2012 4:55 PM by pcarlson
Dr_David Level 1 Level 1 (10 points)

Ever since upgrading to Mountain Lion, I'm having an issue where after the computer wakes from sleep, I get constant beachballing, but ONLY if the wifi is enabled. If I disable wifi, the computer will perform flawlessly. For the sake of completeness, I also have a wired ethernet connection plugged into the computer at the same time that my airport is enabled. This has never (and should never) create an issue. Network priority is given to the ethernet.

 

You can see a video of what it does here:  http://www.youtube.com/watch?v=ts0jRvlfBX0

 

What's odd is that it doesn't actually cause the entire machine to completely freeze, it causes it to freeze one app at a time. And, there's absolutely no way to fix it that I can find, other than by doing a cold restart.

 

I've deleted the airport plist file at /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist and reset the PRAM.

 

I know there were discussions about this before ML was released, and I've filed a radr on it as well; but, I haven't heard anything back from Apple.

 

Does anyone have any insight as to what could be happening and how to resolve this (apart from just leaving my wifi disabled).


MacBook Pro, OS X Mountain Lion
  • 2. Re: Constant beachballing after sleep when WiFi enabled
    Dr_David Level 1 Level 1 (10 points)

    Anyone have an ideas how to fix this bug?

     

    I've tried to remove/add back the Wi-Fi in System Configuration, but that doesn't help.

     

    It seems to be related to deep-sleep. Basically, when the computer goes to sleep and wakes up, you can see the bars of the Airport icon in the menu bar moving for a while; then, it just stops and freezes. Then, the rest of the computer freezes one app at a time.

     

    What's odd is that my wife's MBP is flawless. So, I suspect there's a corrupt plist somewhere..

  • 3. Re: Constant beachballing after sleep when WiFi enabled
    primalman Level 1 Level 1 (5 points)

    How is this helpful to the issue at hand?

  • 4. Re: Constant beachballing after sleep when WiFi enabled
    baltwo Level 9 Level 9 (60,115 points)

    OP claimed:  I'm having an issue where after the computer wakes from sleep, I get constant beachballing.

     

    The response deals with that issue, which is step one. BTW, where's your sage advice?

  • 5. Re: Constant beachballing after sleep when WiFi enabled
    primalman Level 1 Level 1 (5 points)

    Just seems that we all understand what the beachball is representing, yet nothing in the link refers to wifi issues, which is the problem. As well, it seems that he has already gone through several steps. There are many of us with this or a very similar issue and real solutions are not being found. I apologize for seeming seeming terse, but it seemed that the OP understood what the beachball represented.

     

    FYI here is the crossed referenced thread that brought me to this one. Maybe you have some input on this problem?

  • 7. Re: Constant beachballing after sleep when WiFi enabled
    baltwo Level 9 Level 9 (60,115 points)

    No, can't offer anything else, since i never sleep desktops, don't do wifi, and it's not covered in the SBBOD link.

  • 8. Re: Constant beachballing after sleep when WiFi enabled
    pcarlson Level 1 Level 1 (0 points)

    I was having the same problem after installing the upgrade to Mountain Lion and tried every fix I could find online, none of which worked more than a few minutes.  I called Apple support yesterday, even though this iMac is about 18 months old, asking for a waiver on the support fee because I wasn't having the problem before the upgrade.  They granted me the waiver. 

     

    After walking me through most of what I'd already tried, although I hadn't deleted the plist files yet, we got down to the nitty-gritty of the problem.  I was using WEP encryption on our wifi router.  I was told that I would keep having the wifi connectivity problem unless I changed to WPA encryption, and that I should have been having similar problems under Lion, which I wasn't

     

    After hanging up, I changed my wifi encryption to WPA on my PC upstairs, went downstairs to the iMac and relinked to the network, did the same with the iPhones and iPad as well as the Bluray player.  Mind you, I was having no problems with any of those except the Mac.  We are now at 24 hours without a wifi drop.  It was the simplest fix I'd tried.  So if your router is using WEP, try changing it to WPA encryption. I thought I'd have problems with my old HP printer using wifi with my PC upstairs, but it didn't even blink in connecting to the router.  The most difficult to connect - or slowest - was the Bluray player in the family room.

  • 9. Re: Constant beachballing after sleep when WiFi enabled
    Dr_David Level 1 Level 1 (10 points)

    I've only used WPA2. Yet, I get the issues.

     

    But, they were right; you shouldn't use WEP. But, the encryption scheme doesn't have anything to do with the issue IMHO.

  • 10. Re: Constant beachballing after sleep when WiFi enabled
    pcarlson Level 1 Level 1 (0 points)

    Perhaps it shouldn't, but my Mac has not dropped its wifi connection since I made this change.  And I do understand all the issues with WEP but was afraid that my old HP printer would not be able to connect to my desktop using WPA or WPA2, because I'd tried it while setting it up, and it hiccupped and would not connect.  Yesterday it connected easily, for whatever reason.

     

    What I was told is that if I continued to use WEP encryption, the Mac would keep dropping the connection.