Skip navigation

Aperture 3.3.2 hangs on launch (library issue)

6048 Views 70 Replies Latest reply: Oct 10, 2012 1:21 PM by movery RSS
1 2 3 ... 5 Previous Next
Phillip Breske Calculating status...
Currently Being Moderated
Jul 27, 2012 5:00 PM

The hits just keep on comin'! Last week my Aperture library was corrupted and I had to restore some files from a backup and delete some preference files to get it to work again. Now I'm having a new problem....


Aperture 3.3.2 launches and I get the "Opening Aperture library" window, but it never progresses to the usable application. Only a Force Quit allows me to try again. Launching Aperture while pressing the Option key allows me to select a different library (I set up a "dummy" library just for this purpose) and once the application is open, I choose File>Switch to Library>Other/New... and pick the main library, which then opens without further complaint. I can initially choose a dummy file on the same external hard drive as my main library, or I can choose a dummy from the Mac's hard drive—either one allows me to successfuly launch the application and proceed to opening the main library.


If I then quit the application and immediately attempt to re-launch it, the same thing happens again. I need to use the alternate library to launch, then switch from the active application.


I can switch to the alternate before quitting the app and it remembers the alternate library as the new default. It will then launch fine to the new default (alternate) library. At that point I can quickly switch to the main library.


So, I know the problem must be in the main library, but I can't figure out why it will launch successfully only after opening a different library.


I repaired permissions and rebuilt and repaired the database, but none of these seemed to fix the problem I'm having.


Any ideas?

iMac, Mac OS X (10.7.2), 27" iMac Core i7 Quad 12GB
  • Francis Gagnon Calculating status...

    Hi Phillip. Same problem here, although I can quit Aperture when using the menu bar. I also repaired the permissions and the library, and rebuilt the database. I was able to open 3.3.2 for a few days before this problem came up. I installed Moutain Lion, thinking it could be a compatibility problem. No luck. I called Applecare, but I was way past my 90 days of phone support so they sent me to this page on the basics of troubleshooting. I've done everything short of reinstalling Aperture.


    Thanks a lot for sharing your tip of creating a new library - at least it gets me access to my normal library, until the problem is solved.

  • dc cma Calculating status...

    Restored Aperture 3.1.1 from 06.28.12 Time Machine backup ~ Aperture (Original) now working again.. waiting for an Apple tweaka until I go back/forward

  • @rnopier Calculating status...



    I don't know how that is possible but Aperture works again after the same problems we know !

    I made all the things describe above and like every body nothing happen.

    And I try to make a new "library" and import the all one by File>Import>Library ... not enough place (my library is over 350000 pictures ... I was nervous ....) !

    And I I try File>Switch to Library>Other/New ...

    And ... and ... the complete lLibrary appear ! after 2 sad and *.:,,=!¡?¿ days !!!

    Hope that works for you too ...

  • @rnopier Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2012 2:31 AM (in response to @rnopier)

    Ok, now I know how to, because I quit Aperture and that did it again.

    The problem is  the interface of Aperture don't open with the old Library.

    Open Aperture with "option" and choose an old library if you have one, hope you have ...

    This old Library open easy

    And I I try File>Switch to Library>Other/New ...

    And ... and ... the complete lLibrary appear !

  • @rnopier Level 1 Level 1 (0 points)

    It's just a trick please Apple give us a patch to solve that !

  • dbmoore Calculating status...
    Currently Being Moderated
    Jul 30, 2012 8:02 AM (in response to @rnopier)

    I too had a crupted lib file that would not open without using the switch lib trick.  I used my Vault and built a new lib.  Now all is well so far.....

  • Jonathan Hudson Calculating status...

    Same thing happened to me last night. Aperture was running fine. I quit it, then restarted it to do one more thing-- and it is now hanging at "Opening Aperture library." I can't get it to open the library.


    Aperture 3.3.2 on 10.8

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    Jul 30, 2012 12:21 PM (in response to Phillip Breske)

    Again did you try making a new lib from your Vault???   It helped me so I dont have to use the switch lib trick.

  • dbmoore Level 1 Level 1 (95 points)

    So you could go back to a previous time machine Lib and copy that to another location on the hard drive and try that.   I dont think apple will come up with a permanet fix for a crupted lib.  My images are referenced also but I use the Vault for a back up of the Data Base/Library.     good luck   cheers

  • @rnopier Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2012 2:52 PM (in response to dbmoore)

    The problem is not crupted lib or not, the problem is why ! And if you make a backup your file is also crupted.

    Here if we can open the lib by a "back trick door" it's because the file or the lib or what you want is not crupted otherwise it's done ! That happen when i upgrade iPhoto and i think the problem come here ! And we are not alone, it's a professional soft we are waiting for a professional answer !

  • Sanjaya Kumar Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 30, 2012 11:51 PM (in response to Phillip Breske)



    I have the same problem, but the procedure you outlined didn't work for me. I am able to create a new dummy library (6.5 MB). But then Aperture hangs on opening that library as well. I get the same spinning gears while trying to open the newly created empty library. I am not sure what I should try next.

1 2 3 ... 5 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.